質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.70%

kerasでのcnnの実行時のエラー

解決済

回答 2

投稿

  • 評価
  • クリップ 0
  • VIEW 3,738

AnchorBlues

score 16

現在、以下の環境でkerasを動かすことを考えております。

  • Ubuntu16.04
  • GPU GeForce 1070Ti
  • cuda 9.0
  • cudnn v7.1.1 Library for Linux
  • Python3.5(Anaconda)
  • tensorflow  1.6.0
  • keras 2.1.4

基本的な環境構築は、

を元に行いました。

ところが、いざkerasのサンプルコードを走らせてみると、エラーが出てしまいます。

実行したコードはhttps://github.com/keras-team/keras/blob/master/examples/mnist_cnn.py
であり、

出力されたエラーメッセージは以下のとおりです。

2018-03-04 15:35:04.815615: I tensorflow/core/platform/cpu_feature_guard.cc:140] Your CPU supports instructions that this TensorFlow binary was not compiled to use: AVX2 FMA
2018-03-04 15:35:04.932029: I tensorflow/stream_executor/cuda/cuda_gpu_executor.cc:898] successful NUMA node read from SysFS had negative value (-1), but there must be at least one NUMA node, so returning NUMA node zero
2018-03-04 15:35:04.932249: I tensorflow/core/common_runtime/gpu/gpu_device.cc:1212] Found device 0 with properties: 
name: GeForce GTX 1070 Ti major: 6 minor: 1 memoryClockRate(GHz): 1.683
pciBusID: 0000:01:00.0
totalMemory: 7.93GiB freeMemory: 7.60GiB
2018-03-04 15:35:04.932262: I tensorflow/core/common_runtime/gpu/gpu_device.cc:1312] Adding visible gpu devices: 0
2018-03-04 15:35:05.792784: I tensorflow/core/common_runtime/gpu/gpu_device.cc:993] Creating TensorFlow device (/job:localhost/replica:0/task:0/device:GPU:0 with 7344 MB memory) -> physical GPU (device: 0, name: GeForce GTX 1070 Ti, pci bus id: 0000:01:00.0, compute capability: 6.1)
2018-03-04 15:35:07.059592: E tensorflow/stream_executor/cuda/cuda_dnn.cc:378] Loaded runtime CuDNN library: 7101 (compatibility version 7100) but source was compiled with 7004 (compatibility version 7000).  If using a binary install, upgrade your CuDNN library to match.  If building from sources, make sure the library loaded at runtime matches a compatible version specified during compile configuration.
2018-03-04 15:35:07.060155: F tensorflow/core/kernels/conv_ops.cc:717] Check failed: stream->parent()->GetConvolveAlgorithms( conv_parameters.ShouldIncludeWinogradNonfusedAlgo<T>(), &algorithms) 
中止(コアダンプ)

何が問題で、どのようにすれば解決できるのか、どなたかご教授いただけないでしょうか。

よろしくお願いいたします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

check解決した方法

0

自己解決いたしました。
https://developer.nvidia.com/rdp/cudnn-download

イメージ説明

こちらのCuDNNインストール画面で、
当初は

cuDNN v7.1.1 Library for Linux

を選んでおりましたが、こちらをアンインストールして、

cuDNN v7.1.1 Runtime Library for Ubuntu16.04
cuDNN v7.1.1 Developer Library for Ubuntu16.04
cuDNN v7.1.1 Code Samples and User Guide for Ubuntu16.04

からcuDNNをインストールしたら、無事kerasのコードが動きました。

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

0

Loaded runtime CuDNN library: 7101 (compatibility version 7100) but source was compiled with 7004 (compatibility version 7000).

CuDNNのバージョンを合わせてもうまく行きませんか?

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/03/04 20:58

    mkgreiさん

    ご返答ありがとうございます。

    > CuDNNのバージョンを合わせてもうまく行きませんか?

    ここでおっしゃっているCuDNNのバージョンというのは、上記に書いております
    v7.1.1
    のことでしょうか?
    それとも、エラーメッセージにあります、
    CuDNN library
    のバージョンのことでしょうか?

    参考までに申し上げておきますと、cudnnは、
    https://developer.nvidia.com/rdp/cudnn-download
    上記のページにおいて、
    Download cuDNN v7.1.1 (Feb 28, 2018), for CUDA 9.0
    から
    cuDNN v7.1.1 Library for Linux
    を選択してインストールしました。
    CUDAのバージョンと対応したバージョンのCuDNNをインストールしたものと認識していたのですが、そうではなかったのでしょうか。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.70%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る