質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
85.44%
Python

Pythonは、コードの読みやすさが特徴的なプログラミング言語の1つです。 強い型付け、動的型付けに対応しており、後方互換性がないバージョン2系とバージョン3系が使用されています。 商用製品の開発にも無料で使用でき、OSだけでなく仮想環境にも対応。Unicodeによる文字列操作をサポートしているため、日本語処理も標準で可能です。

Q&A

解決済

1回答

684閲覧

pythonのバージョンが上げられません

nifch

総合スコア28

Python

Pythonは、コードの読みやすさが特徴的なプログラミング言語の1つです。 強い型付け、動的型付けに対応しており、後方互換性がないバージョン2系とバージョン3系が使用されています。 商用製品の開発にも無料で使用でき、OSだけでなく仮想環境にも対応。Unicodeによる文字列操作をサポートしているため、日本語処理も標準で可能です。

0グッド

0クリップ

投稿2018/02/27 08:40

前提・実現したいこと

ここに質問の内容を詳しく書いてください。
(例)anacondaで作った仮想環境でpythonを実行しようとするとバージョンが2.7.1
と表示されていました。rootでは最新版がインストールされているにも関わらずです。
そこで conda install python=3.6.4
などでアップデートしようとしたのですが以下のエラーが出ます
どうすれば良いでしょうか

発生している問題・エラーメッセージ

UnsatisfiableError: The following specifications were found to be in conflict:

  • python=3.6
  • ssl_match_hostname -> python[version='>=2.7,<2.8.0a0']

Use "conda info <package>" to see the dependencies for each package.

エラーメッセージ

該当のソースコード

ソースコード

試したこと

ここに問題に対して試したことを記載してください。

補足情報(FW/ツールのバージョンなど)

ここにより詳細な情報を記載してください。

気になる質問をクリップする

クリップした質問は、後からいつでもMYページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

can110

2018/02/27 08:50

実現したいことは「(新たに)3.6の仮想環境を作成」「Anacondaのrootのバージョンを最新(??)から3.6に更新」のどちらでしょうか?
guest

回答1

0

ベストアンサー

これは仮にできたとしてもやめたほうがいいです。Python2.7とPython3.xでは互換性が保たれていない機能が多いので、インストール済みのパッケージが使えなくなります。

無理せず別の仮想環境を作ることをおススメします。
conda create -n py36 python=3.6 anaconda

投稿2018/02/27 08:47

退会済みユーザー

退会済みユーザー

総合スコア0

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

nifch

2018/02/27 08:52

そうなのですか。 新しい仮想環境を作ることにします。 ありがとうございました。
guest

あなたの回答

tips

太字

斜体

打ち消し線

見出し

引用テキストの挿入

コードの挿入

リンクの挿入

リストの挿入

番号リストの挿入

表の挿入

水平線の挿入

プレビュー

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
85.44%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問