質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.21%

PHPで決済機能[Stripe]のライブラリをインストール、updateしたい

受付中

回答 2

投稿

  • 評価
  • クリップ 0
  • VIEW 1,587

shiroshiro

score 6

 前提・実現したいこと

PHPで実装している画面から、Stripeを利用するために、
composerを使ってインストールしようとしていますが、
「composer update」時に、下記のエラーが発生します。

 発生している問題・エラーメッセージ

C:\xampp\htdocs\enis\stripe-php>composer update
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - The requested package stripe/stripe-php No version set (parsed as 1.0.0) is satisfiable by stripe/stripe-php[No version set (parsed as 1.0.0)] but these conflict with your requirements or minimum-stability.
  Problem 2
    - Installation request for satooshi/php-coveralls ~0.6.1 -> satisfiable by satooshi/php-coveralls[v0.6.1].
    - satooshi/php-coveralls v0.6.1 requires ext-curl * -> the requested PHP extension curl is missing from your system.
  Problem 3
    - stripe/stripe-php v6.1.0 requires ext-curl * -> the requested PHP extension curl is missing from your system.
    - stripe/stripe-php v6.0.0 requires ext-curl * -> the requested PHP extension curl is missing from your system.
    - Installation request for stripe/stripe-php 6.* -> satisfiable by stripe/stripe-php[v6.0.0, v6.1.0].

  To enable extensions, verify that they are enabled in your .ini files:
    - C:\xampp\php\php.ini
  You can also run `php --ini` inside terminal to see which files are used by PHP in CLI mode.

 該当のソースコード

{
  "name": "stripe/stripe-php",
  "description": "Stripe PHP Library",
  "keywords": [
    "stripe",
    "payment processing",
    "api"
  ],
  "homepage": "https://stripe.com/",
  "license": "MIT",
  "authors": [
    {
      "name": "Stripe and contributors",
      "homepage": "https://github.com/stripe/stripe-php/contributors"
    }
  ],
  "require": {
    "stripe/stripe-php": "6.*"
  },
  "require-dev": {
    "phpunit/phpunit": "~4.0",
    "satooshi/php-coveralls": "~0.6.1",
    "squizlabs/php_codesniffer": "~2.0"
  },
  "autoload": {
    "psr-4": { "Stripe\\" : "lib/" }
  },
  "extra": {
    "branch-alias": {
      "dev-master": "2.0-dev"
    }
  }
}

 試したこと

ここに問題に対して試したことを記載してください。

 補足情報(FW/ツールのバージョンなど)

最新のPHP用のライブラリをhttps://stripe.com/docs/librariesからダウンロードし、決済画面を実装したphpファイルを保存しているのと同一階層にダウンロードしたフォルダ[stripe-php-6.1.0]をコピーし、フォルダ名を[stripe-php]に変更しています。

Stripeで決済を実行するphpでは、require_once 'vendor/autoload.php';と実装していますが、
該当するライブラリが作成されておらず、エラーが発生します。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

0

公式ページにありますが、composer経由でインストールするのであれば以下コマンドで導入できるのではないでしょうか。

$ composer require stripe/stripe-php

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

0

Curlが無いと言われているので、php.iniファイルにあるextension=php_curl.dllがコメントアウトされているようであれば外してみてください。

C:\xampp\php\php.ini
;extension=php_curl.dllextension=php_curl.dll

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.21%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる