質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.46%

  • Raspberry Pi

    1090questions

    Raspberry Piは、ラズベリーパイ財団が開発した、名刺サイズのLinuxコンピュータです。 学校で基本的なコンピュータ科学の教育を促進することを意図しています。

  • apt-get

    51questions

    apt-getコマンドはUNIX系OSのパッケージのインストールなど、パッケージ管理を行うためのコマンドです。

apt-getを使ったコマンドが全て異常終了する

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 1,267

kota1810

score 2

sudo apt-get upgrade を行うと、以下のようになります。

sudo apt-get upgrade
パッケージリストを読み込んでいます... 完了
依存関係ツリーを作成しています
状態情報を読み取っています... 完了
アップグレードパッケージを検出しています ... 完了
以下のパッケージは保留されます:
  pix-icons pix-plym-splash pixel-wallpaper raspberrypi-ui-mods
以下のパッケージはアップグレードされます:
  bind9-host bluez-firmware cups-bsd cups-client cups-common curl debconf
  firmware-atheros firmware-brcm80211 firmware-libertas firmware-ralink
  firmware-realtek gir1.2-gdkpixbuf-2.0 git git-core git-man gnupg gpgv
  gpicview gtk2-engines-pixbuf libasound2 libasound2-data libavcodec56
  libavformat56 libavresample2 libavutil54 libbind9-90 libc-ares2 libcomerr2
  libcups2 libcupsimage2 libcurl3 libcurl3-gnutls libdns-export100 libdns100
  libdvdnav4 libexpat1 libexpat1-dev libffi6 libgcrypt20 libgd3
  libgdk-pixbuf2.0-0 libgdk-pixbuf2.0-common libgnutls-deb0-28
  libgnutls-openssl27 libgraphite2-3 libgssapi-krb5-2 libgtk2.0-0
  libgtk2.0-bin libgtk2.0-common libicu52 libirs-export91 libisc-export95
  libisc95 libisccc90 libisccfg-export90 libisccfg90 libk5crypto3 libkrb5-3
  libkrb5support0 liblwres90 libnss3 libpoppler46 libraspberrypi-bin
  libraspberrypi-dev libraspberrypi-doc libraspberrypi0 libraw10 libsmbclient
  libsoup-gnome2.4-1 libsoup2.4-1 libss2 libssl1.0.0 libswscale3 libtiff5
  libwbclient0 libwpd-0.10-10 libx11-6 libx11-data libx11-xcb1 libxcursor1
  libxfixes3 libxi6 libxml2 libxrandr2 libxtst6 libxv1 locales lxpanel
  lxpanel-data man-db multiarch-support ncurses-term nodered openssh-client
  openssh-server openssh-sftp-server openssl pi-bluetooth pi-greeter pipanel
  pishutdown poppler-utils python-gpiozero python3-gpiozero
  raspberrypi-bootloader raspberrypi-kernel raspi-config rpi-chromium-mods
  rsync samba-common samba-libs sensible-utils ssh sudo tzdata wget
  wpasupplicant xarchiver
アップグレード: 119 個、新規インストール: 0 個、削除: 0 個、保留: 4 個。
3 個のパッケージが完全にインストールまたは削除されていません。
140 MB 中 2,072 kB のアーカイブを取得する必要があります。
この操作後に追加で 2,798 kB のディスク容量が消費されます。
続行しますか? [Y/n] y
取得:1 http://mirrordirector.raspbian.org/raspbian/ jessie/main curl armhf 7.38.0-4+deb8u9 [196 kB]
取得:2 http://mirrordirector.raspbian.org/raspbian/ jessie/main libcurl3 armhf 7.38.0-4+deb8u9 [232 kB]
取得:3 http://mirrordirector.raspbian.org/raspbian/ jessie/main libcurl3-gnutls armhf 7.38.0-4+deb8u9 [226 kB]
取得:4 http://mirrordirector.raspbian.org/raspbian/ jessie/main libtiff5 armhf 4.0.3-12.3+deb8u5 [203 kB]
取得:5 http://mirrordirector.raspbian.org/raspbian/ jessie/main libpoppler46 armhf 0.26.5-2+deb8u3 [1,094 kB]
取得:6 http://mirrordirector.raspbian.org/raspbian/ jessie/main poppler-utils armhf 0.26.5-2+deb8u3 [123 kB]
2,072 kB を 9秒 で取得しました (222 kB/s)
/bin/sh: 1: /usr/bin/apt-listchanges: not found
パッケージからテンプレートを展開しています: 100%
パッケージを事前設定しています ...
(データベースを読み込んでいます ... 現在 114119 個のファイルとディレクトリがインストールされています。)
.../debconf_1.5.56+deb8u1_all.deb を展開する準備をしています ...
/var/lib/dpkg/info/debconf.prerm: 12: /var/lib/dpkg/info/debconf.prerm: pyclean: not found
dpkg: 警告: サブプロセス 古い pre-removal スクリプト はエラー終了ステータス 127 を返しました
dpkg: 代わりに新規パッケージからスクリプトを実行してみます ...
/var/lib/dpkg/tmp.ci/prerm: 12: /var/lib/dpkg/tmp.ci/prerm: pyclean: not found
dpkg: アーカイブ /var/cache/apt/archives/debconf_1.5.56+deb8u1_all.deb の処理中 にエラーが発生しました (--unpack):
 サブプロセス 新しい pre-removal スクリプト はエラー終了ステータス 127 を返しま した
/var/lib/dpkg/info/debconf.postinst: 75: /var/lib/dpkg/info/debconf.postinst: pycompile: not found
dpkg: クリーンアップ中にエラーが発生しました:
 サブプロセス インストール済みの post-installation スクリプト はエラー終了ステータス 127 を返しました
処理中にエラーが発生しました:
 /var/cache/apt/archives/debconf_1.5.56+deb8u1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


次に、以下のページを参考に sudo apt-get install python-minimal を行ってみました
https://ja.stackoverflow.com/questions/36093/ubuntu16-04%E3%81%A7sudo-apt-get-f-install-%E3%82%B3%E3%83%9E%E3%83%B3%E3%83%89%E3%81%8C%E5%AE%9F%E8%A1%8C%E3%81%A7%E3%81%8D%E3%81%BE%E3%81%9B%E3%82%93

sudo apt-get install python-minimal
パッケージリストを読み込んでいます... 完了
依存関係ツリーを作成しています
状態情報を読み取っています... 完了
python-minimal はすでに最新版です。
提案パッケージ:
  debconf-doc libterm-readline-gnu-perl libgtk2-perl libnet-ldap-perl
  libqtgui4-perl libqtcore4-perl
以下のパッケージはアップグレードされます:
  debconf
アップグレード: 1 個、新規インストール: 0 個、削除: 0 個、保留: 122 個。
3 個のパッケージが完全にインストールまたは削除されていません。
167 kB 中 0 B のアーカイブを取得する必要があります。
この操作後に追加で 0 B のディスク容量が消費されます。
/bin/sh: 1: /usr/bin/apt-listchanges: not found
パッケージを事前設定しています ...
(データベースを読み込んでいます ... 現在 114119 個のファイルとディレクトリがインストールされています。)
.../debconf_1.5.56+deb8u1_all.deb を展開する準備をしています ...
/var/lib/dpkg/info/debconf.prerm: 12: /var/lib/dpkg/info/debconf.prerm: pyclean: not found
dpkg: 警告: サブプロセス 古い pre-removal スクリプト はエラー終了ステータス 127 を返しました
dpkg: 代わりに新規パッケージからスクリプトを実行してみます ...
/var/lib/dpkg/tmp.ci/prerm: 12: /var/lib/dpkg/tmp.ci/prerm: pyclean: not found
dpkg: アーカイブ /var/cache/apt/archives/debconf_1.5.56+deb8u1_all.deb の処理中 にエラーが発生しました (--unpack):
 サブプロセス 新しい pre-removal スクリプト はエラー終了ステータス 127 を返しま した
/var/lib/dpkg/info/debconf.postinst: 75: /var/lib/dpkg/info/debconf.postinst: pycompile: not found
dpkg: クリーンアップ中にエラーが発生しました:
 サブプロセス インストール済みの post-installation スクリプト はエラー終了ステータス 127 を返しました
処理中にエラーが発生しました:
 /var/cache/apt/archives/debconf_1.5.56+deb8u1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

apt-listchangesパッケージは正常にインストールされています。
何が原因でエラーが発生していると思われますか?

Raspberry Pi 3 Model B
OS:Rasbian 8.0

なお、1ヶ月ぶりに起動したため、直前に何を行ったかは覚えていません。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

check解決した方法

+1

諦めてラズパイ再インストールしました。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.46%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る

  • Raspberry Pi

    1090questions

    Raspberry Piは、ラズベリーパイ財団が開発した、名刺サイズのLinuxコンピュータです。 学校で基本的なコンピュータ科学の教育を促進することを意図しています。

  • apt-get

    51questions

    apt-getコマンドはUNIX系OSのパッケージのインストールなど、パッケージ管理を行うためのコマンドです。