質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
85.48%
Oracle

Oracleは、米オラクルが取り扱うリレーショナルデータベース管理システムです。メインフレームからPCまで、多様なプラットフォームに対応しています。

Java

Javaは、1995年にサン・マイクロシステムズが開発したプログラミング言語です。表記法はC言語に似ていますが、既存のプログラミング言語の短所を踏まえていちから設計されており、最初からオブジェクト指向性を備えてデザインされています。セキュリティ面が強力であることや、ネットワーク環境での利用に向いていることが特徴です。Javaで作られたソフトウェアは基本的にいかなるプラットフォームでも作動します。

Ubuntu

Ubuntuは、Debian GNU/Linuxを基盤としたフリーのオペレーティングシステムです。

Q&A

1回答

4148閲覧

Ubuntuで、Oracle-Java8をインストールしようとしたらエラーが出ました

y.fujiwara

総合スコア6

Oracle

Oracleは、米オラクルが取り扱うリレーショナルデータベース管理システムです。メインフレームからPCまで、多様なプラットフォームに対応しています。

Java

Javaは、1995年にサン・マイクロシステムズが開発したプログラミング言語です。表記法はC言語に似ていますが、既存のプログラミング言語の短所を踏まえていちから設計されており、最初からオブジェクト指向性を備えてデザインされています。セキュリティ面が強力であることや、ネットワーク環境での利用に向いていることが特徴です。Javaで作られたソフトウェアは基本的にいかなるプラットフォームでも作動します。

Ubuntu

Ubuntuは、Debian GNU/Linuxを基盤としたフリーのオペレーティングシステムです。

0グッド

0クリップ

投稿2018/01/19 12:46

###前提・実現したいこと
Ubuntuで、Oracle-Java8をインストールしようとしたらエラーが出ました

###発生している問題・エラーメッセージ
下記URLで質問されているように同じエラーがでました。
https://teratail.com/questions/96964

また、同URLのベストアンサーにある手順も試してみましたが、
$ java -versionでバージョンを調べようとすると、
cannot execute binary file: Exec format errorというエラーメッセージがでます。何か他に原因は考えられるでしょうか?

cannot execute binary file: Exec format error

###該当のソースコード

$ sudo mkdir -p /usr/lib/jvm $ cd /usr/lib/jvm $ sudo tar xvfo jdk-8u151-linux-i586.tar.gz $ sudo ln -s jdk1.8.0_151 java-8-oracle-armv7l $ cd $ echo 'export JAVA_HOME=/usr/lib/jvm/java-8-oracle-armv7l' >> .bashrc $ echo 'export PATH=${JAVA_HOME}/bin:${PATH}' >> .bashrc $ java -version

###試したこと
パスの指定も間違っていないです。インストールしたファイルも環境も32bit対応であり問題ないと思います。

###補足情報(言語/FW/ツール等のバージョンなど)
OS: Ubuntu 14.04
インストールファイル:jdk-8u151-linux-i586.tar.gz

気になる質問をクリップする

クリップした質問は、後からいつでもMYページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

KSwordOfHaste

2018/01/19 13:24

一応 uname -a の内容を質問文に補足しておいた方が確実ではないでしょうか?
keicha_hrs

2018/01/19 15:49 編集

恐らく的を射ている回答がすでに出ていますが、動かそうとしているハードウェアがRaspberry Piのような非PCであるならば、それを強調して質問に記さないと適切な回答も出せません。ハードウェアが何も記されなければ回答者も汎用PCであるという「先入観」を持たざるを得ませんから、そこの行き違いで時間をロスするのはとてももったいないことですよね。
guest

回答1

0

$ sudo ln -s jdk1.8.0_151 java-8-oracle-armv7l

Raspberry PiならLinux ARM用のJDKをインストールして下さい。

投稿2018/01/19 13:52

hichon

総合スコア5737

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

あなたの回答

tips

太字

斜体

打ち消し線

見出し

引用テキストの挿入

コードの挿入

リンクの挿入

リストの挿入

番号リストの挿入

表の挿入

水平線の挿入

プレビュー

まだベストアンサーが選ばれていません

会員登録して回答してみよう

アカウントをお持ちの方は

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
85.48%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問