rbenv

RSS
  • 受付中

    回答
    2

    railsを古いバージョンで実行する方法

    前提・実現したいこと railsのバージョンを新しいバージョンから古いバージョンに切り替えたいのですが、 どの様な操作をすればいいのかわかりません。 発生している問題・エラーメッセージ gem list rails を実行した場合、 coffee-rails (4.2.2) rails (5.1.6, 5.1.3) rails-dom-testi

    • 0評価
    • 41PV
    maisumakun maisumakun 21時間前に コメント
  • 解決済

    回答
    1

    ruby-buildでinstallするとエラーが発生する

    Cygwinでrbenvのruby-buildを使いたい rubyの開発環境を作ろうと思いrbenvを使って作ろうと思っています。 rbenv installをしようとしたところ下記のようなエラーが出てうまくいきません どのようにすればよいか教えていただけますでしょうか 発生している問題・エラーメッセージ $ rbenv install -l : 無

    • 0評価
    • 31PV
    reijimatsumura reijimatsumura 1週間前に 質問を編集
  • 受付中

    回答
    0

    capistranoでrailsのデプロイをしたはずがcurrentディレクトリの最新のソースがサイ...

    前提・実現したいこと ruby on railsでwebサイトを作っています。 capistranoで本番環境へのデプロイを自動化しようとしたのですが、 反映がされず(currentディレクトリのファイルではなく、documentroot直下の古いソースコード)前のバージョンのファイルが画面に出力表示されます。 currentディレクトリには最新のソー

    • 0評価
    • 59PV
    teratailが2週間前に アップデート
  • 解決済

    回答
    1

    RubyMineでvagrant上でインストールしたgemを読み込めない

    お世話になります。 RubyMineにてrailsを使った開発を行っているのですが、Vagrant上でrbenvを使いインストールしたgemをダウンロードできず コード保管やリモートデバッグができないので大変困っております。 どなたか解決方法を教えていただけないでしょうか? ちなみに設定は下記の参考サイトの通り実行しました。 参考にしたサイト h

    • 0評価
    • 177PV
    Issei.M Issei.M 3ヶ月前に 回答を編集
  • 解決済

    回答
    1

    rbenv installでエラーがでてしまい、rubyのバージョンを変更することができません

    rbenv installでエラーがでてしまい、rubyのバージョンを変更することができません。 様々なサイトを見てみたのですが解決できずに困っております。 詳しい方いらっしゃいましたらお力を貸していただけると嬉しいです。 -> https://cache.ruby-lang.org/pub/ruby/2.2/ruby-2.2.4.tar.bz2 I

    • 0評価
    • 160PV
    hirahira10 hirahira10 4ヶ月前に コメント
  • 解決済

    回答
    2

    rbenvでのrubyインストールエラー

    rbenvを使って、rubyのインストールをしてたのですが BUILD FAILDエラーが出てインストールが完了しません。。。 原因をネットを使いながら調べたのですが、自力で解決することができませんでした。 -状況- xcodeインストール済み rbenv install -l で2.2.5ダウンドーロ可能か確認済み ・ruby2.2.5を

    • 0評価
    • 264PV
    Yuri0402 Yuri0402 6ヶ月前に ベストアンサー
  • 解決済

    回答
    3

    rbenvのバージョンは2.4.2だが、Rubyのバージョンが更新されない

    MacでRubyのバージョンを2.4.2にアップデートしたいと考えています。 rbenvのバージョンは2.4.2になっていることが確認できたのですが Rubyのバージョンは2.0.0のままとなっております。 $ rbenv versions system * 2.4.2 (set by ~/.ruby-version) $ ruby --vers

    • 0評価
    • 196PV
    knkskmk knkskmk 6ヶ月前に 回答
  • 解決済

    回答
    1

    rails generateで生成したファイルが保存できない

    rails generateで生成したファイルが保存できません。 自分で作成したファイルは保存できます。 ファイルのプロパティを見てみると、所有者がrootになっていました。 概ね下記のサイトのようにインストールしました。 http://dev.classmethod.jp/server-side/language/build-ruby-environm

    • 0評価
    • 123PV
    kosukeKK kosukeKK 7ヶ月前に ベストアンサー
  • 解決済

    回答
    1

    sudoをつけないとrbenvが動かないのを解決したい

    Rubyのバージョンを2.4.0にしたいと思いrbenvでinstallを行なっていたのですが、sudoというものを理解しておらず、気付けばsudoをつけないとrbenvが動かない状態となっていました。 現状は以下のようです。 sudoをつけていない状態 watarasebashi:~ ******$ rbenv global 2.4.0 rbenv:

    • -1評価
    • 226PV
    hatsu hatsu 7ヶ月前に ベストアンサー
  • 解決済

    回答
    1

    仮想環境内で実行されたrails導入スクリプトがうまく走らない

    Vagrant と virtualboxを使って ubuntu16.04 内にrails環境を整え、railsアプリを作成したいと思い、下記のファイルを作成しました。 vagrant up実行後、ターミナルに ==> default: Successfully installed rails-5.1.3 ==> default: 33 gems in

    • 0評価
    • 134PV
    fuzisan fuzisan 8ヶ月前に ベストアンサー
  • 受付中

    回答
    1

    rbenv installできない件について

    ローカル環境でrubyを使いたくrbenvを使ってインストールしたところBUILD FAILEDとなってしまったのでログを見たところ error:1407742E:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version このようなエラーげ出てきました。これについての解説と解決法をご

    • 0評価
    • 159PV
    aizawal-hiroki aizawal-hiroki 8ヶ月前に コメント
  • 1

タグ情報

  • あなたの順位

    -

  • タグ登録者数

    3

  • 総質問数

    11

  • 今週の質問数

    1

関連するタグ

rbenvタグのよく見られている質問

思考するエンジニアのためのQ&Aサイト「teratail」について詳しく知る