質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
86.12%
terminal

Terminalは、Apple社のmacOSに標準で付属しているUNIX端末エミュレータ。UNIXコマンドによってMacの操作および設定を行うことができます。

import

自身のプラットフォーム・プログラム・データセットに対して、外部ソースを取り込むプロセスをimportと呼びます。

Python 3.x

Python 3はPythonプログラミング言語の最新バージョンであり、2008年12月3日にリリースされました。

MacOS(OSX)

MacOSとは、Appleの開発していたGUI(グラフィカルユーザーインターフェース)を採用したオペレーションシステム(OS)です。Macintoshと共に、市場に出てGUIの普及に大きく貢献しました。

解決済

VTKのモジュールをimportしたい

rrhh
rrhh

総合スコア3

terminal

Terminalは、Apple社のmacOSに標準で付属しているUNIX端末エミュレータ。UNIXコマンドによってMacの操作および設定を行うことができます。

import

自身のプラットフォーム・プログラム・データセットに対して、外部ソースを取り込むプロセスをimportと呼びます。

Python 3.x

Python 3はPythonプログラミング言語の最新バージョンであり、2008年12月3日にリリースされました。

MacOS(OSX)

MacOSとは、Appleの開発していたGUI(グラフィカルユーザーインターフェース)を採用したオペレーションシステム(OS)です。Macintoshと共に、市場に出てGUIの普及に大きく貢献しました。

1回答

0グッド

0クリップ

145閲覧

投稿2022/12/08 06:53

前提

macOS Big Sur 11.6
Python 3.11.1
pip 22.3.1

実現したいこと

Calcam(カメラキャリブレーション用のPython package)をターミナルからGUIで起動したい

発生している問題・エラーメッセージ

Calcamをターミナルから実行すると

Could not start calcam GUI: Cannot import VTK python package (error: No module named 'vtkmodules.vtkCommonCore')

というエラーが出てきました。

試したこと

VTKのPython Wrappersというページによると

VTKは100以上の個別モジュールで構成されています。必要なモジュールだけをインポートすることで、プログラムのロード時間を短縮することができます。

しかし、使い始めの頃は、どのモジュールが必要かを知るのは難しいものです。そこで、PythonコンソールでVTKを実験したり、手軽なPythonスクリプトを書いたりする場合、単純にすべてをインポートするのが一番簡単です。これを可能にする'all'という特別なモジュールがあります。

from vtkmodules.all import *

とあったので、Python3をターミナルで起動してこのコードを実行しました。
しかし、

Traceback (most recent call last): File "<stdin>", line 1, in <module> File "/Library/Frameworks/Python.framework/Versions/3.11/lib/python3.11/site-packages/vtkmodules/all.py", line 7, in <module> from .vtkCommonCore import * ModuleNotFoundError: No module named 'vtkmodules.vtkCommonCore'

vtkmodules.vtkCommonCoreというモジュールがないと言われました。
vtkmodules.vtkCommonCoreを入れるにはどうしたらよいでしょうか。よろしくお願いいたします。

以下のような質問にはグッドを送りましょう

  • 質問内容が明確
  • 自分も答えを知りたい
  • 質問者以外のユーザにも役立つ

グッドが多くついた質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

気になる質問をクリップする

クリップした質問は、後からいつでもマイページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

下記のような質問は推奨されていません。

  • 間違っている
  • 質問になっていない投稿
  • スパムや攻撃的な表現を用いた投稿

適切な質問に修正を依頼しましょう。

回答1

0

自己解決

インストールしていたVTK9.2.2がPython 3.11.1に対応していないことが原因でした。ダウングレードしたPython(3.10や3.9)で

import calcam
calcam.start_gui()

を実行したらCalcamをGUIで起動できました。

ただ、ターミナルから

calcam

を実行して直接GUIを起動することはできませんでした。
ひと手間必要みたいです。

投稿2022/12/09 05:27

rrhh

総合スコア3

良いと思った回答にはグッドを送りましょう。
グッドが多くついた回答ほどページの上位に表示されるので、他の人が素晴らしい回答を見つけやすくなります。

下記のような回答は推奨されていません。

  • 間違っている回答
  • 質問の回答になっていない投稿
  • スパムや攻撃的な表現を用いた投稿

このような回答には修正を依頼しましょう。

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
86.12%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問

同じタグがついた質問を見る

terminal

Terminalは、Apple社のmacOSに標準で付属しているUNIX端末エミュレータ。UNIXコマンドによってMacの操作および設定を行うことができます。

import

自身のプラットフォーム・プログラム・データセットに対して、外部ソースを取り込むプロセスをimportと呼びます。

Python 3.x

Python 3はPythonプログラミング言語の最新バージョンであり、2008年12月3日にリリースされました。

MacOS(OSX)

MacOSとは、Appleの開発していたGUI(グラフィカルユーザーインターフェース)を採用したオペレーションシステム(OS)です。Macintoshと共に、市場に出てGUIの普及に大きく貢献しました。