質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
85.46%
Flutter

Flutterは、iOSとAndroidのアプリを同じコードで開発するためのフレームワークです。オープンソースで開発言語はDart。双方のプラットフォームにおける高度な実行パフォーマンスと開発効率を提供することを目的としています。

Android Studio

Android Studioは、 Google社によって開発された、 Androidのネイティブアプリケーション開発に特化した統合開発ツールです。

Dart

Dartは、Googleによって開発されたJavaScriptの代替となることを目的に作られた、ウェブ向けのプログラミング言語である。

Q&A

解決済

1回答

14316閲覧

【Flutter】Dart SDKのバージョン変更をしたい【AndroidStudio】

pcn

総合スコア30

Flutter

Flutterは、iOSとAndroidのアプリを同じコードで開発するためのフレームワークです。オープンソースで開発言語はDart。双方のプラットフォームにおける高度な実行パフォーマンスと開発効率を提供することを目的としています。

Android Studio

Android Studioは、 Google社によって開発された、 Androidのネイティブアプリケーション開発に特化した統合開発ツールです。

Dart

Dartは、Googleによって開発されたJavaScriptの代替となることを目的に作られた、ウェブ向けのプログラミング言語である。

0グッド

0クリップ

投稿2022/01/13 10:25

編集2022/01/23 07:13

AndroidStudioにてDartSDKのバージョン変更の方法を知りたいです。

FlutterでRiverpodを導入しようとしたところ、以下エラーが出てきて先へ進めません。

The current Dart SDK version is 2.13.4. Because riverpod_sample requires SDK version >=2.14.0 <3.0.0, version solving failed. pub get failed (1; Because riverpod_sample requires SDK version >=2.14.0 <3.0.0, version solving failed.)

pubspec.yamlにて、

environment: sdk: ">=2.14.0 <3.0.0"

上記のように変更をしてから「Pub get」を行おうとしても、同様のエラーが出てきて、先へは進めません。

AndroidStudioで進めており、Dart SDKのバージョンは以下の通りです。
イメージ説明

Dart SDKのバージョンを変更したいのですが、変更方法がわからないため、教えていただきたいです。
以下リンクの内容も試してみましたが、「2.14.0」への変更ができませんでした。
https://dart.dev/get-dart

「flutter upgrade」を行っても、DartSDKのバージョンは更新されませんでした。

どのようにしたら良いでしょうか?
よろしくお願いいたします。

気になる質問をクリップする

クリップした質問は、後からいつでもMYページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

guest

回答1

0

自己解決

FlutterSDKを再度ダウンロードし、既存フォルダに上書きするだけで解決しました。
https://docs.flutter.dev/get-started/install/macos

投稿2022/01/26 07:03

pcn

総合スコア30

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

あなたの回答

tips

太字

斜体

打ち消し線

見出し

引用テキストの挿入

コードの挿入

リンクの挿入

リストの挿入

番号リストの挿入

表の挿入

水平線の挿入

プレビュー

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
85.46%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問