質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
87.20%
composer

Composerとは、PHP5.3.2以上で使用可能なパッケージ管理ツールです。指定ディレクトリ内だけでパッケージ管理します。

受付中

comporser  エラーコード通りバージョンを合わせても同じエラーが出る原因が知りたい

samidare_chan
samidare_chan

総合スコア142

composer

Composerとは、PHP5.3.2以上で使用可能なパッケージ管理ツールです。指定ディレクトリ内だけでパッケージ管理します。

1回答

-3評価

0クリップ

603閲覧

投稿2022/03/13 03:11

編集2022/03/14 01:29

提示コードですが以下のコンソールのエラーの対処方法がわかりません。エラコードrequires nesbot/carbon 2.0.0-beta.2 as 1.25.0 にあるとおり1.25.0にバージョンを合わせたのですが同じエラー出ます。原因がわかりません。
ルートcomposer.jsonにはkylekatarnls/laravel-carbon-20.1.0が必要ですとありますがそれは既にjsonファイルに追加済みですなぜでしょうか?また"nesbot/carbon": "2.0.0-beta.2"としてみましたが別のエラー出ますがこれは正しいのでしょうか?

参考サイト:https://packagist.org/packages/nesbot/carbon#1.25.0
参考サイト:https://packagist.org/packages/kylekatarnls/laravel-carbon-2#0.1.0

json

{ "config": { "platform-check": false, "platform": { "php": "7.1.8" }, "allow-plugins": { "kylekatarnls/update-helper": true } }, "require": { "nesbot/carbon": "1.25.0", "kylekatarnls/laravel-carbon-2": "0.1.0", "michelf/php-markdown": "1.9.1", "ramsey/uuid": "3.9.6", "laravel/laravel": "5.5.28" }, "require-dev": { "composer/composer": "^2.2" } }
日本語訳
問題1 -ルートcomposer.jsonにはkylekatarnls/laravel-carbon-20.1.0が必要です->kylekatarnls/laravel-carbon-2[0.1.0]で満足できます。 --kylekatarnls /laravel-carbon-20.1.0では1.25.0としてnesbot/carbon2.0.0-beta.2が必要です->nesbot/ carbon [2.0.0-beta.2]が見つかりましたが、最小安定性と一致しません 。 オプション--with-all-dependencies(-W)を使用して、現在特定のバージョンにロックされているパッケージのアップグレード、ダウングレード、および削除を許可します。
shigurechan@shigurechan-System-Product-Name:~/prg/html/vendor/bin$ composer -W update No composer.json in current directory, do you want to use the one at /home/shigurechan/prg/html? [Y,n]? Y Always want to use the parent dir? Use "composer config --global use-parent-dir true" to change the default. Composer is operating significantly slower than normal because you do not have the PHP curl extension enabled. Loading composer repositories with package information Updating dependencies Your requirements could not be resolved to an installable set of packages. Problem 1 - Root composer.json requires kylekatarnls/laravel-carbon-2 0.1.0 -> satisfiable by kylekatarnls/laravel-carbon-2[0.1.0]. - kylekatarnls/laravel-carbon-2 0.1.0 requires nesbot/carbon 2.0.0-beta.2 as 1.25.0 -> found nesbot/carbon[2.0.0-beta.2] but it does not match your minimum-stability. Use the option --with-all-dependencies (-W) to allow upgrades, downgrades and removals for packages currently locked to specific versions. shigurechan@shigurechan-System-Product-Name:~/prg/html/vendor/bin$
"nesbot/carbon": "2.0.0-beta.2"
shigurechan@shigurechan-System-Product-Name:~/prg/html/vendor/bin$ composer update No composer.json in current directory, do you want to use the one at /home/shigurechan/prg/html? [Y,n]? Y Always want to use the parent dir? Use "composer config --global use-parent-dir true" to change the default. Composer is operating significantly slower than normal because you do not have the PHP curl extension enabled. Loading composer repositories with package information Updating dependencies Your requirements could not be resolved to an installable set of packages. Problem 1 - laravel/framework[v5.5.0, ..., v5.5.38] require nesbot/carbon ~1.20 -> found nesbot/carbon[1.20.0, ..., 1.39.1] but it conflicts with your root composer.json require (2.0.0-beta.2). - laravel/framework[v5.5.39, ..., v5.5.44] require nesbot/carbon ^1.24.1 -> found nesbot/carbon[1.24.1, ..., 1.39.1] but it conflicts with your root composer.json require (2.0.0-beta.2). - laravel/framework[v5.5.45, ..., v5.5.50] require nesbot/carbon ^1.26.0 -> found nesbot/carbon[1.26.0, ..., 1.39.1] but it conflicts with your root composer.json require (2.0.0-beta.2). - laravel/laravel v5.5.28 requires laravel/framework 5.5.* -> satisfiable by laravel/framework[v5.5.0, ..., v5.5.50]. - Root composer.json requires laravel/laravel 5.5.28 -> satisfiable by laravel/laravel[v5.5.28]. Use the option --with-all-dependencies (-W) to allow upgrades, downgrades and removals for packages currently locked to specific versions.

良い質問の評価を上げる

以下のような質問は評価を上げましょう

  • 質問内容が明確
  • 自分も答えを知りたい
  • 質問者以外のユーザにも役立つ

評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

気になる質問をクリップする

クリップした質問は、後からいつでもマイページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

  • プログラミングに関係のない質問
  • やってほしいことだけを記載した丸投げの質問
  • 問題・課題が含まれていない質問
  • 意図的に内容が抹消された質問
  • 過去に投稿した質問と同じ内容の質問
  • 広告と受け取られるような投稿

評価を下げると、トップページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

m.ts10806

2022/03/13 03:17

エラーに書いてあります。
m.ts10806

2022/03/13 03:18

読まないならプログラミングやる資格はありません。全部業者に任せてください。
samidare_chan

2022/03/13 03:40

質問ですがどこに書いてあるのでしょうか?
m.ts10806

2022/03/13 04:25

エラーに書いてあります。 質問からは読んだ感が全くない エラーから考察した感もない
ganbaritaiX

2022/03/13 16:29

読まないならプログラミングやる資格はありません。

まだ回答がついていません

会員登録して回答してみよう

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
87.20%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問

同じタグがついた質問を見る

composer

Composerとは、PHP5.3.2以上で使用可能なパッケージ管理ツールです。指定ディレクトリ内だけでパッケージ管理します。