質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
86.12%
Laravel

LaravelとはTaylor Otwellによって開発された、オープンソースなPHPフレームワークです。Laravelはシンプルで表現的なシンタックスを持ち合わせており、ウェブアプリケーション開発の手助けをしてくれます。

composer

Composerとは、PHP5.3.2以上で使用可能なパッケージ管理ツールです。指定ディレクトリ内だけでパッケージ管理します。

解決済

laravel duskインストール時にエラーが発生する

mtest10811020
mtest10811020

総合スコア44

Laravel

LaravelとはTaylor Otwellによって開発された、オープンソースなPHPフレームワークです。Laravelはシンプルで表現的なシンタックスを持ち合わせており、ウェブアプリケーション開発の手助けをしてくれます。

composer

Composerとは、PHP5.3.2以上で使用可能なパッケージ管理ツールです。指定ディレクトリ内だけでパッケージ管理します。

1回答

0グッド

0クリップ

593閲覧

投稿2022/08/25 02:13

編集2022/08/25 02:16

前提

laravel duskをインストールしようとするとエラーになりました。対処方法などありましたがご教授いただけると助かります。Laravel Framework 9.26.1

composer require --dev laravel/dusk

※stack over flowでも同じ質問をしています。
https://ja.stackoverflow.com/questions/90742/laravel-dusk%e3%82%a4%e3%83%b3%e3%82%b9%e3%83%88%e3%83%bc%e3%83%ab%e6%99%82%e3%81%ab%e3%82%a8%e3%83%a9%e3%83%bc%e3%81%8c%e7%99%ba%e7%94%9f%e3%81%99%e3%82%8b

発生している問題・エラーメッセージ

Your requirements could not be resolved to an installable set of packages. Problem 1 - laravel/dusk[v5.0.0, ..., v5.0.2] require illuminate/console ~5.7.0|~5.8.0 -> found illuminate/console[v5.7.0, ..., 5.8.x-dev] but these were not loaded, likely because it conflicts with another require. - laravel/dusk v5.0.3 requires illuminate/console ~5.7.0|~5.8.0|~5.9.0 -> found illuminate/console[v5.7.0, ..., 5.8.x-dev] but these were not loaded, likely because it conflicts with another require. - laravel/dusk[5.0.x-dev, ..., v5.11.0] require ext-zip * -> it is missing from your system. Install or enable PHP's zip extension. - Root composer.json requires laravel/dusk ^5.0 -> satisfiable by laravel/dusk[v5.0.0, ..., v5.11.0]. To enable extensions, verify that they are enabled in your .ini files: - /usr/local/etc/php/php.ini - /usr/local/etc/php/conf.d/docker-php-ext-pdo_mysql.ini - /usr/local/etc/php/conf.d/docker-php-ext-sodium.ini - /usr/local/etc/php/conf.d/xdebug.ini You can also run `php --ini` in a terminal to see which files are used by PHP in CLI mode. Alternatively, you can run Composer with `--ignore-platform-req=ext-zip` to temporarily ignore these required extensions. You can also try re-running composer require with an explicit version constraint, e.g. "composer require laravel/dusk:*" to figure out if any version is installable, or "composer require laravel/dusk:^2.1" if you know which you need. Installation failed, reverting ./composer.json and ./composer.lock to their original content.

補足情報(FW/ツールのバージョンなど)

composer.json

1{ 2 "name": "laravel/laravel", 3 "type": "project", 4 "description": "The Laravel Framework.", 5 "keywords": ["framework", "laravel"], 6 "license": "MIT", 7 "require": { 8 "php": "^8.0.2", 9 "guzzlehttp/guzzle": "^7.2", 10 "inertiajs/inertia-laravel": "^0.5.4", 11 "laravel/framework": "^9.19", 12 "laravel/sanctum": "^2.8", 13 "laravel/tinker": "^2.7", 14 "tightenco/ziggy": "^1.0" 15 }, 16 "require-dev": { 17 "barryvdh/laravel-ide-helper": "^2.12", 18 "fakerphp/faker": "^1.9.1", 19 "laravel/breeze": "^1.11", 20 "laravel/pint": "^1.0", 21 "laravel/sail": "^1.0.1", 22 "mockery/mockery": "^1.4.4", 23 "nunomaduro/collision": "^6.1", 24 "phpunit/phpunit": "^9.5.10", 25 "spatie/laravel-ignition": "^1.0", 26 "squizlabs/php_codesniffer": "^3.7" 27 }, 28 "autoload": { 29 "psr-4": { 30 "App\\": "app/", 31 "Database\\Factories\\": "database/factories/", 32 "Database\\Seeders\\": "database/seeders/" 33 } 34 }, 35 "autoload-dev": { 36 "psr-4": { 37 "Tests\\": "tests/" 38 } 39 }, 40 "scripts": { 41 "post-autoload-dump": [ 42 "Illuminate\\Foundation\\ComposerScripts::postAutoloadDump", 43 "@php artisan package:discover --ansi" 44 ], 45 "post-update-cmd": [ 46 "@php artisan vendor:publish --tag=laravel-assets --ansi --force" 47 ], 48 "post-root-package-install": [ 49 "@php -r \"file_exists('.env') || copy('.env.example', '.env');\"" 50 ], 51 "post-create-project-cmd": [ 52 "@php artisan key:generate --ansi" 53 ] 54 }, 55 "extra": { 56 "laravel": { 57 "dont-discover": [] 58 } 59 }, 60 "config": { 61 "optimize-autoloader": true, 62 "preferred-install": "dist", 63 "sort-packages": true, 64 "allow-plugins": { 65 "pestphp/pest-plugin": true 66 } 67 }, 68 "minimum-stability": "dev", 69 "prefer-stable": true 70} 71

以下のような質問にはグッドを送りましょう

  • 質問内容が明確
  • 自分も答えを知りたい
  • 質問者以外のユーザにも役立つ

グッドが多くついた質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

気になる質問をクリップする

クリップした質問は、後からいつでもマイページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

下記のような質問は推奨されていません。

  • 間違っている
  • 質問になっていない投稿
  • スパムや攻撃的な表現を用いた投稿

適切な質問に修正を依頼しましょう。

回答1

0

自己解決

環境構築をdockerで行っていたのですが、dockerfileに下記を記載して、laravel duskをインストールしたところうまくいきました。

RUN apt-get update RUN apt-get -y install libzip-dev RUN docker-php-ext-install zip

投稿2022/08/25 05:49

mtest10811020

総合スコア44

良いと思った回答にはグッドを送りましょう。
グッドが多くついた回答ほどページの上位に表示されるので、他の人が素晴らしい回答を見つけやすくなります。

下記のような回答は推奨されていません。

  • 間違っている回答
  • 質問の回答になっていない投稿
  • スパムや攻撃的な表現を用いた投稿

このような回答には修正を依頼しましょう。

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
86.12%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問

同じタグがついた質問を見る

Laravel

LaravelとはTaylor Otwellによって開発された、オープンソースなPHPフレームワークです。Laravelはシンプルで表現的なシンタックスを持ち合わせており、ウェブアプリケーション開発の手助けをしてくれます。

composer

Composerとは、PHP5.3.2以上で使用可能なパッケージ管理ツールです。指定ディレクトリ内だけでパッケージ管理します。