質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
85.42%
MySQL Workbench

MySQL Workbenchは、オープンソースのデータベースモデリングツールです。ビジュアルなデータベース設計・SQL開発・サーバー設定・ユーザー管理・バックアップといった様々な管理ツールを備えます。

MySQL

MySQL(マイエスキューエル)は、TCX DataKonsultAB社などが開発するRDBMS(リレーショナルデータベースの管理システム)です。世界で最も人気の高いシステムで、オープンソースで開発されています。MySQLデータベースサーバは、高速性と信頼性があり、Linux、UNIX、Windowsなどの複数のプラットフォームで動作することができます。

Q&A

2回答

212閲覧

MySQL Workbench(Mac)の使い方について

hanamin

総合スコア3

MySQL Workbench

MySQL Workbenchは、オープンソースのデータベースモデリングツールです。ビジュアルなデータベース設計・SQL開発・サーバー設定・ユーザー管理・バックアップといった様々な管理ツールを備えます。

MySQL

MySQL(マイエスキューエル)は、TCX DataKonsultAB社などが開発するRDBMS(リレーショナルデータベースの管理システム)です。世界で最も人気の高いシステムで、オープンソースで開発されています。MySQLデータベースサーバは、高速性と信頼性があり、Linux、UNIX、Windowsなどの複数のプラットフォームで動作することができます。

0グッド

0クリップ

投稿2024/05/30 08:19

編集2024/05/30 08:20

実現したいこと

先ほど、下記の質問をさせていただき解決後、MySQL Workbenchの使い方をもとに、MySQL Workbenchを開いたのですが、
warningが再び出たため、進めてよいか質問しました。

先ほどの質問:
https://teratail.com/questions/m0gca5ef5zegry
(MySQL Workbenchのバージョンに対応しておらずインストールできない)

補足:
MySQL 8.3.0をインストール(最新バージョンだとインストールできなかったため)

発生している問題・分からないこと

以下の通知が出ますが、continue anywayを押して使い続けても問題ないでしょうか。
→continue anywayを押すと、パスワードは求められませんでした。

もしくは、version 6.3.で再インストールすべきでしょうか。
(仕事ではなく、勉強として使います)

Connection Warning (localhost)
Incompatible/nonstandard server version or connection protocol detected (8.3.0).

A connection to this database can be established but some MySQL Workbench features may not work properly since the database is not fully compatible with the supported versions of MySQL.

MySQL Workbench is developed and tested for MySQL Server versions 5.6, 5.7 and 8.0.
For MySQL Server older than 5.6, please use MySQL Workbench version 6.3.

該当のソースコード

特になし

試したこと・調べたこと

  • teratailやGoogle等で検索した
  • ソースコードを自分なりに変更した
  • 知人に聞いた
  • その他
上記の詳細・結果

次に進んで良いかわかりません。

補足

特になし

気になる質問をクリップする

クリップした質問は、後からいつでもMYページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

guest

回答2

0

仕事ではなく、勉強として使います

「Workbenchそのものについて究めなければならない」なんてことは通常考えられませんので、やるべきことはMySQLの学習かと思われます。

他の方も触れられているように、(古いバージョンで作られたプログラムへの対応などの事情があるならともかく)「Workbenchが合わないから」MySQLのバージョンを落とすのは本末転倒です。

対応としては、

  • 最新版のWorkbenchを動かせるようにOSなどを含めた環境を更新する
  • Workbench自体に見切りをつけて、別なツールでMySQLにアクセスする

のどちらかかと思います。

投稿2024/05/31 01:02

maisumakun

総合スコア145525

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

0

MySQL Workbench version 6.3を使いたいからといって、あからさまに古いMySQL5.6なんて今から使わない方が良いですよ。今から勉強するならMySQL8.0系か最新のMySQL8.3系か8.4系を使うべきですし、それに対応したMySQL Workbenchを入れればいいです。Warning出るくらいは別に気にしなくて良いですし(一応、中身を読んで問題ないかはネットでざっくり調べる)、どうしてもWarningが気になるならMacOSのバージョンを上げるなりして対応しましょう。

追記)
maisumakunさんの意見を見て追記します。私も普段はMacを使用していますが、MySQL Workbenchは使わずにSequel Aceというアプリを使っています。Mac App Storeで無料で使えるものです。MySQL Workbenchほど機能があるわけでもないですが、最低限のことはできます。MySQLのバージョンに関しては8.0系を主に使ってますが、おそらく8.3系でも使えるんじゃないでしょうか。

投稿2024/05/30 11:29

編集2024/05/31 02:10
AbeTakashi

総合スコア4719

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

あなたの回答

tips

太字

斜体

打ち消し線

見出し

引用テキストの挿入

コードの挿入

リンクの挿入

リストの挿入

番号リストの挿入

表の挿入

水平線の挿入

プレビュー

まだベストアンサーが選ばれていません

会員登録して回答してみよう

アカウントをお持ちの方は

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
85.42%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問