質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
85.42%
MySQL Workbench

MySQL Workbenchは、オープンソースのデータベースモデリングツールです。ビジュアルなデータベース設計・SQL開発・サーバー設定・ユーザー管理・バックアップといった様々な管理ツールを備えます。

MySQL

MySQL(マイエスキューエル)は、TCX DataKonsultAB社などが開発するRDBMS(リレーショナルデータベースの管理システム)です。世界で最も人気の高いシステムで、オープンソースで開発されています。MySQLデータベースサーバは、高速性と信頼性があり、Linux、UNIX、Windowsなどの複数のプラットフォームで動作することができます。

SQL

SQL(Structured Query Language)は、リレーショナルデータベース管理システム (RDBMS)のデータベース言語です。大きく分けて、データ定義言語(DDL)、データ操作言語(DML)、データ制御言語(DCL)の3つで構成されており、プログラム上でSQL文を生成して、RDBMSに命令を出し、RDBに必要なデータを格納できます。また、格納したデータを引き出すことも可能です。

Q&A

解決済

1回答

243閲覧

MySQL Workbenchのバージョンに対応しておらずインストールできない

hanamin

総合スコア3

MySQL Workbench

MySQL Workbenchは、オープンソースのデータベースモデリングツールです。ビジュアルなデータベース設計・SQL開発・サーバー設定・ユーザー管理・バックアップといった様々な管理ツールを備えます。

MySQL

MySQL(マイエスキューエル)は、TCX DataKonsultAB社などが開発するRDBMS(リレーショナルデータベースの管理システム)です。世界で最も人気の高いシステムで、オープンソースで開発されています。MySQLデータベースサーバは、高速性と信頼性があり、Linux、UNIX、Windowsなどの複数のプラットフォームで動作することができます。

SQL

SQL(Structured Query Language)は、リレーショナルデータベース管理システム (RDBMS)のデータベース言語です。大きく分けて、データ定義言語(DDL)、データ操作言語(DML)、データ制御言語(DCL)の3つで構成されており、プログラム上でSQL文を生成して、RDBMSに命令を出し、RDBに必要なデータを格納できます。また、格納したデータを引き出すことも可能です。

0グッド

0クリップ

投稿2024/05/30 04:54

実現したいこと

MySQL Workbenchをインストールしたい

発生している問題・分からないこと

経緯:
mac os monterey バージョン 12.7を使用しており、
ターミナルからMysqlをインストールしました。
そして、MySQL Workbenchのx86_64bitをダウンロードし、アプリケーションに移動させようとすると、バージョンに対応しておらずインストールできません。

uname -m で確認しても、x86_64でした。

エラーメッセージ

error

1macOS 12.7.5を使用しています。このアプリケーションを使用するにはmacOS 13.0以降が必要です。

該当のソースコード

特になし

試したこと・調べたこと

  • teratailやGoogle等で検索した
  • ソースコードを自分なりに変更した
  • 知人に聞いた
  • その他
上記の詳細・結果

https://terakoya.sejuku.net/question/detail/36945
上記の記事で、macOS, MySQL, MySQL Workbench のバージョンを揃えるのが良いと理解しましたが、どれに揃えたら良いか。もしくは他に解決方法があるのかがわからないです。

補足

特になし

気になる質問をクリップする

クリップした質問は、後からいつでもMYページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

symfo

2024/05/30 05:22

>このアプリケーションを使用するにはmacOS 13.0以降が必要です。
dodox86

2024/05/30 05:39

MacBookの機種の関係でOSのアップデートができない場合、MySQLの公式のダウンロードサイトで、アーカイブのページから古いバージョンをダウンロードしてインストールするのもひとつの手です。 https://downloads.mysql.com/archives/workbench/ 8.0.34 だと「Packages for Ventura (13) are compatible with Monterey (12)」とのことなので、使えるのではないでしょうか。(8.0.35は未リリースとのこと) ※もし解決できたとしたら、ご自身で対応した方法を投稿して「自己解決」で閉じてください。
maisumakun

2024/05/30 05:54

「どうしてもMySQL Workbenchでなければならない理由がある」状況でしょうか?それとも、「MySQLを操作できるツールなら他のものでもいい」のでしょうか?
logres_Fan

2024/05/30 06:48

エラーメッセージで指摘されているように、バージョンアップすればいいんじゃないの?出来ない場合、新しいMacを購入しましょう。
hanamin

2024/05/30 06:54

dodox86様 ありがとうございます!8.3.2でインストールできました(それまでの最新バージョンは、x86,ARMの選択肢がないバージョンだとひらけました) 大変助かりました。
hanamin

2024/05/30 06:55

maisumakun様 ご提案ありがとうございます。現在学習しているサイトで、MySQL Workbenchを使用していたのと、今後同じエラーが出た際の対処法を知りたく。質問いたしました。 他のツールでも可能なのも知れてよかったです。
guest

回答1

0

自己解決

8.3.2でインストールし、解決いたしました。(dodox86様ご提案)

投稿2024/05/30 06:58

hanamin

総合スコア3

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

dodox86

2024/05/31 00:50

> 8.3.2でインストールし、解決いたしました。(dodox86様ご提案) ? "8.3.2" とは何の製品のバージョン番号でしょうか。MySQL Workbenchにはそういう番号のものは無いし、MySQLのデータベースそのものにも見当たらないようです。 MySQL の8.3は、"8.3.0"が最新かと。 https://dev.mysql.com/doc/relnotes/mysql/8.3/en/news-8-3-0.html
guest

あなたの回答

tips

太字

斜体

打ち消し線

見出し

引用テキストの挿入

コードの挿入

リンクの挿入

リストの挿入

番号リストの挿入

表の挿入

水平線の挿入

プレビュー

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
85.42%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問