質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
87.20%
Ruby on Rails

Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

受付中

bundle install、update時のエラー対応について

Sayre
Sayre

総合スコア20

Ruby on Rails

Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

1回答

0評価

0クリップ

313閲覧

投稿2022/04/19 09:27

編集2022/04/21 10:56

前提

bundle install時にエラーが発生しました。
使用しているRubyのバージョン 2.4.1p111を使用しています。
Rubyのバージョンがかなり古いかと思いますが、諸事情でバージョンはあまり変えたくありません。
Gemfileは以下になります。文字数制限の関係上、エラーが出てバージョン変更した部分周辺の抜粋になります。

Gemfile

# frozen_string_literal: true source 'https://rubygems.org' #gem 'rails', '~> 6.1.4.6' gem 'rails', '~> 4.2', '>= 4.2.11.1' gem 'bootsnap', '~> 1.9.1', require: false # OS detection for usage ping #gem 'ohai', '~> 16.10' gem 'ohai', '~> 14.15' # Markdown and HTML processing gem 'html-pipeline', '~> 2.13.2' gem 'deckar01-task_list', '2.3.1' gem 'gitlab-markup', '~> 1.8.0' gem 'github-markup', '~> 1.7.0', require: 'github/markup' gem 'commonmarker', '~> 0.23.4' gem 'kramdown', '~> 2.3.1' gem 'RedCloth', '~> 4.3.2' gem 'rdoc', '~> 6.3.2' gem 'org-ruby', '~> 0.9.12' gem 'creole', '~> 0.5.0' gem 'wikicloth', '0.8.1' gem 'asciidoctor', '~> 2.0.10' gem 'asciidoctor-include-ext', '~> 0.3.1', require: false gem 'asciidoctor-plantuml', '~> 0.0.12' gem 'asciidoctor-kroki', '~> 0.5.0', require: false gem 'rouge', '~> 3.27.0' gem 'truncato', '~> 0.7.11' gem 'bootstrap_form', '~> 4.2.0' #gem 'nokogiri', '~> 1.12' gem 'nokogiri', '~> 1.10', '>= 1.10.10' gem 'escape_utils', '~> 1.1' # Background jobs #gem 'sidekiq', '~> 6.4' gem 'sidekiq', '~> 5.2', '>= 5.2.10' gem 'sidekiq-cron', '~> 1.2' gem 'redis-namespace', '~> 1.8.1' gem 'gitlab-sidekiq-fetcher', '0.8.0', require: 'sidekiq-reliable-fetch' # Metrics gem 'method_source', '~> 1.0', require: false gem 'webrick', '~> 1.6.1', require: false #gem 'webrick', '~> 1.7', require: false gem 'prometheus-client-mmap', '~> 0.15.0', require: 'prometheus/client' gem 'warning', '~> 1.2.0' group :test do gem 'fuubar', '~> 2.2.0' gem 'rspec-retry', '~> 0.6.1' gem 'rspec_profiling', '~> 0.0.6' gem 'rspec-benchmark', '~> 0.6.0' gem 'rspec-parameterized', require: false # gem 'capybara', '~> 3.35.3' gem 'capybara', '~> 3.32', '>= 3.32.2' gem 'capybara-screenshot', '~> 1.0.22' gem 'selenium-webdriver', '~> 3.142' gem 'shoulda-matchers', '~> 4.0.1', require: false gem 'email_spec', '~> 2.2.0' gem 'webmock', '~> 3.9.1' gem 'rails-controller-testing' gem 'concurrent-ruby', '~> 1.1' gem 'test-prof', '~> 1.0.7' gem 'rspec_junit_formatter' gem 'guard-rspec'

発生している問題・エラーメッセージ

bundle install時に以下エラーが発生。

bundle install Don't run Bundler as root. Bundler can ask for sudo if it is needed, and installing your bundle as root will break this application for all non-root users on this machine. Fetching source index from https://rubygems.org/ Resolving dependencies......................................................................................................................................................................................... Bundler found conflicting requirements for the Ruby version: In Gemfile: rails (~> 6.1.4.6) was resolved to 6.1.4.6, which depends on Ruby (>= 2.5.0) bootsnap (~> 1.9.1) was resolved to 1.9.1, which depends on Ruby (>= 2.3.0) responders (~> 3.0) was resolved to 3.0.0, which depends on Ruby (>= 2.4.0) sprockets (~> 3.7.0) was resolved to 3.7.2, which depends on Ruby (>= 1.9.3) pg (~> 1.1) was resolved to 1.2.3, which depends on Ruby (>= 2.2) devise (~> 4.7.2) was resolved to 4.7.3, which depends on Ruby (>= 2.1.0) ruby-saml (~> 1.13.0) was resolved to 1.13.0, which depends on Ruby (>= 1.8.7) attr_encrypted (~> 3.1.0) was resolved to 3.1.0, which depends on Ruby (>= 2.0.0) ohai (~> 16.10) was resolved to 16.10.6, which depends on Ruby (>= 2.6) commonmarker (~> 0.23.4) was resolved to 0.23.4, which depends on Ruby (>= 2.6, < 4.0) bootstrap_form (~> 4.2.0) was resolved to 4.2.0, which depends on Ruby (>= 2.2.2) icalendar was resolved to 2.4.1, which depends on Ruby (>= 1.9.2) asana (~> 0.10.3) was resolved to 0.10.3, which depends on Ruby (> 2.0) licensee (~> 9.14.1) was resolved to 9.14.1, which depends on Ruby (> 2.3) tanuki_emoji (~> 0.6) was resolved to 0.6.0, which depends on Ruby (>= 2.7.0) ruby_parser (~> 3.15) was resolved to 3.15.0, which depends on Ruby (>= 2.1, < 3.1) thin (~> 1.8.0) was resolved to 1.8.0, which depends on Ruby (>= 1.8.5) pry-rails (~> 0.3.9) was resolved to 0.3.9, which depends on Ruby (>= 1.9.1) gitlab-license_finder (~> 6.0) was resolved to 6.14.2.1, which depends on Ruby (>= 2.3.3) asana (~> 0.10.3) was resolved to 0.10.3, which depends on oauth2 (~> 1.4) was resolved to 1.4.7, which depends on Ruby (>= 1.9.0) yajl-ruby (~> 1.4.1) was resolved to 1.4.1, which depends on Ruby (>= 1.8.6) graphql-docs (~> 1.6.0) was resolved to 1.6.0, which depends on gemoji (~> 3.0) was resolved to 3.0.1, which depends on Ruby (> 1.9) org-ruby (~> 0.9.12) was resolved to 0.9.12, which depends on rubypants (~> 0.2) was resolved to 0.2.0, which depends on Ruby (> 0.0.0) solargraph (~> 0.43) was resolved to 0.43.0, which depends on diff-lcs (~> 1.4) was resolved to 1.4.4, which depends on Ruby (>= 1.8) Ruby

コンフリクトを起こした際に、bundle updateすれば解決するかもしれない、
Gemfile.lockを削除してbundle installすれば解決するかもしれないという記事を読んだので、
Gemfile.lockを削除後、bundle updateを実施しました。
実施後、以下のようにエラーが変わりました。

Bundler found conflicting requirements for the Ruby version: In Gemfile: Ruby aws-sdk-core (~> 3) was resolved to 3.130.1, which depends on Ruby (>= 2.3) gitlab-license_finder (~> 6.0) was resolved to 6.14.2.1, which depends on Ruby (>= 2.3.3) gitlab-net-dns (~> 0.9.1) was resolved to 0.9.1, which depends on Ruby (>= 2.1) grpc (~> 1.42.0) was resolved to 1.42.0, which depends on Ruby (< 3.1.dev, >= 2.4) nokogiri (~> 1.12) was resolved to 1.12.5, which depends on Ruby (>= 2.5.0)

試したこと

Rubyのバージョン 2.4.1p111 を使用しており、nokogiriの期待するrubyのバージョンと合わないためエラーが出ているのだと判断。
以下サイトを参考に必要Rubyバージョンが2.4.1以下のものを探して、Gemfileを修正後再度install updateを実施。
参考URL: https://rubygems.org/
再度install update実施後も同じようなエラーが出て、都度都度Gemfileを修正しています。
またruby2.4.1に合わせるためにライブラリのバージョンを下げてるせいか、
そのバージョンを下げたライブラリに依存するライブラリに関してもエラーが出てきて、
どんどんエラーが増えていっている状態です。

まず、このエラー対応は正しいのでしょうか。ruby初学者かつこのようなエラー対応は初めてなので、
このままこの対応をしていて問題ないのかと不安になり質問致しました。
分かる方いればぜひ教えていただければ幸いです。

良い質問の評価を上げる

以下のような質問は評価を上げましょう

  • 質問内容が明確
  • 自分も答えを知りたい
  • 質問者以外のユーザにも役立つ

評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

気になる質問をクリップする

クリップした質問は、後からいつでもマイページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

  • プログラミングに関係のない質問
  • やってほしいことだけを記載した丸投げの質問
  • 問題・課題が含まれていない質問
  • 意図的に内容が抹消された質問
  • 過去に投稿した質問と同じ内容の質問
  • 広告と受け取られるような投稿

評価を下げると、トップページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

mingos

2022/04/19 10:19

rubyのバージョンが古すぎるので、Gemfileは各gemのバージョンを細かく指定しないといけない気がします。 いずれにしても、Gemfile全体を省略せずに質問に記載したほうが回答が付きやすいと思います。 現段階の情報だけだとなんとも答えられません。
Sayre

2022/04/20 01:51

ご指摘ありがとうございます。 Gemfileは文字数制限の関係上全体を表示できず、エラーが出た部分周辺のみの抜粋となってしまっています。

まだ回答がついていません

会員登録して回答してみよう

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
87.20%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問

同じタグがついた質問を見る

Ruby on Rails

Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。