回答編集履歴

3 追記

ngyuki

ngyuki score 4464

2015/07/14 17:05  投稿

RDS の Parameter Group で `init_connect` をおかしな値に設定してしまっているなら、次のような手順で一度デフォルトの Parameter Group に戻してみると良いのでは無いでしょうか?
1. RDS の当該インスタンスを選択
2. RDS の「Instance Actions」から Modify を選択
3. DB Parameter Group という箇所のセレクトボックスで default.mysql5.6 に変更
4. 右下の Continue をクリック
5. 確認画面で Modify DB Instance をクリック
6. RDS の「Instance Actions」から Reboot を選択
7. 右下の Reboot をクリック
リブートが完了したら、デフォルトの Parameter Group (`init_connect` は空)で起動すると思います。
---
↓これを読んだ感じ、`init_connect` で `time_zone` を設定するように Parameter Group で設定していると、インスタンス作成時は問題なくても、リブートすると同症状が発生するようになったりするようです。
[https://forums.aws.amazon.com/thread.jspa?messageID=239869](https://forums.aws.amazon.com/thread.jspa?messageID=239869)
[https://forums.aws.amazon.com/message.jspa?messageID=238331](https://forums.aws.amazon.com/message.jspa?messageID=238331)
[https://forums.aws.amazon.com/message.jspa?messageID=238331](https://forums.aws.amazon.com/message.jspa?messageID=238331)
他にも「RDS タイムゾーン」でググると日本語の情報がいろいろヒットするので、わりと有名な問題のようです。
2 追記

ngyuki

ngyuki score 4464

2015/07/14 17:02  投稿

RDS の Parameter Group で `init_connect` をおかしな値に設定してしまっているなら、次のような手順で一度デフォルトの Parameter Group に戻してみると良いのでは無いでしょうか?
1. RDS の当該インスタンスを選択
2. RDS の「Instance Actions」から Modify を選択
3. DB Parameter Group という箇所のセレクトボックスで default.mysql5.6 に変更
4. 右下の Continue をクリック
5. 確認画面で Modify DB Instance をクリック
6. RDS の「Instance Actions」から Reboot を選択
7. 右下の Reboot をクリック
リブートが完了したら、デフォルトの Parameter Group (`init_connect` は空)で起動すると思います。
---
↓これを読んだ感じ、`init_connect` で `time_zone` を設定するように Parameter Group で設定していると、インスタンス作成時は問題なくても、リブートすると同症状が発生するようになったりするようです。
https://forums.aws.amazon.com/thread.jspa?messageID=239869
[https://forums.aws.amazon.com/thread.jspa?messageID=239869](https://forums.aws.amazon.com/thread.jspa?messageID=239869)
[https://forums.aws.amazon.com/message.jspa?messageID=238331](https://forums.aws.amazon.com/message.jspa?messageID=238331)
1 追記

ngyuki

ngyuki score 4464

2015/07/14 16:59  投稿

RDS の Parameter Group で `init_connect` をおかしな値に設定してしまっているなら、次のような手順で一度デフォルトの Parameter Group に戻してみると良いのでは無いでしょうか?
1. RDS の当該インスタンスを選択
2. RDS の「Instance Actions」から Modify を選択
3. DB Parameter Group という箇所のセレクトボックスで default.mysql5.6 に変更
4. 右下の Continue をクリック
5. 確認画面で Modify DB Instance をクリック
6. RDS の「Instance Actions」から Reboot を選択
7. 右下の Reboot をクリック
リブートが完了したら、デフォルトの Parameter Group (`init_connect` は空)で起動すると思います。
リブートが完了したら、デフォルトの Parameter Group (`init_connect` は空)で起動すると思います。
---
↓これを読んだ感じ、`init_connect` で `time_zone` を設定するように Parameter Group で設定していると、インスタンス作成時は問題なくても、リブートすると同症状が発生するようになったりするようです。
https://forums.aws.amazon.com/thread.jspa?messageID=239869

思考するエンジニアのためのQ&Aサイト「teratail」について詳しく知る