質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.52%

pythonでMeCab

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 1,344

aoisj

score 25

実現したいこと

python3でMeCabを使って形態素解析をしたいと考えています。
しかし、エラーが出てしまい実行ができませんでした。
コードはサイトに落ちていたものから構文エラーが出ないように
若干の修正を加えたとても短いものです。
以下にサンプルコードの修正版と実行時のエラーメッセージを記します。

サンプルコード(修正版)↓

# -*- coding: utf-8 -*-

import sys
import MeCab

m = MeCab.Tagger ("-Ochasen")

print ("私の名前はボブです。")
print (m.parse("私の名前はボブです。"))


エラーメッセージ↓

runfile('/home/m-m/Python_code/tf-idf/mecab_sample.py', wdir='/home/m-m/Python_code/tf-idf')
Traceback (most recent call last):

  File "<ipython-input-4-955e879451f5>", line 1, in <module>
    runfile('/home/m-m/Python_code/tf-idf/mecab_sample.py', wdir='/home/m-m/Python_code/tf-idf')

  File "/home/m-m/anaconda3/lib/python3.6/site-packages/spyder/utils/site/sitecustomize.py", line 880, in runfile
    execfile(filename, namespace)

  File "/home/m-m/anaconda3/lib/python3.6/site-packages/spyder/utils/site/sitecustomize.py", line 102, in execfile
    exec(compile(f.read(), filename, 'exec'), namespace)

  File "/home/m-m/Python_code/tf-idf/mecab_sample.py", line 3, in <module>
    import MeCab

  File "/home/m-m/anaconda3/lib/python3.6/site-packages/MeCab.py", line 26, in <module>
    _MeCab = swig_import_helper()

  File "/home/m-m/anaconda3/lib/python3.6/site-packages/MeCab.py", line 22, in swig_import_helper
    _mod = imp.load_module('_MeCab', fp, pathname, description)

  File "/home/m-m/anaconda3/lib/python3.6/imp.py", line 242, in load_module
    return load_dynamic(name, filename, file)

  File "/home/m-m/anaconda3/lib/python3.6/imp.py", line 342, in load_dynamic
    return _load(spec)

ImportError: /home/m-m/anaconda3/lib/python3.6/site-packages/numexpr/../../../libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /usr/lib/libmecab.so.2)

python3もMeCabも触るのが初めてなので、
馬鹿馬鹿しいミスによるものかもしれないのですが、
アドバイスをお願いしたいです。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

OSなどの環境の詳細、MeCabおよびMeCab-Pythonの導入手順が不明ですが
ImportError: ~ version GLIBCXX_3.4.20' not found (required by /usr/lib/libmecab.so.2)というエラーメッセージ検索して以下が出てきました。
Ubuntu 16.04.1 LTSにPython 3(Anaconda)とMeCabをインストールする

conda install libgccにてlibgccインストールすることで解消するかもしれません。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/08/24 16:32

    アドバイスありがとうございます。
    頂いたアドバイス通りに```conda install libgcc```
    を実行し、問いに対してyで答えましたが、
    実行結果は変わらないままでした...。
    コンソールの方で```import MeCab```
    と入力した時点で同様のエラーが出てしまっているようです...。

    キャンセル

  • 2017/08/24 16:38

    OSなどの環境の詳細、MeCabおよびMeCab-Pythonの導入手順を質問に追記ください。
    導入手順については「このページを参考にしました」ではなく、ご自身で操作、実行した具体的な手順、コマンドを提示ください。

    キャンセル

  • 2017/08/24 16:43

    OS:
    Ubuntu

    MeCabインストール手順:
    sudo apt-get install mecab libmecab-dev mecab-ipadic
    sudo aptitude install mecab-ipadic-utf8
    sudo apt-get install python-mecab

    以上の手順で導入しました。
    この手順で誤っているところがあれば教えていただきたいです。

    キャンセル

  • 2017/08/24 17:10

    私も過去にubuntu(16.04.2)+Anaconda(python=3.6.0)に導入しましたが、違いは
    sudo apt-get install python-mecab
    ではなく
    pip install --upgrade pip
    pip install mecab-python3
    と実行し、同様エラー発生したため
    conda install libgcc
    で解消しました。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.52%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る