質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.47%

  • Ruby

    7945questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails

    7495questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

  • MySQL

    6019questions

    MySQL(マイエスキューエル)は、TCX DataKonsultAB社などが開発するRDBMS(リレーショナルデータベースの管理システム)です。世界で最も人気の高いシステムで、オープンソースで開発されています。MySQLデータベースサーバは、高速性と信頼性があり、Linux、UNIX、Windowsなどの複数のプラットフォームで動作することができます。

  • SQLite

    640questions

    SQLiteはリレーショナルデータベース管理システムの1つで、サーバーではなくライブラリとして使用されている。

railsにおけるデータベースの扱い方

解決済

回答 2

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 568

renren643

score 208

rubyとrailsをインストールしたのですが、それとは別に
データベース(mysql, sqlite)もインストールしなくてはいけないのでしょうか? 

railsを使っていて、rails db:migrateで変更を反映させてもエラーが出ます。
また、rails -vでrailsが確認できるように、いま自分がデータベースを使える状態なのかを確認する手段はありますか??

 # Raises <tt>ActiveRecord::PendingMigrationError</tt> error if any migrations are pending.

      def check_pending!(connection = Base.connection)
        #⇓ここがエラー
        raise ActiveRecord::PendingMigrationError if ActiveRecord::Migrator.needs_migration?(connection)

      end



      def load_schema_if_pending!


rails db:versionを実行したところ、「Current version: 0」と出ていますが何か関係はありますか?
rails dbを実行したらこうなりました。
Couldn't find database client: sqlite3.exe. Check your $PATH and try again.

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

checkベストアンサー

+2

DBは別にインストールが必要です。
gemには使いたいDBに接続するためのものをインストールします。
sqlite3なら

gem 'sqlite3'


mysqlなら

gem 'mysql2'


などのコードですね。
バージョン確認ですが、何のDBを使おうと思っているのかによって変わります。

$ mysql --version
$ sqlite3 --version


等のコマンドで調べられます。
DBをインストールした覚えが無いようならインストールされていない可能性は高いと思います。
rake db:versionの出力結果ですが、DBのバージョンではなく、マイグレーションのバージョンになりますので、Current version: 0ということでmigrateされていないというものです。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/08/20 22:05

    回答ありがとうございました!またよろしくお願いします!

    キャンセル

0

Gemfileに

gem 'sqlite3'

とか

gem 'pg'


とかを記述して

bundle install


をするとgem に書いてあるDBがインストールされます。(この段階ではデータベースができた訳ではありません。インストールされただけです。)

その後に、modelを作る過程でmigrationファイルが生成されます。

rails g model User name email password


例えば、上記のようにUserモデルを作る指示をすると、migrationファイルが生成されます。migrationファイルとは、Userテーブルにname email passwordのカラムを作るための指示書的なものが生成されるので、これをrake db:migrateとすると、実際にDBにカラムを作ってくれて、データを入れられる状態になります。

gemにはDBの記載があり、sqlite3であれば、config/database.ymlに特に指定をしなくてもdefaultで利用きると思います。エラーを見る限り、migrationされていないのでは、と思います。もしくは、Databaseは存在するけど、migrationファイルが上手く記述されていなくて、エラーになっているのかもしれません。

一度migrationファイルを削除して、migrationファイルから作り直してみては如何でしょうか。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/08/19 12:23

    Gemfileに書くだけではDB自体のインストールはされないと思います。
    それでインストールされるのは各DBに接続するためのアダプタではないでしょうか?

    キャンセル

  • 2017/08/19 12:31

    確かにそうですね、失礼しました。
    しかし、sqlite3は自分でインストールした覚えがないのに使えてしまうのは、なんででしょう。

    キャンセル

  • 2017/08/19 12:38

    Macですと最初からインストールされているようです。
    LinuxですとOSインストール時のソフトウェアの選択によってはインストールされていることもあるという感じです。

    キャンセル

  • 2017/08/19 12:46

    有難うございます。

    キャンセル

関連した質問

  • 解決済

    Middlemanでsqlite3からデータを取りたいんですけど・・・

    これまで、Ruby on Railsで作成されたページを、静的なサイトに変更しようと考えています。 ERBなどをそのまま使えることもあり、 静的サイトジェネレータである、midd

  • 解決済

    [sqlite3]出力結果をきれいに改行して出力したい

    皆様お世話になっております。 OSXのターミナルでsqlite3を使って、テーブルの構造を確認しようとしたらカラムごとに改行されず、一行で出力されてしましました。テーブル構造を確

  • 受付中

    RailsAPIでアップロードした画像に処理を加えたい

    お世話になっております。 こちらのサイトさまを参考にRailsAPIを制作してみました。 Railsで、画像をアップロード、ダウンロードするREST API 無事、サイト通

  • 解決済

    データベースの中身をリセットしたい

    SQLiteで、データベースの中身をリセットしたいのですがそのようなコマンドはあるでしょうか? テーブル自体を削除するのではなく、中身をリセット(削除)するだけなのですが。。。

  • 解決済

    異なるDB間で、特定のカラムのみコピーしたい

    前提・実現したいこと 自作のAndroidアプリ内でsqliteを利用しています。 構造が同じ2つのデータベースA,Bがあり、複数テーブルが存在します。 実現したいことは、デー

  • 受付中

    VB.netでCSVを読み込んでSQLiteにInsertしたい

    いつもお世話になっております。 今回、VB.netでCSVを読み込んでSQLiteのDataBaseにInsertしたいのですが 参考資料がC#ばかりであまりよくわかりませんで

  • 解決済

    Ruby on RailsでNoMethodErrorが出ます

     前提・実現したいこと ドットインストールを見ながら第12回目(https://dotinstall.com/lessons/basic_rails_v3/41812)まで実際に作

  • 解決済

    sqlite3カラム削除

    sqlite3でカラム削除は可能でしょうか? また、可能であればどのように行うのでしょうか?

同じタグがついた質問を見る

  • Ruby

    7945questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails

    7495questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

  • MySQL

    6019questions

    MySQL(マイエスキューエル)は、TCX DataKonsultAB社などが開発するRDBMS(リレーショナルデータベースの管理システム)です。世界で最も人気の高いシステムで、オープンソースで開発されています。MySQLデータベースサーバは、高速性と信頼性があり、Linux、UNIX、Windowsなどの複数のプラットフォームで動作することができます。

  • SQLite

    640questions

    SQLiteはリレーショナルデータベース管理システムの1つで、サーバーではなくライブラリとして使用されている。