質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.51%

  • Linux

    4436questions

    Linuxは、Unixをベースにして開発されたオペレーティングシステムです。日本では「リナックス」と呼ばれています。 主にWebサーバやDNSサーバ、イントラネットなどのサーバ用OSとして利用されています。 上位500のスーパーコンピュータの90%以上はLinuxを使用しています。 携帯端末用のプラットフォームAndroidは、Linuxカーネル上に構築されています。

  • Raspberry Pi

    1065questions

    Raspberry Piは、ラズベリーパイ財団が開発した、名刺サイズのLinuxコンピュータです。 学校で基本的なコンピュータ科学の教育を促進することを意図しています。

  • Raspbian

    144questions

  • Debian

    131questions

    Debianは、Debian GNU/Linux などのOS(オペレーティングシステム)です。

DebianにTeamViwerがインストールできない

解決済

回答 2

投稿

  • 評価
  • クリップ 0
  • VIEW 1,644

scrollman

score 49

DebianのRaspberrypiにTeamViwerをインストール出来ません。

サポートされていないシステムへのインストール
を参考にして

apt install teamviewer_12.0.76279_i386.deb


を行うも

パッケージリストを読み込んでいます... 完了
依存関係ツリーを作成しています                
状態情報を読み取っています... 完了
E: パッケージ teamviewer_12.0.76279_i386.deb が見つかりません
E: 正規表現 'teamviewer_12.0.76279_i386.deb' ではパッケージは見つかりませんでした


と表示されます。

dpkg -i teamviewer_i386.deb


次にこれを行うも

(データベースを読み込んでいます ... 現在 121113 個のファイルとディレクトリがインストールされています。)
teamviewer_i386.deb を展開する準備をしています ...
teamviewer (12.0.76279) で (12.0.76279 に) 上書き展開しています ...
dpkg: 依存関係の問題により teamviewer の設定ができません:
 teamviewer は以下に依存 (depends) します: libc6 (>= 2.11).
 teamviewer は以下に依存 (depends) します: libgcc1.
 teamviewer は以下に依存 (depends) します: libasound2.
 teamviewer は以下に依存 (depends) します: libdbus-1-3.
 teamviewer は以下に依存 (depends) します: libexpat1.
 teamviewer は以下に依存 (depends) します: libfontconfig1.
 teamviewer は以下に依存 (depends) します: libfreetype6.
 teamviewer は以下に依存 (depends) します: libjpeg62.
 teamviewer は以下に依存 (depends) します: libsm6.
 teamviewer は以下に依存 (depends) します: libxdamage1.
 teamviewer は以下に依存 (depends) します: libxext6.
 teamviewer は以下に依存 (depends) します: libxfixes3.
 teamviewer は以下に依存 (depends) します: libxinerama1.
 teamviewer は以下に依存 (depends) します: libxrandr2.
 teamviewer は以下に依存 (depends) します: 
dpkg: パッケージ teamviewer の処理中にエラーが発生しました (--install):
 依存関係の問題 - 設定を見送ります
gnome-menus (3.13.3-6) のトリガを処理しています ...
desktop-file-utils (0.22-1) のトリガを処理しています ...
mime-support (3.58) のトリガを処理しています ...
hicolor-icon-theme (0.13-1) のトリガを処理しています ...
処理中にエラーが発生しました:
 teamviewer

と出てやはりインストールが出来まふせん。
どうすればインストールが出来ますか?
環境
No LSB modules are available.
Distributor ID: Raspbian
Description: Raspbian GNU/Linux 8.0 (jessie)
Release: 8.0
Codename: jessie

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

checkベストアンサー

0

syuumuさん、

RaspberryPi(2/3)が対応してるのは、いまのところ、TeamViewer Hostの方ですかね?
Teamviewer の Downloadページから、Linux を選んで、下のほうの、TeamViewer Hostのとこにある、armv7 32bitだと思います。


環境: Raspberry Pi 3 + Raspbian (2017-07-05-raspbian-jessie)にて.

# パッケージ更新
sudo apt update && sudo apt upgrade -y

# Teamviewerダウンロードとインストール。
wget https://download.teamviewer.com/download/linux/teamviewer-host_armhf.deb
sudo dpkg -i ./teamviewer-host_armhf.deb
sudo apt-get install -f -y


これで、ウィンドウが開いて、ライセンスを受諾するか聞かれると思います。
表示されている、IDとパスワードを使って、WindowsのTeamviewerから、接続できました。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/07/21 11:49

    お蔭様でリモートデスクトップできるようになりました!。
    返信してくださりありがとうございました。

    キャンセル

0

aptを使ってdebファイルをインストールする場合は以下のようにしてください、

apt install ./teamviewer_12.0.76279_i386.deb


ここまで書いておいて申し訳ないのですが、RaspberryPiのCPUはIntel系のCPUではなくARM系のCPUですので、インストールできない(できたとしても実行できない)かと思います。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/07/12 00:03

    本当ですか!?
    ググってみると成功事例があるんですよね、なんででしょう、、。
    ご返答ありがとうございます。
    もう少し粘ってみます

    キャンセル

同じタグがついた質問を見る

  • Linux

    4436questions

    Linuxは、Unixをベースにして開発されたオペレーティングシステムです。日本では「リナックス」と呼ばれています。 主にWebサーバやDNSサーバ、イントラネットなどのサーバ用OSとして利用されています。 上位500のスーパーコンピュータの90%以上はLinuxを使用しています。 携帯端末用のプラットフォームAndroidは、Linuxカーネル上に構築されています。

  • Raspberry Pi

    1065questions

    Raspberry Piは、ラズベリーパイ財団が開発した、名刺サイズのLinuxコンピュータです。 学校で基本的なコンピュータ科学の教育を促進することを意図しています。

  • Raspbian

    144questions

  • Debian

    131questions

    Debianは、Debian GNU/Linux などのOS(オペレーティングシステム)です。