質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.61%

  • Ruby

    7324questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails 4

    2404questions

    Ruby on Rails4はRubyによって書かれたオープンソースのウェブフレームワークです。 Ruby on Railsは「設定より規約」の原則に従っており、効率的に作業を行うために再開発を行う必要をなくしてくれます。

Ruby on Railsのインストールが出来ません

解決済

回答 2

投稿

  • 評価
  • クリップ 0
  • VIEW 4,240

ComSatooooshi

score 16

本日Ruby on Rails の入門書を購入し、現在開発環境の設定を行っております。
現在Ruby、SQLite、DevKit、Node.jsのインストールが完了し、最後にRuby on Rails
のインストールをしている所です。

コマンドプロンプトで下記のように入力したところ、エラーが発生しました。

【入力コマンド】
>gem install rails -v 4.0.2

【エラー】
ERROR: Could not find a valid gem 'rails' (= 4.0.2),here is why:Unable to download data from http://rubygems.org/ - SSL_connect returned=1 errno=0 state=SSLv3 read server certificate verify failed(http://rubygems.org/specs.4.8.gz)

エラーの原因を検索したところ、下記の解決策が書いてありました。

【対策】
SSL証明書の問題のため、自分で入手してアップデートをしてあげればよい。
【手順】
・以下から「AddTrustExternalCARoot-2048.pem」をダウンロード。
https://gist.github.com/luislavena/f064211759ee0f806c88
・上記のpemファイルを「${RUBY_HOME]/ruby/2.1.0/rubygems/ssl_certs」にコピー
・Ruby On Railsのインストール手順を再実行

しかし、https://gist.github.com/luislavena/f064211759ee0f806c88にアクセスし
「AddTrustExternalCARoot-2048.pem」をダウンロードしようとしましたが、別の画面に
移り文字の羅列が表示されただけで、具体的に何をどうすれば良いかわからない状況です。

お手数ですが、こういった場合の対処法をご教示いただけると助かります。

よろしくお願い致します。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

checkベストアンサー

+3

標準で入っているgemが古いせいでこの現象が起こるようです。アップデートすると解決します。
自分はこれを読んで解決しました。
rubygems-updateというgemを手動でインストールし、update_rubygemsすると解決するという方法です。

手動でインストールする方法は、rubygemsのrubygems-updateのページのDownloadのところからダウンロードし、そのファイルがあるフォルダでgem install --local rubygems-update-2.4.6.gemとコマンドを打てばインストールできます。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

+1

ダウンロードしようとしましたが、別の画面に移り文字の羅列が表示されただけで、具体的に何をどうすれば良いかわからない状況です。 

Rubyというより、ブラウザの使い方ですね。
その画面を、ファイルメニューの「名前を付けて保存」というのが一つのやり方です。

普通のダウンロードのやり方としては、AddTrustExternalCARoot-2048.pemへのリンクを右クリックして「名前を付けてリンク先を保存」です。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.61%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る

  • Ruby

    7324questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails 4

    2404questions

    Ruby on Rails4はRubyによって書かれたオープンソースのウェブフレームワークです。 Ruby on Railsは「設定より規約」の原則に従っており、効率的に作業を行うために再開発を行う必要をなくしてくれます。