質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.09%

Ubuntu, Apache にtcp80番で繋がらない

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 2,553
退会済みユーザー

退会済みユーザー

さくらのVPSを使って簡単なWEBサーバを構成しようとしています。外部からサーバに接続することができず、原因がわかりません。何かヒントをお持ちの方は、お教えいただけると幸いです。

 環境

  • Ubuntu 16.04
  • Apache 2.4.18

 これまでの作業

# apacheをインストール
$ sudo apt-get update
$ sudo apt-get install apache2

# ufwで22番(ssh)と80番(http)のインカミングコネクションを許可
$ sudo ufw default deny incoming
$ sudo ufw default allow outgoing
$ sudo ufw allow ssh
$ sudo ufw allow http
$ sudo ufw enable

 現状の確認

以下のコマンドで、現状を確認しました。

# apacheのデーモンが起動していることを確認
$ sudo systemctl status apache2.service
● apache2.service - LSB: Apache2 web server
   Loaded: loaded (/etc/init.d/apache2; bad; vendor preset: enabled)
  Drop-In: /lib/systemd/system/apache2.service.d
           └─apache2-systemd.conf
   Active: active (running) since Mon 2017-06-12 01:03:06 JST; 1h 3min ago
     Docs: man:systemd-sysv-generator(8)
   CGroup: /system.slice/apache2.service
           ├─3771 /usr/sbin/apache2 -k start
           ├─3774 /usr/sbin/apache2 -k start
           └─3775 /usr/sbin/apache2 -k start

Jun 12 01:03:04 tk2-224-21889 systemd[1]: Starting LSB: Apache2 web server...
Jun 12 01:03:04 tk2-224-21889 apache2[3748]:  * Starting Apache httpd web server apache2
Jun 12 01:03:06 tk2-224-21889 apache2[3748]:  *
Jun 12 01:03:06 tk2-224-21889 systemd[1]: Started LSB: Apache2 web server.

# ufwが正しく設定されていることを確認
$ sudo ufw status
Status: active

To                         Action      From
--                         ------      ----
22                         ALLOW       Anywhere
80                         ALLOW       Anywhere
22 (v6)                    ALLOW       Anywhere (v6)
80 (v6)                    ALLOW       Anywhere (v6)

Ubuntu内で curl を利用して、Apacheが80番でlistenしていることは確認できています。

# (ubuntu内で)apacheが応答することを確認
$ curl 'http://localhost'

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
  <!--
    Modified from the Debian original for Ubuntu
    Last updated: 2014-03-19
    See: https://launchpad.net/bugs/1288690
  -->
  <head>
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    <title>Apache2 Ubuntu Default Page: It works</title>
    <style type="text/css" media="screen">
  * {
    margin: 0px 0px 0px 0px;
    padding: 0px 0px 0px 0px;
  }
# 以下省略…

 推測

Ubuntu内部からはApacheにアクセスできているので、Apache自体は問題なく動いていると考えています。Apacheはaptでインストールしただけで、何も設定はしていません。

macOSローカルから telnet でUbuntuに対して22番(ssh)と80番(http)に接続を試みると、22番は問題なく接続できましたが、80番ではrefuseされたので、何かしらのファイアウォールが未だに動いているのではないかと考えています。

# 22番は接続成功
$ telnet <my ip address> 22
Trying <my ip address>...
Connected to <my server>.
Escape character is '^]'.
SSH-2.0-OpenSSH_7.2p2 Ubuntu-4ubuntu2.2

# 80番はrefuseされる
$ telnet <my ip address> 80
Trying <my ip address>...
telnet: connect to address <my ip address>: Connection refused
telnet: Unable to connect to remote host
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • TaichiYanagiya

    2017/06/13 11:46

    /var/log/ufw.log に拒否されたログが出ていないでしょうか?

    キャンセル

回答 1

checkベストアンサー

+1

さくらVPSにfirewalldのサービスは稼働しておりますか?
以下のコマンドで確認をお願いいたします。

$ sudo systemctl status firewalld

もし、設定などがなされていなかった場合はこちらをお試しください。

$ sudo systemctl start firewalld.service
$ sudo systemctl enable firewalld.service
$ sudo firewall-cmd --zone=public --add-port=80/tcp -permanent
$ sudo firewall-cmd --permanent --add-service=http
$ sudo firewall-cmd --list-all
$ sudo firewall-cmd --reload
$ sudo systemctl restart firewalld.service
$ sudo systemctl status firewalld

参考になれば幸いです^^

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/06/13 13:19

    ご回答ありがとうございます。

    おかげさまで無事外部からアクセスすることができました😭
    この度はありがとうございました!

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.09%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる