質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.97%

sudo apt-get -f install を実行するとエラーをはいてしまいます

受付中

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 1,916

abea

score 17

sudo apt-get -f install を端末で実行すると

""
パッケージリストを読み込んでいます... 完了
依存関係ツリーを作成しています                
状態情報を読み取っています... 完了
依存関係を解決しています ... 完了
以下のパッケージが自動でインストールされましたが、もう必要とされていません:
linux-headers-4.4.0-59 linux-headers-4.4.0-59-generic linux-headers-4.4.0-62
linux-headers-4.4.0-62-generic linux-headers-4.4.0-63
linux-headers-4.4.0-63-generic linux-image-4.4.0-59-generic
linux-image-4.4.0-62-generic linux-image-4.4.0-63-generic
linux-image-extra-4.4.0-59-generic linux-image-extra-4.4.0-62-generic
linux-image-extra-4.4.0-63-generic linux-signed-image-4.4.0-59-generic
linux-signed-image-4.4.0-62-generic linux-signed-image-4.4.0-63-generic
これを削除するには 'sudo apt autoremove' を利用してください。
以下の追加パッケージがインストールされます:
python-appindicator
以下のパッケージはアップグレードされます:
python-appindicator
アップグレード: 1 個、新規インストール: 0 個、削除: 0 個、保留: 308 個。
3 個のパッケージが完全にインストールまたは削除されていません。
7,740 B のアーカイブを取得する必要があります。
この操作後に 36.9 kB のディスク容量が解放されます。
続行しますか? [Y/n] Y
取得:1 http://jp.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 python-appindicator amd64 12.10.1+16.04.20170215-0ubuntu1 [7,740 B]
7,740 B を 0秒 で取得しました (75.0 kB/s)       
(データベースを読み込んでいます ... 現在 325947 個のファイルとディレクトリがインストールされています。)
.../python-appindicator_12.10.1+16.04.20170215-0ubuntu1_amd64.deb を展開する準備をしています ...
/var/lib/dpkg/info/python-appindicator.prerm: 6: /var/lib/dpkg/info/python-appindicator.prerm: pyclean: not found
dpkg: 警告: サブプロセス 古い pre-removal スクリプト はエラー終了ステータス 127 を返しました
dpkg: 代わりに新規パッケージからスクリプトを実行してみます ...
/var/lib/dpkg/tmp.ci/prerm: 6: /var/lib/dpkg/tmp.ci/prerm: pyclean: not found
dpkg: アーカイブ /var/cache/apt/archives/python-appindicator_12.10.1+16.04.20170215-0ubuntu1_amd64.deb の処理中にエラーが発生しました (--unpack):
サブプロセス 新しい pre-removal スクリプト はエラー終了ステータス 127 を返しました
/var/lib/dpkg/info/python-appindicator.postinst: 6: /var/lib/dpkg/info/python-appindicator.postinst: pycompile: not found
dpkg: クリーンアップ中にエラーが発生しました:
サブプロセス インストール済みの post-installation スクリプト はエラー終了ステータス 127 を返しました
処理中にエラーが発生しました:
/var/cache/apt/archives/python-appindicator_12.10.1+16.04.20170215-0ubuntu1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
""

とエラーをはいて実行することができません。
これは何が原因なのでしょうか?教えてくださると助かります。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

0

Redhat(CentOS)屋なので特定までは難しいですが、yumに置き換えれば大体が依存関係によるエラーです。

https://serverlog.jp/apt-get-dependence/

「apt-getによる依存関係の解決方法」といったページで「Sub-process /usr/bin/dpkg returned an error code (1)」エラーに関する対処方法が記載されていたのでURLを載せておきます。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.97%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る