質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.06%

PhantomJSのビルド

解決済

回答 2

投稿

  • 評価
  • クリップ 0
  • VIEW 910

ooeok

score 457

前提・実現したいこと

さくらインターネットのレンタルサーバにてPhantomJSを公式サイトの手順でbuildしようとしています。
http://phantomjs.org/build.html

発生している問題・エラーメッセージ

以下のメッセージが出て途中で止まってしまいました。

configuring Qt Base, please wait...
Executing in /home/xxx/local/src/phantomjs/src/qt/qtbase: /home/xxx/local/src/phantomjs/src/qt/qtbase/configure -static -opensource -confirm-license -prefix /home/xxx/local/src/phantomjs/src/qt/qtbase -qt-zlib -qt-libpng -qt-libjpeg -qt-pcre -nomake examples -nomake tools -nomake tests -no-qml-debug -no-dbus -no-opengl -no-audio-backend -D QT_NO_GRAPHICSVIEW -D QT_NO_GRAPHICSEFFECT -D QT_NO_STYLESHEET -D QT_NO_STYLE_CDE -D QT_NO_STYLE_CLEANLOOKS -D QT_NO_STYLE_MOTIF -D QT_NO_STYLE_PLASTIQUE -D QT_NO_PRINTPREVIEWDIALOG -qpa phantom -openssl -openssl-linked -no-openvg -no-eglfs -no-egl -no-glib -no-gtkstyle -no-cups -no-sm -no-xinerama -no-xkb -no-xcb -no-kms -no-linuxfb -no-directfb -no-mtdev -no-libudev -no-evdev -no-pulseaudio -no-alsa -no-feature-PRINTPREVIEWWIDGET -fontconfig -icu -release

This is the Qt Open Source Edition.

You are licensed to use this software under the terms of
the Lesser GNU General Public License (LGPL) versions 2.1.
You are also licensed to use this software under the terms of
the GNU Lesser General Public License (LGPL) versions 3.

You have already accepted the terms of the Open Source license.

<srcbase> = /home/xxx/local/src/phantomjs/src/qt/qtbase
<outbase> = /home/xxx/local/src/phantomjs/src/qt/qtbase
Creating qmake...
.Done.
Running configuration tests...
The ICU library support cannot be enabled.
 Turn on verbose messaging (-v) to /home/xxx/local/src/phantomjs/src/qt/qtbase/configure to see the final report.
 If you believe this message is in error you may use the continue
 switch (-continue) to /home/xxx/local/src/phantomjs/src/qt/qtbase/configure to continue.

ERROR: Failed to build PhantomJS! Configuration of Qt Base failed.

qtのbuidで失敗しているようですが、この辺りの知識がないため自分では解決できませんでした。
どうすればbuildできるようになるのでしょうか?

試したこと

composer installはRuntimeExceptionが出てしまい無理でした。

  [RuntimeException]
  The Installer could not select a PhantomJS package for this OS.
                  Please install PhantomJS manually into the /bin folder of your project.

環境

  • FreeBSD 9.1-RELEASE-p24(さくらインターネット)
  • Python 2.7.6
  • git  version 2.13.GIT(自前でbuild。SSL証明書をチェックをしない)
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

check解決した方法

0

結局さくらでのインストールはあきらめました。
パッケージの依存関係を解消できず、制約が多い環境でがんばるより、もっと制約の緩いVPSに移るべきという結論に達しました。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

0

直接的な回答ではありませんが

ports や pkg に 存在しているようですので、そちらからのインストールも検討されてはいかがでしょうか。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/08/11 20:20

    回答ありがとうございます。
    質問してから自分でもジタバタしてみました。
    いろいろなライブラリに依存しているらしく、依存しているライブラリをインストールしようとするとそれも別のものに依存していて、さらにまた別のライブラリに依存しているといった依存の連鎖に疲れ果てました。
    それらを全部自分で解決するのはちょっと無理です。
    素直にyumやapt-getが使える環境に移ることにします。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.06%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る