質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.92%

ubuntuでapt-getがうまく動作しません。

受付中

回答 2

投稿

  • 評価
  • クリップ 1
  • VIEW 6,516

atfamic

score 12

現在ubuntu14.04を使用しているのですが、どうもapt-get installコマンドがうまく動作しません。以下のような表示が出るのですが対処法がいまいちよくわからなくて、、

以下のパッケージには満たせない依存関係があります:
 bluefish : 依存: bluefish-data (= 2.2.5-1) しかし、インストールされようとしていません
            依存: bluefish-plugins (= 2.2.5-1) しかし、インストールされようとしていません
 cpp-4.8 : 依存: gcc-4.8-base (= 4.8.2-19ubuntu1) しかし、4.8.4-2ubuntu1~14.04.3 はインストールされようとしています
 gcc-4.8 : 依存: cpp-4.8 (= 4.8.4-2ubuntu1~14.04.3) しかし、4.8.2-19ubuntu1 はインストールされようとしています

これはどうやって対応すれば良いのでしょうか??またその原因は何なのでしょうか??

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

+2

apt-getを使ってBluefish Editorをインストールしようとしているのですか?
そうであれな、以下のコマンドを実行し、レポジトリの追加を行い、インストールしてください。

sudo add-apt-repository ppa:klaus-vormweg/bluefish
sudo apt-get update
sudo apt-get install bluefish

下のcppとgccのエラーに関してですが、インストールしているバージョンの違いで依存関係がうまく解決できないため起こっている問題です。cpp及びgccをインストールする必要があるのであれば、aptitudeコマンドを使用してcppおよびgccをインストールしてください。

例:

aptitude update
aptitude install cpp
aptitude install gcc

解決方法を提示してくれるはずなので、詳細を確認してからYを押してインストールしてください。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/05/14 20:52

    回答有難うございます!
    aptitudeコマンドなのですが、aptitudeコマンドをインストールしようとするとまた同じようなエラー「
    aptitude : 依存: aptitude-common (= 0.6.8.2-1ubuntu4) しかし、インストールされようとしていません
    依存: libboost-iostreams1.54.0 しかし、インストールされようとしていません
    依存: libcwidget3 しかし、インストールされようとしていません
    依存: libept1.4.12 しかし、インストールされようとしていません
    cpp-4.8 : 依存: gcc-4.8-base (= 4.8.2-19ubuntu1) しかし、4.8.4-2ubuntu1~14.04.3 はインストールされようとしています
    gcc-4.8 : 依存: cpp-4.8 (= 4.8.4-2ubuntu1~14.04.3) しかし、4.8.2-19ubuntu1 はインストールされようとしています
    E: 未解決の依存関係です。'apt-get -f install' を実行してみてください (または解法を明示してください)。
    」というように出てしまいます。。。

    キャンセル

0

一旦そうなると一度リセットしなければaptが一切使えなくなる謎の罠みたいなものですね。

とりあえず

$ sudo apt remove bluefish bluefish-data bluefish-plugins 


を入力してみてください。さらにそのあと

$ sudo apt clean ; sudo apt autoclean


を実行してみてください。これでaptが復活するはずです。

ちなみに、aptは基本的に依存を解決してくれるのですが、これが表示されるということはなんらかの原因でaptではインストールできないという意味なので、他の方がおっしゃっているとおりにppaでインストールしてみてはいかがでしょうか。

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.92%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る