質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.91%

Beautifulsoupで競馬情報のスクレイピングを行っていましたが、突然、プログラムが動かなくなりました

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 1,080

akakage13

score 89

Windows7 (ver6.1.7601), python2.7の最新版で競馬情報のスクレイピングを行っておりましたが、
今日、プログラムを動かしたところ、以下のようなエラーがでました。

C:\Users\satoru\horse\horse>horse-scan.py
Traceback (most recent call last):
File "C:\Users\satoru\horse\horse\horse-scan.py", line 6, in <module>
from bs4 import BeautifulSoup
File "C:\Python27\lib\site-packages\bs4\init.py", line 30, in <module>
from .builder import builder_registry, ParserRejectedMarkup
File "C:\Python27\lib\site-packages\bs4\builder\init.py", line 314, in <module>
from . import _html5lib
File "C:\Python27\lib\site-packages\bs4\builder\_html5lib.py", line 70, in <module>
class TreeBuilderForHtml5lib(html5lib.treebuilders._base.TreeBuilder):
AttributeError: 'module' object has no attribute '_base'

htmllib等の再インストールも行いましたが、うまくいきません。

特に何かソースコードを変更したわけでもないのに、突然にエラーが発生して、非常に困っております。

先輩方の御教示、よろしくお願いいたします。

追記

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

C:\Users\satoru>pip install bs4
Requirement already satisfied: bs4 in c:\python27\lib\site-packages
Requirement already satisfied: beautifulsoup4 in c:\python27\lib\site-packages (from bs4)

C:\Users\satoru>pip install builder_registry
Collecting builder_registry
Could not find a version that satisfies the requirement builder_registry (from versions: )
No matching distribution found for builder_registry

C:\Users\satoru>

上記のようなことも試みましたが、うまくいきません。versionの問題なのでしょうか?

追記

突然と申し上げましたが、しいて変更したとすれば、jupyterをインストールしました。
先ほどアンインストールしましたが、改善出来ておりません。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

+1

PyPI パッケージ間のバージョン齟齬が疑われる…等の理由でインストール済みのパッケージをバージョンアップしたい場合は、 pip install コマンドに --upgrade 引数を付けて実行してみてください。

$ pip install --upgrade bs4

突然と申し上げましたが、しいて変更したとすれば、jupyterをインストールしました。
先ほどアンインストールしましたが、改善出来ておりません。

恐らく、 jupyter の依存関係で html5lib のバージョンが上がったりしたのではないでしょうか。
こういったトラブルを避けるために、 Python 2.7 では virtualenv という「プロジェクト毎に pip の環境を分けておく」機能が広く使われていますので、調べておくと良いかもしれません。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.91%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る