質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.33%

  • Node.js

    2006questions

    Node.jsとはGoogleのV8 JavaScriptエンジンを使用しているサーバーサイドのイベント駆動型プログラムです。

  • npm

    313questions

    npmは、Node Packaged Modulesの略。Node.jsのライブラリ・パッケージを管理できるツールです。様々なモジュールを簡単にインストールでき、自分でモジュールを作成し公開する際にも使用できます。

  • gulp

    289questions

    gulpは、Node.jsをベースとしたタスク自動化ツールの一つ。ストリームでファイルを処理することが特徴です。CSSプリプロセッサの使用時のコンパイルや、CSS・JavaScriptファイルの圧縮・結合などを自動的に行うことができます。

npm install 時に発生するエラーについて

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 2,243

koikuti

score 21

前提・実現したいこと

npm install を使用して、gulp-sourcemaps をインストールしようとしたところ、以下のエラーが発生しました。

発生している問題・エラーメッセージ

npm ERR! registry error parsing json
npm ERR! Windows_NT 6.1.7601
npm ERR! argv "C:\\Program Files\\nodejs\\node.exe" "C:\\Program Files\\nodejs\\
node_modules\\npm\\bin\\npm-cli.js" "install" "gulp-sourcemaps"
npm ERR! node v6.2.1
npm ERR! npm  v3.9.3

npm ERR! Unexpected token < in JSON at position 0
npm ERR! <html>
npm ERR!   <head>
npm ERR!     <title>404 - Request is serviced by NPM metadata service, remote ac
cess not needed from DefaultNpmProxyRepository(id=npm)</title>
npm ERR!     <meta http-equiv="Content-Type" content="text/html; charset=utf-8"/>

(以下略)

補足情報(言語/FW/ツール等のバージョンなど)

OS:windows7 64bit
node:v6.2.1
npm:v3.9.3

エラーメッセージ自体は、「ソースファイル(?)によくわからない、文字『<』が入っているよ。」なのですが、npm install時にどのファイルを見て、対象のパッケージをインストールするのかがわからず、どこに『<』が入っているのか見当がつきません。package.jsonに『<』が入っていないことは確認したのですが...。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

npmがリポジトリーサーバー(?)へのAPIインターフェースを通じてjsonをとってこようとした際にサーバーからHTMLが応答されてしまい先頭が'<html...'となっていたため、「それjsonじゃないよ!」となったのではないでしょうか?

サーバーからの応答HTMLの中身をみると「このサーバーへ問い合わせる必要はなくて NPMのメタデータサービスから取得できるはずですよ」というようなことを言ってる気がします。インストール済みのnpmがローカルに持っている情報で間に合うはずということなんでしょうかね・・・(npmの仕組みがよくわかってないので想像で物を言っています)

詳しい方が適切な回答をしてくれるかも知れませんが・・・自分はnpmのバージョンが古いことが原因かも知れないと思いました。

より新しいバージョンが存在するのでアップデートしてみるというのも対処としてありえる気がします。(npmだけアップデートしたほうがいいんでしょうか・・・nodejsの事情に暗いのでそのあたりは自分も知りたいところですが)

参考までに自分の環境(windows 10)は以下です。

nodejs v6.10.1
npm 3.10.10

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

同じタグがついた質問を見る

  • Node.js

    2006questions

    Node.jsとはGoogleのV8 JavaScriptエンジンを使用しているサーバーサイドのイベント駆動型プログラムです。

  • npm

    313questions

    npmは、Node Packaged Modulesの略。Node.jsのライブラリ・パッケージを管理できるツールです。様々なモジュールを簡単にインストールでき、自分でモジュールを作成し公開する際にも使用できます。

  • gulp

    289questions

    gulpは、Node.jsをベースとしたタスク自動化ツールの一つ。ストリームでファイルを処理することが特徴です。CSSプリプロセッサの使用時のコンパイルや、CSS・JavaScriptファイルの圧縮・結合などを自動的に行うことができます。