質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.33%

  • Python 3.x

    7428questions

    Python 3はPythonプログラミング言語の最新バージョンであり、2008年12月3日にリリースされました。

python3.6でpipを使いたい

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 4,442

tama01

score 3

質問内容

python3.6でpipを使いたいです。pythonと共にインストールされるpipを使いたいのですが、$pip -vと打ってもcommand not foundとなります。
$ python3 -m pip -Vと打つと
pip 9.0.1 from /Library/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages (python 3.6)と表示され、インストールはされているようです。
上のパス(/Library/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages)を環境変数PATHに追加(echo $PATHで確認しました)しても変化はないです。

/Library/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages
の中身は
README.txt            pip-9.0.1.dist-info
pycache            pkg_resources
easy_install.py            setuptools
pip                setuptools-28.8.0.dist-info

であり、このディレクトリのpipもディレクトリだったので中身を見ると
init.py    cmdoptions.py    locations.py    utils
main.py    commands    models        vcs
pycache    compat        operations    wheel.py
_vendor        download.py    pep425tags.py
basecommand.py    exceptions.py    req
baseparser.py    index.py    status_codes.py
このようになっていました。
使用OSはmac OS Sierra 10.12.4
pythonは公式ページからインストールしました。
解決方法をご存知の方、よろしくお願いします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • tell_k

    2017/04/09 21:08

    お使いの環境と、Python3.6をどのようにインストールしたのかを書くと回答がつきやすいと思います。

    キャンセル

回答 1

checkベストアンサー

0

もしかしたら、 python3 コマンドと同様にpip3 というコマンドでインストールされてるかもしれません。試しに which pip3 と打ってみてパスが表示されるか確認してみてください? 

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/04/15 15:07

    ありがとうございました。解決しました。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.33%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る

  • Python 3.x

    7428questions

    Python 3はPythonプログラミング言語の最新バージョンであり、2008年12月3日にリリースされました。