質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.50%

  • PHP

    20358questions

    PHPは、Webサイト構築に特化して開発されたプログラミング言語です。大きな特徴のひとつは、HTMLに直接プログラムを埋め込むことができるという点です。PHPを用いることで、HTMLを動的コンテンツとして出力できます。HTMLがそのままブラウザに表示されるのに対し、PHPプログラムはサーバ側で実行された結果がブラウザに表示されるため、PHPスクリプトは「サーバサイドスクリプト」と呼ばれています。

  • composer

    151questions

    Composerとは、PHP5.3.2以上で使用可能なパッケージ管理ツールです。指定ディレクトリ内だけでパッケージ管理します。

composerの使用時に生じるPHPのバージョンの不一致

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 951

gogandantesu

score 1

前提・実現したいこと

使用しているレンタルサーバーはロリポップのスタンダードプランです。
composerを使ってTwilio PHP SDKをインストールしようとしたところPHPのバージョンが条件を満たしていないという趣旨のエラーメッセージが吐かれます。
しかしphpinfo()で確認できるPHPバージョンもphp-vで確認できるバージョンが7と表示されているのにも関わらず、このエラーメッセージによると利用しているPHPバージョンが5.5.35となっております。

発生している問題・エラーメッセージ

Problem 1

  • This package requires php >=7.1 but your PHP version (5.5.35) does not satisfy that requirement.
    Problem 2
  • The requested package cakephp/cakephp (locked at 3.3.15, required as 3.4.*) is satisfiable by cakephp/cakephp[3.3.15] but these conflict with your requirements or minimum-stability.
    Problem 3
  • cakephp/cakephp 3.4.3 requires php >=5.6.0 -> your PHP version (5.5.35) does not satisfy that requirement.
  • cakephp/cakephp 3.4.2 requires php >=5.6.0 -> your PHP version (5.5.35) does not satisfy that requirement.
  • cakephp/cakephp 3.4.1 requires php >=5.6.0 -> your PHP version (5.5.35) does not satisfy that requirement.
  • cakephp/cakephp 3.4.0 requires php >=5.6.0 -> your PHP version (5.5.35) does not satisfy that requirement.
  • Installation request for cakephp/cakephp 3.4.* -> satisfiable by cakephp/cakephp[3.4.0, 3.4.1, 3.4.2, 3.4.3]

試したこと

補足情報(言語/FW/ツール等のバージョンなど)

より詳細な情報

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

+2

コマンドラインで実行しているPHPとWEBサーバー経由で実行されているPHPが別物ということはないでしょうか?

コマンドラインからphpinfoを表示した場合のphpのバージョンはおそらく5.5.35ですよね?
以下のコマンドを実行してみてください。

$ php -i | head

ロリポップのマニュアルには以下の記載があります。

PHP設定 / サーバー・プログラム / マニュアル - レンタルサーバーならロリポップ!
https://lolipop.jp/manual/user/php-setting/#p-php-ini

【SSHでphp5.6 / php5.5 / php5.4 / php5.3をご利用の場合】
以下のパスをしていただくことでご利用いただけます。
php5.6をご利用の場合
『/usr/local/php5.6/bin/php』のパスを指定
(以下省略)

ロリポップを利用したことないのでできるかわからないですが、
以下のようにパスを指定すればお望みのバージョンでPHPが実行できるのではないでしょうか?

↓うまくいけば、「version 7.1」のような文字列が表示されるはず。

$ /usr/local/php7.1/bin/php  -i | head

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/03/20 12:04

    おかげさまで無事に問題を解決することができました。
    とても分かりやすく教えていただきありがとうございましたm(_ _)m

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.50%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

  • 受付中

    重複しない選択肢のセレクトボックス

    cakephp2.7を使っています。 セレクトボックスの選択肢を、テーブルのデータにしたいのですが、 (例) id   name   posi 1    aaa      FW

  • 解決済

    cakephpがつながらない

    お世話になっております cakephpをエクリプスに実装したいのですが最初のページのエラーからぬけだせません 発生している問題・エラーメッセージ ( ! ) Fatal 

  • 解決済

    指定バージョンのCakePHPをインストールする方法について

    CakePHPのインストールに関する質問です。 Windows10、PHP 5.6.24という環境にCakePHPの3.1.14をインストールしたいのですが、 最新バージョ

  • 解決済

    AWSにてlaraval環境構築

    aws無料利用枠でLaravelの環境を構築しようとしていたところ、以下のようなエラーが出ており、困っております。 composer global require "lara

  • 解決済

    さくらのレンタルサーバにcakephp3をインストールしたい

    さくらのレンタルサーバ スタンダードで,さくらのレンタルサーバにCakePHP3を導入を参考にしてcakephp3をインストールしようと思っています. しかし,「10.CakeP

  • 受付中

    cakephp3のShellでphpQueryを使いたいです

    <?php require_once('phpQuery-onefile.php'); $doc = phpQuery::newDocumentFile('http

  • 解決済

    PHPのintl拡張が出来ない

    vagrantのサーバーを使って、cakephpでアプリを作ろうとしています。 centos7で、phpのバージョンは7です。 cakephpのサーバーを立ち上げようと思い

  • 解決済

    PHPMailerのセットアップ中にエラー

    PHP初心者です。現在、下記の情報を参考に、PHPMailerというメールライブラリをwindows10のxamppの中にインストールしようとしています。 https://gith

同じタグがついた質問を見る

  • PHP

    20358questions

    PHPは、Webサイト構築に特化して開発されたプログラミング言語です。大きな特徴のひとつは、HTMLに直接プログラムを埋め込むことができるという点です。PHPを用いることで、HTMLを動的コンテンツとして出力できます。HTMLがそのままブラウザに表示されるのに対し、PHPプログラムはサーバ側で実行された結果がブラウザに表示されるため、PHPスクリプトは「サーバサイドスクリプト」と呼ばれています。

  • composer

    151questions

    Composerとは、PHP5.3.2以上で使用可能なパッケージ管理ツールです。指定ディレクトリ内だけでパッケージ管理します。