質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.91%

【PHPStorm設定】fontを変えたときに勝手に全体の色が変わる

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 1,574

kuroneko-22

score 7

PHPStormの設定をもとに戻したい

PHPStormの色設定で誤操作をし、戻せなくなってしまいました。

元の設定:
Appearance > UI Options > Theme > IntellJを使用したまま、
Editor > Colors&Fonts > Font > Scheme > Monokaiに設定
⇒タブなどは白系のまま、Editorのみダーク系の背景で使用しておりました。

今回、fontを変更しようと思いいじっていたところ、
「fontがダーク系のため、全体のカラーテーマも合わせますか?」
といった内容のダイアログが出てきたときに、誤って「YES」を押してしまいました。
しかも、「次回表示しない」にチェックを入れてしまっていたため、詳細なアラート内容など把握できておりません。

アラートの詳細内容等ご提示できず、申し訳ございませんが、ダイアログをもう一度出す方法、または今回のダイアログと同様の設定を行う箇所についてご教授いただければ幸いです。
よろしくお願いいたします。

環境

Windows7
PHPStorm2016.3.3

追記

その場しのぎではありますが、直接configsフォルダの中身をいじってみました。

  1. PhpStorm上で全体のThemeをIntelliJに変更
  2. PhpStormのfontsでDefaultのコピーを作成(Default Copy)
  3. エクスプローラーからPhpStorm > configs > colors > Default Copy.iclsを開き、もともと使っていたfont設定(Monokai.icls)の中身をコピー(<scheme>はそのままにし、中身のみ変更)
  4. PhpStormを再起動

configsのファイルを直接いじったことはないので場合によってはキケンかもしれませんが、慣れない見た目がどうにも気持ち悪かったため、ひとまずこちらで対応いたしました。
やりたいことはできましたが、PhpStorm上でfontsなどをいじると戻ってしまうため、引き続き根本解決となるご回答をお待ちしております。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

+3

以下の手順でいかがでしょうか?

  1. Settings > Appearance > UI Options > ThemeDarculaIntellJに変更。
  2. Editor > Colors&Fonts > Font > SchemeDefaultMonokaiに変更。

また、ダイアログの内容は以下のものではないかと思います。

Looks like you have set a dark editor theme. Would you like to set dark theme for entire PhpStorm

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/03/10 11:06

    ご回答ありがとうございます!
    いただいた手順を試したところ、やはりfontを変更したところで全体のテーマがDarculaになってしまいました。

    ダイアログの内容はいただいたものだったかと思います。ご教示いただきありがとうございます!
    いただいたダイアログの内容で引き続き調べてみます。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.91%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る