質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.53%

  • Ruby on Rails

    8647questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

  • Ubuntu

    1746questions

    Ubuntuは、Debian GNU/Linuxを基盤としたフリーのオペレーティングシステムです。

  • Cloud9

    530questions

    Cloud9は、クラウドからのプログラミングが可能になるWebサービス。IDEとしての機能が搭載されており、GitHubやHerokuなど他ツールとの連携も可能です。ブラウザ上で動くため、デバイスに関係なく開発環境を準備できます。

  • ImageMagick

    114questions

    ImageMagickとは、画像の表示や操作を行うオープンソースのソフトウェアです。プログラムはCで書かれており、GIFやJPEG、PDFなど画像ファイルフォーマット100種類以上に対応しています。

Could not run the `identify` command. Please install ImageMagick.

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 1,440

s.k

score 249

前提・実現したいこと

paperclipを使用して、画像投稿をできるようにしたいです。

発生している問題・エラーメッセージ

写真を添付して保存ボタンを押すと以下のエラーが出ます。

Could not run the `identify` command. Please install ImageMagick.

こちらの記事を参考に進めたのですが、うまく行きません。。。

imagemagickはインストールしています。
ただ、インストールまで一悶着ありました。

最初にbrewでimagemagickをインストールすると失敗しましたので、brewをupdateしました。
その後、imagemagickをインストールすると成功しました。

$ brew install imagemagick★失敗★
Error: Unsupported special dependency :perl
Please report this bug:
・・・省略・・・

$ brew update

$ which convert★成功★
/home/ubuntu/.linuxbrew/bin/convert

$ brew install imagemagick
Warning: imagemagick-7.0.5-0 already installed

該当のソースコード

【config/development.rb】

  Paperclip.options[:image_magick_path] = "/usr/local/bin"
  Paperclip.options[:command_path] = "/usr/local/bin"
  def create
     @micropost = current_user.microposts.build(micropost_params)
     @micropost.save!
  end


      private

        def micropost_params
          params.require(:micropost).permit(:title, :lecture, :professor, :price, :content, :user_id, :photo)
        end

【micropost.rb】

# photoattachファイルとする。stylesで画像サイズを定義できる
  has_attached_file :photo, styles: { medium: "300x300>", thumb: "100x100>" }

  # ファイルの拡張子を指定(これがないとエラーが発生する)
  validates_attachment :photo, content_type: { content_type: ["image/jpg", "image/jpeg", "image/png", "image/gif"] }

ご経験ある方ご指摘お願いします!

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

check解決した方法

0

パスが間違っていたようです。

  Paperclip.options[:image_magick_path] = "/usr/local/bin"
  Paperclip.options[:command_path] = "/usr/local/bin"

ではありませんでした。

コンバートのパスを指定するんですね。

$ which convert
/home/ubuntu/.linuxbrew/bin/convert

ということでこうなります。

  Paperclip.options[:image_magick_path] = "/home/ubuntu/.linuxbrew/bin"
  Paperclip.options[:command_path] = "//home/ubuntu/.linuxbrew/bin"

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

同じタグがついた質問を見る

  • Ruby on Rails

    8647questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

  • Ubuntu

    1746questions

    Ubuntuは、Debian GNU/Linuxを基盤としたフリーのオペレーティングシステムです。

  • Cloud9

    530questions

    Cloud9は、クラウドからのプログラミングが可能になるWebサービス。IDEとしての機能が搭載されており、GitHubやHerokuなど他ツールとの連携も可能です。ブラウザ上で動くため、デバイスに関係なく開発環境を準備できます。

  • ImageMagick

    114questions

    ImageMagickとは、画像の表示や操作を行うオープンソースのソフトウェアです。プログラムはCで書かれており、GIFやJPEG、PDFなど画像ファイルフォーマット100種類以上に対応しています。