質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.54%

  • Ruby on Rails

    8658questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

TypeError: オブジェクトでサポートされていないプロパティまたはメソッドです。

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 3,410

pecchan

score 242

Ruby on Rails 初心者です。
Ruby on Railsは、現時点での最新を使っています。

Windows 8.1 Pro
ruby Ruby 2.3.3p222 (2016-11-21 revision 56859) [x64-mingw32]
Rails 5.0.1

以下のチュートリアルを参考に進んでます
https://railstutorial.jp/chapters/beginning?version=5.0#sec-rails_server

testコントローラ作成しルーティングを設定しました。

class TestController < ApplicationController
  def index
    @msg = "Hello"
  end
end
Rails.application.routes.draw do
  root "test#index"
end

これでhttp://localhost:3000/にアクセスすると以下のようなエラーが表示されます。
「TypeError: オブジェクトでサポートされていないプロパティまたはメソッドです。」

googleで調べると
coffee-script-source を 1.8.0 に戻すと良いとありました。
https://www.oiax.jp/books/rails3book/coffee-script-type-error.html

ここの記載通りにし早速rails serverを再起動しました。
すると再起動中にまた違うエラーが。
イメージ説明

Gemfileを見ると以下のバージョンでした
coffee-script-source (1.12.2)

もうどうしたら良いのか分かりません。。。
分かる居ましたら宜しくお願い致します。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

+1

Node.jsをインストールしましょう(coffee-script-sourceのバージョン指定は不要です)。

CoffeeScriptの実行にはJavaScriptエンジンが必要ですが、Windows付属のWSHはきわめて古いため、実行できずにエラーとなります。

Windows 7 の Rails で ExecJS が TypeError を吐くようになった

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/02/21 13:53

    有難う御座いました!!!
    Node.jsをインストール→表示されました!!

    キャンセル

同じタグがついた質問を見る

  • Ruby on Rails

    8658questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。