質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.10%

djangoで作ったアプリをHerokuにデプロイできない

解決済

回答 3

投稿

  • 評価
  • クリップ 0
  • VIEW 2,165

Udomomo

score 1479

DjangoGirlsJapanのガイドラインに従ってdjangoアプリを作っていますが、デプロイのところでエラーになります。

$ git push heroku master


と入力してデプロイしようとすると、

remote: Could not find a version that satisfies the requirement command-not-found==0.3 (from -r requirements.txt (line 2)) (from versions: )


というエラーが出ます。

この「command-not-found==0.3」というパッケージですが、手動でインストールしようとしてもそのようなバージョンはないといわれます。

$ pip install command-not-found==0.3
Collecting command-not-found==0.3
  Could not find a version that satisfies the requirement command-not-found==0.3 (from versions: )
No matching distribution found for command-not-found==0.3

しかし、pip freezeの結果を出力したrequirements.txtには、以下のようにcommand-not-foundパッケージが記載されています。

chardet==2.3.0
command-not-found==0.3
dj-database-url==0.4.1
Django==1.10.4
gunicorn==19.6.0
language-selector==0.1
pycurl==7.43.0
pygobject==3.20.0
python-apt==1.1.0b1
python-debian==0.1.27
python-systemd==231
requests==2.9.1
six==1.10.0
ssh-import-id==5.5
ufw==0.35
unattended-upgrades==0.1
urllib3==1.13.1
whitenoise==3.2.2
psycopg2==2.5.4

この場合どう対応すればよいでしょうか?

なお、プロジェクトのツリーは以下のようになっています。ガイドラインと唯一違う点は、virtualenvを作っていないことです。

djangogirls
├── Procfile
├── blog
│   ├── __init__.py
│   ├── __pycache__
│   │   ├── __init__.cpython-35.pyc
│   │   ├── admin.cpython-35.pyc
│   │   └── models.cpython-35.pyc
│   ├── admin.py
│   ├── apps.py
│   ├── migrations
│   │   ├── 0001_initial.py
│   │   ├── __init__.py
│   │   └── __pycache__
│   │       ├── 0001_initial.cpython-35.pyc
│   │       └── __init__.cpython-35.pyc
│   ├── models.py
│   ├── tests.py
│   └── views.py
├── db.sqlite3
├── manage.py
├── mysite
│   ├── __init__.py
│   ├── __pycache__
│   │   ├── __init__.cpython-35.pyc
│   │   ├── settings.cpython-35.pyc
│   │   └── urls.cpython-35.pyc
│   ├── local_settings.py
│   ├── settings.py
│   ├── urls.py
│   └── wsgi.py
├── requirements.txt
└── runtime.txt
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 3

+2

あれから仮想環境で作り直したらうまくいきました。(Could not find a versionエラーがまた出ましたが、requirements.txtから引っかかったものを消したら通りました)
tanihataさん、ありがとうございました!今後もDjangoアプリを作る予定なので、pip install --upgrade setuptoolsのやり方も覚えておきます。

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

checkベストアンサー

+1

command-not-found==0.3がいらんかもしれないですね!!
その一行消してやってみて下さい。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/12/06 19:54

    その一行を消し、その後も同様のエラーが出たので最終的にrequirements.txtを以下まで減らしました。
    chardet==2.3.0
    dj-database-url==0.4.1
    Django==1.10.4
    gunicorn==19.6.0
    pycurl==7.43.0
    requests==2.9.1
    six==1.10.0
    ssh-import-id==5.5
    ufw==0.35
    unattended-upgrades==0.1
    urllib3==1.13.1
    whitenoise==3.2.2
    psycopg2==2.5.4

    ただ、今度は
    Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-xs2pe01_/ssh-import-id/
    というエラーが出てしまっています。

    キャンセル

  • 2016/12/06 22:47

    http://buta9999.hatenablog.jp/entry/2014/01/21/142359に書いている

    pip install --upgrade setuptools
    これでそれは解決できないですか?

    キャンセル

0

http://buta9999.hatenablog.jp/entry/2014/01/21/142359に書いている

pip install --upgrade setuptools
これでそれは解決できないですか?

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.10%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる