質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.12%

Debian系のパッケージインストール(アップデート)方法について

解決済

回答 2

投稿

  • 評価
  • クリップ 0
  • VIEW 2,196

EzrealTrueshot

score 401

Debian系のパッケージインストール(アップデート)方法について教えて頂けませんでしょうか?

当方、RedHat系のlinux(yum管理)のものは少々いじったことがあるのですが、Debian系はまったく経験がなく困っております。

サーバーにZabbix-Agent(サーバーリソース監視ツール)をインストールしようと試みたところ下記エラーが出てしまいました。

The following packages have unmet dependencies:
 zabbix-agent : Depends: libc6 (>= 2.17) but 2.11.3-4+deb6u11 is to be installed
                Depends: libssl1.0.0 (>= 1.0.1) but it is not installable


libc6の最新パッケージをローカルに持ってきて、インストールしようとしても

root:~$ sudo dpkg -i libc6_2.19-18+deb8u6_amd64.deb

dpkg: regarding libc6_2.19-18+deb8u6_amd64.deb containing libc6:
 libc6 breaks locales (<< 2.19)
  locales (version 2.11.3-4+deb6u11) is present and installed.
dpkg: error processing libc6_2.19-18+deb8u6_amd64.deb (--install):
 installing libc6 would break locales, and
 deconfiguration is not permitted (--auto-deconfigure might help)
Errors were encountered while processing:
 libc6_2.19-18+deb8u6_amd64.deb

前のversionが残っているからダメと怒られてしまいます。

またもう一つの libssl の方ですが

root:~$ sudo dpkg -i libssl1.0.2_1.0.2j-1_amd64.deb

Selecting previously deselected package libssl1.0.2.
(Reading database ... 38743 files and directories currently installed.)
Unpacking libssl1.0.2 (from libssl1.0.2_1.0.2j-1_amd64.deb) ...
dpkg: error processing libssl1.0.2_1.0.2j-1_amd64.deb (--install):
 triggers ci file contains unknown directive `activate-noawait'
Errors were encountered while processing:
 libssl1.0.2_1.0.2j-1_amd64.deb


こちらは元々入っていないので、新規にインストールするだけでいいのかなと思ったのですが
activate-nowaitというのが含まれているのがいけないのか、これもまた怒られてしまいます。

上記2つの依存関係( libc6 と libssl )の解決方法を教えて頂けませんでしょうか?
何か足りない情報等ありましたら追記させて頂きます。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

checkベストアンサー

0

zabbixのサイトのインストール手順通りに実行すれば、依存関係にあるパッケージもまとめてインストールされるはずです。debファイルをダウンロードしてdpkgでインストールされているのでしょうか?

【zabbixサイトの手順(v3.4)】

Zabbix 3.4 for Debian 8:

# リポジトリ情報のパッケージをダウンロードして登録
$ wget http://repo.zabbix.com/zabbix/3.4/debian/pool/main/z/zabbix-release/zabbix-release_3.4-1+jessie_all.deb
$ dpkg -i zabbix-release_3.4-1+jessie_all.deb

# リポジトリ情報を更新
$ apt-get update

Example for installing Zabbix agent only.

# zabbixエージェントのパッケージをインストール
$ apt-get install zabbix-agent

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/11/09 18:32 編集

    root:~$ sudo lsb_release -a

    No LSB modules are available.
    Distributor ID: Debian
    Description: Debian GNU/Linux 6.0.10 (squeeze)
    Release: 6.0.10
    Codename: squeeze

    このような結果となっております。

    キャンセル

  • 2016/11/09 19:41

    Debian6用を使用する必要があるようです。Zabbix2.2 LTSまででZabbix3はサポートしていないようです。

    キャンセル

  • 2016/11/10 11:29

    ぶは;
    そうだったのですか、色々とご教示ありがとうございました。
    お手数おかけ致しました!

    キャンセル

0

Debian系でyumコマンドに相当するものはapt-getです。
参考サイト:[Ubuntu] apt-get まとめ

※yumのように依存関係を解決してくれます。
※dpkgはRedhat系でいうところのrpmコマンド相当なので、個別のパッケージを手動でインストールする場合などに使われます。

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/11/09 00:37

    回答ありがとうございます!
    apt-getコマンドをもう少し調べてみようと思います。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.12%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る