質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
85.44%
PHP

PHPは、Webサイト構築に特化して開発されたプログラミング言語です。大きな特徴のひとつは、HTMLに直接プログラムを埋め込むことができるという点です。PHPを用いることで、HTMLを動的コンテンツとして出力できます。HTMLがそのままブラウザに表示されるのに対し、PHPプログラムはサーバ側で実行された結果がブラウザに表示されるため、PHPスクリプトは「サーバサイドスクリプト」と呼ばれています。

composer

Composerとは、PHP5.3.2以上で使用可能なパッケージ管理ツールです。指定ディレクトリ内だけでパッケージ管理します。

Laravel 5

Laravel 5は、PHPフレームワークLaravelの最新バージョンで、2014年11月に発表予定です。ディレクトリ構造がが現行版より大幅に変更されるほか、メソッドインジェクションやFormRequestの利用が可能になります。

Q&A

解決済

2回答

4663閲覧

composer require laravelcollective/html コマンドを打つとエラーが出ます

honey_cake

総合スコア39

PHP

PHPは、Webサイト構築に特化して開発されたプログラミング言語です。大きな特徴のひとつは、HTMLに直接プログラムを埋め込むことができるという点です。PHPを用いることで、HTMLを動的コンテンツとして出力できます。HTMLがそのままブラウザに表示されるのに対し、PHPプログラムはサーバ側で実行された結果がブラウザに表示されるため、PHPスクリプトは「サーバサイドスクリプト」と呼ばれています。

composer

Composerとは、PHP5.3.2以上で使用可能なパッケージ管理ツールです。指定ディレクトリ内だけでパッケージ管理します。

Laravel 5

Laravel 5は、PHPフレームワークLaravelの最新バージョンで、2014年11月に発表予定です。ディレクトリ構造がが現行版より大幅に変更されるほか、メソッドインジェクションやFormRequestの利用が可能になります。

0グッド

0クリップ

投稿2016/10/12 02:31

ViewでFormを記述するために
composer require laravelcollective/html コマンドを打つとエラーが出ます。

エラー文は↓

Your requirements could not be resolved to an installable set of packages. Problem 1 - Installation request for laravelcollective/html ^5.3 -> satisfiable by laravelcollective/html[v5.3.0]. - Conclusion: remove laravel/framework v5.2.45 - Conclusion: don't install laravel/framework v5.2.45 - laravelcollective/html v5.3.0 requires illuminate/view 5.3.* -> satisfiable by illuminate/view[v5.3.0, v5.3.16, v5.3.4]. - don't install illuminate/view v5.3.0|don't install laravel/framework v5.2.45 - don't install illuminate/view v5.3.16|don't install laravel/framework v5.2.45 - don't install illuminate/view v5.3.4|don't install laravel/framework v5.2.45 - Installation request for laravel/framework (locked at v5.2.45, required as 5.2.*) -> satisfiable by laravel/framework[v5.2.45]. Installation failed, reverting ./composer.json to its original content.

どのように解決できるしょうか?

気になる質問をクリップする

クリップした質問は、後からいつでもMYページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

guest

回答2

0

/app/Providers/EventServiceProvider.phpで定義されているbootメソッドを引数なしに変更してからcomposer updateしてみましょうか。これでダメだったらララベルをアンインストールしてからcomposer updateしてください。ララベルのアンインストール方法はググってください。

/app/Providers/EventServiceProvider.php

php

1 public function boot() 2 { 3 parent::boot(); 4 }

投稿2016/10/12 05:32

fromageblanc

総合スコア2724

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

0

ベストアンサー

ララベルのバージョンが古いようですよ。

- Conclusion: remove laravel/framework v5.2.45 - Conclusion: don't install laravel/framework v5.2.45

ver5.2.45を削除してねっていってます。

投稿2016/10/12 02:39

fromageblanc

総合スコア2724

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

fromageblanc

2016/10/12 02:41

composer.json編集して、composer updateするのが良いかと。
honey_cake

2016/10/12 04:09

ありがとうございます! 早速、 ``` "require": { "php": ">=5.5.9", "laravel/framework": "5.2.*" ``` の5.2を5.3に変更して、composer updateしたのですが、 ``` [ErrorException] Declaration of App\Providers\EventServiceProvider::boot() should be compatible with Illuminate\Foundation\Support\Providers\EventServiceProvider::boot() Script php artisan optimize handling the post-update-cmd event returned with error code 1 ``` のエラーが出てきて、うまく行きませんでした???? composer.jsonの編集が良くなかったのでしょうか?
guest

あなたの回答

tips

太字

斜体

打ち消し線

見出し

引用テキストの挿入

コードの挿入

リンクの挿入

リストの挿入

番号リストの挿入

表の挿入

水平線の挿入

プレビュー

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
85.44%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問