質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.36%

Rake db:migrateを実行できない

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 7,225

itsuki

score 15

ubuntsでruby on railsを動かしたく、ドットインストールのRuby On Rails入門に沿って
①rails new app
②Gemfileの gem 'therubyracer',platform: :rubyをコメントアウトから外す

③appフォルダ内でrails sでサーバーの立ち上げ

④rails generate scaffold User name:string score:integer
まで実行し、いずれもエラーなく動きました。
しかし、次にrake db:migrateを実行しようとしたら、
rake aborted!
Don't know how to build task 'test:recent' (see --tasks)
というエラーが発生し、rake db:createなど多くのrakeコマンド(?)を実行しても必ず上記と同じエラーが発生してしまいました。
エラーを検索して、'test;recent'が出ている質問があまりないことや、rakeやbundleをアップデートするなどの方法を試しました。が、いずれもうまくいかなかったので質問させていただきました。よろしくお願いいたします。

---rake vesion---
rake, version 11.2.0

---ruby version---
ruby 2.3.1p112 (2016-04-26 revision 54768) [i386-linux-gnu]

---rails version---
Rails 4.0.2

---rake db;migrateを実行したときのエラー---
rake aborted!
Don't know how to build task 'test:recent' (see --tasks)
/var/lib/gems/2.3.0/gems/railties-4.0.2/lib/rails/test_unit/testing.rake:98:in block in <top (required)>' /var/lib/gems/2.3.0/gems/railties-4.0.2/lib/rails/test_unit/testing.rake:65:in <top (required)>'
/var/lib/gems/2.3.0/gems/activesupport-4.0.2/lib/active_support/dependencies.rb:223:in load' /var/lib/gems/2.3.0/gems/activesupport-4.0.2/lib/active_support/dependencies.rb:223:in block in load'
/var/lib/gems/2.3.0/gems/activesupport-4.0.2/lib/active_support/dependencies.rb:214:in load_dependency' /var/lib/gems/2.3.0/gems/activesupport-4.0.2/lib/active_support/dependencies.rb:223:in load'
/var/lib/gems/2.3.0/gems/railties-4.0.2/lib/rails/test_unit/railtie.rb:15:in block in <class:TestUnitRailtie>' /var/lib/gems/2.3.0/gems/railties-4.0.2/lib/rails/railtie.rb:201:in instance_exec'
/var/lib/gems/2.3.0/gems/railties-4.0.2/lib/rails/railtie.rb:201:in block in run_tasks_blocks' /var/lib/gems/2.3.0/gems/railties-4.0.2/lib/rails/railtie.rb:201:in each'
/var/lib/gems/2.3.0/gems/railties-4.0.2/lib/rails/railtie.rb:201:in run_tasks_blocks' /var/lib/gems/2.3.0/gems/railties-4.0.2/lib/rails/application.rb:243:in block in run_tasks_blocks'
/var/lib/gems/2.3.0/gems/railties-4.0.2/lib/rails/engine/railties.rb:17:in each' /var/lib/gems/2.3.0/gems/railties-4.0.2/lib/rails/engine/railties.rb:17:in each'
/var/lib/gems/2.3.0/gems/railties-4.0.2/lib/rails/application.rb:243:in run_tasks_blocks' /var/lib/gems/2.3.0/gems/railties-4.0.2/lib/rails/engine.rb:446:in load_tasks'
/var/lib/gems/2.3.0/gems/railties-4.0.2/lib/rails/railtie/configurable.rb:30:in method_missing' /home/zico/app2/Rakefile:6:in <top (required)>'
/var/lib/gems/2.3.0/gems/rake-11.2.0/exe/rake:27:in `<top (required)>'
(See full trace by running task with --trace)

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

どうやら、rake test:recenttest/unitに依存したタスクのようで、しかもtest/unitはRuby 2.2以降ではGemとして入れないといけないようです。

Gemfileにgem 'test-unit'を書き足してみてください。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/06/12 10:43

    回答ありがとうございます。Gemfileにgem 'test-unit'を追加した後にrake db:migrateコマンドを実行しました。すると、
    Could not find gem 'test-unit (>= 0) ruby' in the gems available on this machine.
    Run `bundle install` to install missing gems.
    が表示され、bundle installを行い、再びrake db:migrateコマンドを実行すると、
    rake aborted!
    Don't know how to build task 'test:recent' (see --tasks)
    が出ました。

    ---rake db:migrate---

    rake aborted!
    Don't know how to build task 'test:recent' (see --tasks)
    /var/lib/gems/2.3.0/gems/railties-4.0.2/lib/rails/test_unit/testing.rake:98:in `block in <top (required)>'
    /var/lib/gems/2.3.0/gems/railties-4.0.2/lib/rails/test_unit/testing.rake:65:in `<top (required)>'
    /var/lib/gems/2.3.0/gems/activesupport-4.0.2/lib/active_support/dependencies.rb:223:in `load'
    /var/lib/gems/2.3.0/gems/activesupport-4.0.2/lib/active_support/dependencies.rb:223:in `block in load'
    /var/lib/gems/2.3.0/gems/activesupport-4.0.2/lib/active_support/dependencies.rb:214:in `load_dependency'
    /var/lib/gems/2.3.0/gems/activesupport-4.0.2/lib/active_support/dependencies.rb:223:in `load'
    /var/lib/gems/2.3.0/gems/railties-4.0.2/lib/rails/test_unit/railtie.rb:15:in `block in <class:TestUnitRailtie>'
    /var/lib/gems/2.3.0/gems/railties-4.0.2/lib/rails/railtie.rb:201:in `instance_exec'
    /var/lib/gems/2.3.0/gems/railties-4.0.2/lib/rails/railtie.rb:201:in `block in run_tasks_blocks'
    /var/lib/gems/2.3.0/gems/railties-4.0.2/lib/rails/railtie.rb:201:in `each'
    /var/lib/gems/2.3.0/gems/railties-4.0.2/lib/rails/railtie.rb:201:in `run_tasks_blocks'
    /var/lib/gems/2.3.0/gems/railties-4.0.2/lib/rails/application.rb:243:in `block in run_tasks_blocks'
    /var/lib/gems/2.3.0/gems/railties-4.0.2/lib/rails/engine/railties.rb:17:in `each'
    /var/lib/gems/2.3.0/gems/railties-4.0.2/lib/rails/engine/railties.rb:17:in `each'
    /var/lib/gems/2.3.0/gems/railties-4.0.2/lib/rails/application.rb:243:in `run_tasks_blocks'
    /var/lib/gems/2.3.0/gems/railties-4.0.2/lib/rails/engine.rb:446:in `load_tasks'
    /var/lib/gems/2.3.0/gems/railties-4.0.2/lib/rails/railtie/configurable.rb:30:in `method_missing'
    /home/zico/app2/Rakefile:6:in `<top (required)>'
    /var/lib/gems/2.3.0/gems/rake-11.2.0/exe/rake:27:in `<top (required)>'
    (See full trace by running task with --trace)

    キャンセル

  • 2016/06/12 18:31

    ・sudo gem update rake
    ・bundle update rake
    ・rake db:migtate
    で実行できました!(何が原因か分かりませんでしたけど・・・)
    ありがとうございました!

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.36%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る