質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.35%

Java DJUnitの導入について

解決済

回答 1

投稿

  • 評価
  • クリップ 2
  • VIEW 5,466

kt3

score 18

現在のプロジェクトでJUnit、DJUnitを使うことになり勉強をしております。
JUnitは問題なく使えておりますがDJUnit導入にあたりインストール中にエラーが発生し
ネットで調べてみたところ現在使用中のEclipse Marsには対応していないとありました。

そこで質問なのでですがDJUnitはEclipse Juno辺りまでしか使用できないのでしょうか。
現在はMarsを使っているのですが、Junoでしか使用できないのであれば導入も検討中です。
詳しい方がいらっしゃればご教示いただきたいです。

よろしくお願いいたします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

手元のEclipse Marsで確認しましたが、動作しないみたいですね。

DJUnitはすでに長らくメンテナンスされておらず、公式にはEclipse4.x系の対応も行われていません。
なので、仮に今使えたとしても、今後いつ使えなくなるかは分かりません。

単にカバレッジツールをお求めなのであれば、EclEmmaの方をお勧めします。
操作感はDJUnitと少し異なりますが、カバレッジツールとしてできることはそれほど変わりません。

EclEmmaはマーケットプレイス経由でのインストールが楽です。

EclEmma - Java Code Coverage for Eclipse  
http://eclemma.org/

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/06/04 22:56

    >argiusさん
    素早い確認、解答ありがとうございます。
    やはりEclipse4.x系では動作しないのですね。
    現在早急にカバレッジツールが必要なわけではないのですが
    EclEmmaは調査し導入の検討はしてみます。


    キャンセル

  • 2016/06/04 23:02

    念のため。

    正確には、動作しないわけではないです。
    Eclipse Kepler(Eclipse 4.3) では動作しましたし、私も使っていました。
    4.4は未確認ですが、
    「Eclipse Mars(4.5)で動作しない」は確認したので、間違いないと思います。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.35%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る