質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.50%

  • Ruby

    7894questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails 4

    2454questions

    Ruby on Rails4はRubyによって書かれたオープンソースのウェブフレームワークです。 Ruby on Railsは「設定より規約」の原則に従っており、効率的に作業を行うために再開発を行う必要をなくしてくれます。

  • RubyGems

    336questions

    RubyGemsはRubyによるプログラミングのためのパッケージマネジメントツールです。ユーザはこれを使用することで、Rubyライブラリのダウンロードやアップデートや、依存関係の自動解決が可能になります。

Railsでbundle install 時にエラーが発生する。 Gem::InstallError: listen requires Ruby version >= 2.2.3, ~> 2.2

受付中

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 1,045

hirotto57

score 50

Railsでbundle install 時に下記エラーが出るようになりました。
Rubyのバージョンが関係していると思うのですが、解決策が分からず困っております。
解決策が分かる方教えて頂きたいです。
何卒宜しくお願い致します。

Gemfile
ruby '2.1.5'

エラー文
Gem::InstallError: listen requires Ruby version >= 2.2.3, ~> 2.2.
An error occurred while installing listen (3.1.3), and Bundler cannot continue.
Make sure that gem install listen -v '3.1.3' succeeds before bundling.

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

0

rubyのバージョンが悪いのではないでしょうか?
ruby -vでバージョンは確認できます。
もしくは、bunlderが利用しているrubyのバージョンが悪いのかも。
vender/bunle以下のバージョンを見るとどのバージョンのrubyを利用してるかわかりますよ

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/05/09 09:53

    エラー文からの推察でRubyのバージョンを、ruby '2.2.3' に変更。→ bundleできない。
    他の2.2系ならOKかもと思い、ruby '2.2.1' に変更。しても同じエラーが発生してしまいました。 他に思い当たる原因はありますでしょうか?

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.50%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

  • 解決済

    deviseとomniauthを使用したログイン機能の実装について

    railsでアプリケーションを作成しております。 今回deviseとomniauthというgemを導入し、アドレスとパスワードによるログイン及びTwitterと連携したログイン機能

  • 受付中

    railsチュートリアルのRSpecでエラーが発生する

    rails チュートリアル第3章を進めています。 $ rails generate rspec:install を実行すると以下のエラーが吐き出されます。 /User

  • 解決済

    ruby on railsのサーバーが起動しない

    前提・実現したいこと rubyをインストールし、ruby -vで確認済み Bundlerもインストールしており、-vで確認済み rails new rails-test

  • 解決済

    Bundle install エラー

    OSX El Capitan Homebrew 1.1.8 Bundler version 1.14.3 rails 4.2.6 ruby 2.3.1 rbenv 1.0

  • 解決済

    rails new のバージョン指定について

    前提・実現したいこと rails newにてアプリケーションを作成した際に、バージョンを5.0.0.1に指定をしました。 しかし作成されたアプリケーションは、指定したバージョン

  • 解決済

    Ruby on rails

    前提・実現したいこと Ruby on railsのテスト環境構築中です ターミナルから rails s  しても下記のエラーでつまずいています 発生している問題・エラ

  • 解決済

    Ruby on Railsでのtestに関する質問

    前提・実現したいこと Ruby on Railsにおいて以下のメッセージが出てしまったのですが、どうすれば正常にテストを行うことができるでしょうか? 発生している問題・エラーメ

  • 解決済

    Railsのサーバー起動に関して困っています。

    発生している問題・エラーメッセージ bin/rails s /Users/Takashi/.rbenv/versions/2.2.1/lib/ruby/2.2.0/rubygems

同じタグがついた質問を見る

  • Ruby

    7894questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails 4

    2454questions

    Ruby on Rails4はRubyによって書かれたオープンソースのウェブフレームワークです。 Ruby on Railsは「設定より規約」の原則に従っており、効率的に作業を行うために再開発を行う必要をなくしてくれます。

  • RubyGems

    336questions

    RubyGemsはRubyによるプログラミングのためのパッケージマネジメントツールです。ユーザはこれを使用することで、Rubyライブラリのダウンロードやアップデートや、依存関係の自動解決が可能になります。

  • トップ
  • Rubyに関する質問
  • Railsでbundle install 時にエラーが発生する。 Gem::InstallError: listen requires Ruby version >= 2.2.3, ~> 2.2