質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.50%

  • Ubuntu

    1474questions

    Ubuntuは、Debian GNU/Linuxを基盤としたフリーのオペレーティングシステムです。

Lubuntuでサスペンド時にロックされないようにしたい

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 4,854

cingyan

score 19

前提・実現したいこと

ubuntu15.04をインストールしてから、Lubuntuをインストールして、自宅のパソコンを使用しています。

サスペンドから復帰するとき、xscreensaverでロックされていてパスワードを求められるのですが、ロックしないように設定したいのですが方法が分からず、こちらで質問するに至った次第です。

試したこと

$ light-locker --no-lock-on-suspend
これを実行し、問題解決かと思っていましたが、次の日になってまたロックが掛かるという状態です。

補足情報

~/.Xresources
このファイルで設定できるような情報を得たのですが、何をどうすれば良いか分かりません。

xscreensaverのバージョンは、5.30です。

ロックが掛からない方法は分からないなら、xscreensaverを削除するという方法でも良いです。

画像も提示できるので参考にご覧ください。

イメージ説明
イメージ説明
$ light-locker --no-lock-on-suspend
このコマンドで、サスペンド復帰時に上の画像が表示されなくなったように思います。
何時間もサスペンドにしていると、この画像が出た時もあったような気がするという曖昧な話をしてすみません。手探りであらゆる方法を試しているので、記憶が曖昧です。

現在はサスペンドから復帰する時、以下の表示があります。
イメージ説明

サスペンド実行後、数秒後すぐに復帰を試みると、ロックは掛からずすぐに使用できます。

私の考えでは、上2枚の画像は、light-lockerというソフトだから、それを停止したので、xscreensaverだけが残ったのかと思います。全く素人の考えですが。

2016/5/1 追記

username@username-J3228:~$ sudo light-locker --no-lock-on-suspend
[sudo] password for username: 

 (light-locker:3996): WARNING : Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-yrGjFd8ul9: 接続を拒否されました
process 3996: arguments to dbus_message_new_method_call() were incorrect, assertion "path != NULL" failed in file ../../dbus/dbus-message.c line 1340.
This is normally a bug in some application using the D-Bus library.
このように表示されていたのですが、これが原因でしょうか。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

「次の日」というのはログインし直したら、ということでしょうか?
環境を用意できないのですが、light-locker: screen always automatically locked のコメントにある、~/.config/autostart/light-locker.desktop ファイルの Exec 箇所のオプションを調整すればできるかもしれません。
ファイルがなければ、/usr/share/applications/light-locker.desktop などに元のファイルがあると思うので、~/.config/autostart/ にコピーしてみてください。

あるいは、LXDE の場合は .desktop ファイルではなく、~/.config/lxsession/Lubuntu/autostart ファイルや /etc/xdg/lxsession/Lubuntu/autostart ファイル(全ユーザー共通)かもしれません。

(2016/04/28 21:42) 追記

同じバージョンではないのですが、Ubuntu 16.04 を調べました。

light-locker については、GUI で設定を変更できます。

  • 「設定」→「Light Lockerの設定」 (または light-locker-settings コマンド)
    「サスペンドする時にロックする」を ON→OFF に変更し、適用ボタンを押す

light-locker-settings コマンドで python のエラー(has no attribute 'get_pid_list')が出る場合は、下記コマンドでも light-locker の設定を変更することができます。

gsettings set apps.light-locker lock-on-suspend 'false'

また、xscreen-saver でロックがかかる原因はよくわからないのですが、下記設定を確認してください。

  • 「設定」→「スクリーンセーバー」 (または xscreensaver-demo コマンド)
    「画面をロックするまで」(チェックボックス)のチェックが付いていないことを確認

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/04/27 17:03

    御回答ありがとうございました。

    次の日は、ログオンしなおしたと言うことだと思います。
    思いますというのは、ログオンし直しでどう変化が出るか確認するために電源を落としたつもりはないのです。

    /.config/autostart/light-locker.desktop

    このパスはホームからのものとして見ました。

    Exec=
    このようになっていて記入はありませんでした。

    /usr/share/applications/light-locker.desktopここにアプリケーションがいくつもあり、
    [ LightLockerの設定 ]と[ スクリーンセーバー ]という同じ絵のアイコンがあったので、両方コピーして置いて試しましたが、変わりませんでした。

    また、autostartファイルは両方共白紙でした。

    試しに、以下を実行しバージョンアップすればできないかとやってみました。

    username@username-J3228:~$ sudo apt upgrade xscreensaver
    [sudo] password for username:
    パッケージリストを読み込んでいます... 完了
    依存関係ツリーを作成しています
    状態情報を読み取っています... 完了
    アップグレードパッケージを検出しています ... xscreensaver はすでに最新版です。
    完了

    と表示されますが、画像のようにバージョンが古いと英語で出ているのも疑問です。

    補足に画像などを加えましたのでよろしくお願いします。

    キャンセル

  • 2016/04/29 16:36

    2016/4/29 16:35 追記

    追記のご回答ありがとうございました。

    GUIでLight Lockerの
    [ light-lockerを有効にする ]をオフ
    [ サスペンドする時にロックする ]もオフにしてあります。

    また、Xscreen-saverのGUIでも、
    [ セーバーを無効にする ] に設定してあります。
    [ 画面をロックするまで ] はグレーアウトです。

    $ light-locker --no-lock-on-suspend
    このコマンドを実行したから、一番上と次の画像が出てロックすることはなくなったと思っていましたが、今日、またそのロックになってしまいました。
    一番上の画像と次の画像のロックがLight Lockだと思っているのですが、違うのでしょうか。
    それで、Light Lockになったり、Xscreen-saverになったりするようです。
    時には、ロックされずXscreen-saverのバージョンが古いなどといったメッセージが出ることもあります。
    動作が不安定ということでしょうか。

    教えていただいたコマンドの

    gsettings set apps.light-locker lock-on-suspend 'false'

    をしておきました。
    このまま、サスペンドからの復帰時、Light Lockerが出ないことを願います。

    スクリーンセーバーは使わないので、Xscreen-saverをアンインストールします。
    これで、問題はLight Lockerのみになるので、解決に近づくと思います。

    キャンセル

  • 2016/05/27 16:19

    gsettings set apps.light-locker lock-on-suspend 'false'

    これを実行して2日目になりますが、サスペンドからの復帰時にロックは掛からなくなりました。

    私が今までやっていた方法だと、ロックが掛かったり掛からなかったりしていましたので、もう少し様子を見てみたいと思います。

    キャンセル

  • 2016/06/02 15:41

    gsettings set apps.light-locker lock-on-suspend 'false'
    このコマンドを実行して8日目。一度もロックがかかりません。
    これで成功したことにします。
    貴重な情報、ありがとうございました。。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.50%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る

  • Ubuntu

    1474questions

    Ubuntuは、Debian GNU/Linuxを基盤としたフリーのオペレーティングシステムです。