質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
85.44%
Ruby on Rails 6

Ruby on Rails 6は、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

Q&A

解決済

1回答

3500閲覧

bundle installの結果、バージョンコンフリクトが起きてしまう

asm_t

総合スコア14

Ruby on Rails 6

Ruby on Rails 6は、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

0グッド

0クリップ

投稿2021/03/27 15:48

編集2021/03/27 16:08

プログラミング初心者です。
bundle installを実行すると、以下のようなエラーが返ってきます。
調べたところ、「バージョンコンフリクト」が起こってしまったようです。
色々と試しましたがどうしても解決できないため、
ご教示いただけますと幸いです。
なお、Gemfileを編集しました。
よろしくお願いいたします。

bundle installの結果

Bundler could not find compatible versions for gem "railties": In Gemfile: jquery-rails (= 3.0.4) was resolved to 3.0.4, which depends on railties (< 5.0, >= 3.0) rails (= 6.1.3) was resolved to 6.1.3, which depends on railties (= 6.1.3)

試したこと① $ gem listで確認

$ gem list *** LOCAL GEMS *** actioncable (6.1.3) actionmailbox (6.1.3) actionmailer (6.1.3) actionpack (6.1.3, 6.1.1) actiontext (6.1.3) actionview (6.1.3, 6.1.1) activejob (6.1.3) activemodel (6.1.3, 6.1.1) activerecord (6.1.3) activestorage (6.1.3) activesupport (6.1.3, 6.1.1) addressable (2.7.0) benchmark (default: 0.1.0) bigdecimal (default: 2.0.0) bindex (0.8.1) bootsnap (1.7.3) builder (3.2.4) bundler (2.2.11, default: 2.1.2) byebug (11.1.3) capybara (3.35.3) cgi (default: 0.1.0) childprocess (3.0.0) concurrent-ruby (1.1.8) crass (1.0.6) csv (default: 3.1.2) date (default: 3.0.0) dbm (default: 1.1.0) delegate (default: 0.1.0) did_you_mean (default: 1.4.0) erubi (1.10.0) etc (default: 1.1.0) fcntl (default: 1.0.0) ffi (1.15.0) fiddle (default: 1.0.0) fileutils (default: 1.4.1) forwardable (default: 1.3.1) getoptlong (default: 0.1.0) globalid (0.4.2) i18n (1.8.9) io-console (default: 0.5.3) ipaddr (default: 1.2.2) irb (default: 1.2.1) jbuilder (2.11.2) json (default: 2.3.0) listen (3.5.0) logger (default: 1.4.2) loofah (2.9.0) mail (2.7.1) marcel (0.3.3) matrix (default: 0.2.0) method_source (1.0.0) mimemagic (0.3.6) mini_mime (1.0.2) mini_portile2 (2.5.0) minitest (5.14.4) msgpack (1.4.2) mutex_m (default: 0.1.0) mysql2 (0.5.3) net-pop (default: 0.1.0) net-smtp (default: 0.1.0) net-telnet (0.2.0) nio4r (2.5.7) nokogiri (1.11.2 x86_64-darwin) observer (default: 0.1.0) open3 (default: 0.1.0) openssl (default: 2.1.2) ostruct (default: 0.2.0) power_assert (1.1.5) prime (default: 0.1.1) pstore (default: 0.1.0) psych (default: 3.1.0) public_suffix (4.0.6) puma (5.2.2) racc (1.5.2, default: 1.4.16) rack (2.2.3) rack-mini-profiler (2.3.1) rack-proxy (0.6.5) rack-test (1.1.0) rails (6.1.3) rails-dom-testing (2.0.3) rails-html-sanitizer (1.3.0) railties (6.1.3) rake (13.0.3) rb-fsevent (0.10.4) rb-inotify (0.10.1) rdoc (default: 6.2.1) readline (default: 0.0.2) readline-ext (default: 0.1.0) regexp_parser (2.1.1) reline (default: 0.1.2) rexml (default: 3.2.3) rss (default: 0.2.8) rubyzip (2.3.0) sass-rails (6.0.0) sassc (2.4.0) sassc-rails (2.1.2) sdbm (default: 1.0.0) selenium-webdriver (3.142.7) semantic_range (3.0.0) singleton (default: 0.1.0) spring (2.1.1) sprockets (4.0.2) sprockets-rails (3.2.2) sqlite3 (1.4.2) stringio (default: 0.1.0) strscan (default: 1.0.3) test-unit (3.3.4) thor (1.1.0) tilt (2.0.10) timeout (default: 0.1.0) tracer (default: 0.1.0) turbolinks (5.2.1) turbolinks-source (5.2.0) tzinfo (2.0.4) uri (default: 0.10.0) web-console (4.1.0) webdrivers (4.6.0) webpacker (5.2.1) webrick (default: 1.6.0) websocket-driver (0.7.3) websocket-extensions (0.1.5) xmlrpc (0.3.0) xpath (3.2.0) yaml (default: 0.1.0) zeitwerk (2.4.2) zlib (default: 1.1.0)

エラーメッセージにある「railties」や「rails」に関しては特にバージョンが複数入っているわけではありませんでした。
「jquery-rails」が上記に含まれていないことが何か影響していることはあるのでしょうか。

試したこと② $ sudo gem cleanupを実行した上でbundle installを実行

$ sudo gem cleanup Cleaning up installed gems... Attempting to uninstall webdrivers-4.5.0 Successfully uninstalled webdrivers-4.5.0 Attempting to uninstall sqlite3-1.4.1 Successfully uninstalled sqlite3-1.4.1 Attempting to uninstall semantic_range-2.3.1 Successfully uninstalled semantic_range-2.3.1 Attempting to uninstall regexp_parser-2.0.3 Successfully uninstalled regexp_parser-2.0.3 Attempting to uninstall rails-6.1.1 Successfully uninstalled rails-6.1.1 Attempting to uninstall rake-13.0.1 Successfully uninstalled rake-13.0.1 Attempting to uninstall rack-mini-profiler-2.3.0 Successfully uninstalled rack-mini-profiler-2.3.0 Attempting to uninstall puma-5.1.1 Successfully uninstalled puma-5.1.1 Attempting to uninstall puma-5.2.0 Successfully uninstalled puma-5.2.0 Attempting to uninstall puma-5.2.1 Successfully uninstalled puma-5.2.1 Attempting to uninstall nio4r-2.5.4 Successfully uninstalled nio4r-2.5.4 Attempting to uninstall msgpack-1.3.3 Successfully uninstalled msgpack-1.3.3 Attempting to uninstall minitest-5.13.0 Successfully uninstalled minitest-5.13.0 Attempting to uninstall listen-3.4.1 Successfully uninstalled listen-3.4.1 Attempting to uninstall jbuilder-2.11.0 Successfully uninstalled jbuilder-2.11.0 Attempting to uninstall i18n-1.8.7 Successfully uninstalled i18n-1.8.7 Attempting to uninstall ffi-1.14.2 Successfully uninstalled ffi-1.14.2 Attempting to uninstall capybara-3.34.0 Successfully uninstalled capybara-3.34.0 Attempting to uninstall bootsnap-1.5.1 Successfully uninstalled bootsnap-1.5.1 Attempting to uninstall bootsnap-1.6.0 Successfully uninstalled bootsnap-1.6.0 Attempting to uninstall bootsnap-1.7.1 Successfully uninstalled bootsnap-1.7.1 Attempting to uninstall bootsnap-1.7.2 Successfully uninstalled bootsnap-1.7.2 Attempting to uninstall msgpack-1.4.1 Successfully uninstalled msgpack-1.4.1 Attempting to uninstall nokogiri-1.11.1-x86_64-darwin Successfully uninstalled nokogiri-1.11.1-x86_64-darwin Attempting to uninstall mimemagic-0.3.5 Successfully uninstalled mimemagic-0.3.5 Attempting to uninstall nio4r-2.5.5 Successfully uninstalled nio4r-2.5.5 Attempting to uninstall minitest-5.14.3 Successfully uninstalled minitest-5.14.3 Attempting to uninstall i18n-1.8.8 Successfully uninstalled i18n-1.8.8 Attempting to uninstall regexp_parser-1.8.2 Successfully uninstalled regexp_parser-1.8.2 Attempting to uninstall railties-6.1.1 Successfully uninstalled railties-6.1.1 Attempting to uninstall actiontext-6.1.1 Successfully uninstalled actiontext-6.1.1 Attempting to uninstall actionmailer-6.1.1 Successfully uninstalled actionmailer-6.1.1 Attempting to uninstall actionmailbox-6.1.1 Successfully uninstalled actionmailbox-6.1.1 Attempting to uninstall actioncable-6.1.1 Successfully uninstalled actioncable-6.1.1 Attempting to uninstall activestorage-6.1.1 Successfully uninstalled activestorage-6.1.1 Attempting to uninstall activerecord-6.1.1 Successfully uninstalled activerecord-6.1.1 Attempting to uninstall activejob-6.1.1 Successfully uninstalled activejob-6.1.1 Clean up complete $ bundle install Bundler could not find compatible versions for gem "railties": In Gemfile: jquery-rails (= 3.0.4) was resolved to 3.0.4, which depends on railties (< 5.0, >= 3.0) rails (= 6.1.3) was resolved to 6.1.3, which depends on railties (= 6.1.3)

全く同じエラーメッセージが返ってくるだけでした。

試したこと③ $ bundle update --conservative rails railties

Bundler could not find compatible versions for gem "railties": In Gemfile: jquery-rails (= 3.0.4) was resolved to 3.0.4, which depends on railties (< 5.0, >= 3.0) rails (= 6.1.3) was resolved to 6.1.3, which depends on railties (= 6.1.3)

全く同じエラーメッセージが返ってくるだけでした。

補足情報①

【Gemfileの中身】 source 'https://rubygems.org' ruby '2.7.0' #ruby-gemset=railstutorial_rails_4_0 gem 'rails','6.1.3' gem 'pg', '0.15.1' group :development, :test do gem 'rspec-rails', '2.13.1' end group :test do gem 'selenium-webdriver', '2.35.1' gem 'capybara', '2.1.0' end gem 'sass-rails', '4.0.5' gem 'uglifier', '2.1.1' gem 'coffee-rails', '4.0.1' gem 'jquery-rails', '3.0.4' gem 'turbolinks', '1.1.1' gem 'jbuilder', '1.0.2' group :doc do gem 'sdoc', '0.3.20', require: false end group :production do gem 'rails_12factor', '0.0.2' end

補足情報②

【PostgreSQLのversion】
psql (PostgreSQL) 13.2

気になる質問をクリップする

クリップした質問は、後からいつでもMYページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

guest

回答1

0

ベストアンサー

「bundle installの結果」に出たエラーメッセージのとおり、jquery-rails 3.0.4はRails 3あるいは4系列専用です(railties (< 5.0, >= 3.0))。

Rails 6と使うには、jquery-railsのバージョンをもっと新しいものにする必要があります(現在ある最新版の4.4.0はRails 6で利用可能です)。

投稿2021/03/28 00:29

maisumakun

総合スコア145295

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

asm_t

2021/03/28 03:21

maisumakun様 ご回答いただきましてありがとうございます。 jquery-railsのバージョンを上げる方法を調べている中で、 そもそもjqueryが入っていなかったことに気づき、yarn add jqueryでjqueryを導入しました。 Rails6からはgemの追加が必要なくなり、代わりにwebpackで必要な情報をインストールする形になったのですね。 (参考記事https://qiita.com/iiyama_makoto/items/940b130fd20540fd70f1) お陰様でjquery-railsのエラーが解消できました! 本当にありがとうございました。
guest

あなたの回答

tips

太字

斜体

打ち消し線

見出し

引用テキストの挿入

コードの挿入

リンクの挿入

リストの挿入

番号リストの挿入

表の挿入

水平線の挿入

プレビュー

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
85.44%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問