質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
87.20%
Qt

QtはGUIプログラムの開発で広く使われているクロスプラットフォーム開発のフレームワークです。

Python

Pythonは、コードの読みやすさが特徴的なプログラミング言語の1つです。 強い型付け、動的型付けに対応しており、後方互換性がないバージョン2系とバージョン3系が使用されています。 商用製品の開発にも無料で使用でき、OSだけでなく仮想環境にも対応。Unicodeによる文字列操作をサポートしているため、日本語処理も標準で可能です。

解決済

qmake のqt version のアップデート方法

Suisoniumu
Suisoniumu

総合スコア11

Qt

QtはGUIプログラムの開発で広く使われているクロスプラットフォーム開発のフレームワークです。

Python

Pythonは、コードの読みやすさが特徴的なプログラミング言語の1つです。 強い型付け、動的型付けに対応しており、後方互換性がないバージョン2系とバージョン3系が使用されています。 商用製品の開発にも無料で使用でき、OSだけでなく仮想環境にも対応。Unicodeによる文字列操作をサポートしているため、日本語処理も標準で可能です。

1回答

0評価

0クリップ

192閲覧

投稿2022/05/21 12:38

編集2022/05/23 21:08

前提

pythonのpyqtgraphを使ってグラフを書きたいです。
qtのバージョンが古いといわれるのですが、アップデートの方法を調べてもわかりません。

発生している問題・エラーメッセージ

Traceback (most recent call last): File "C:\Users\moto\OneDrive\ドキュメント\プログラミング\python\pyQtgraph\example.py", line 9, in <module> import pyqtgraph as pg File "C:\Users\moto\anaconda3\lib\site-packages\pyqtgraph\__init__.py", line 17, in <module> from .colors import palette File "C:\Users\moto\anaconda3\lib\site-packages\pyqtgraph\colors\palette.py", line 1, in <module> from ..Qt import QtGui File "C:\Users\moto\anaconda3\lib\site-packages\pyqtgraph\Qt\__init__.py", line 402, in <module> raise Exception('pyqtgraph requires Qt version >= %d.%d (your version is %s)' % (versionReq[0], versionReq[1], QtVersion)) Exception: pyqtgraph requires Qt version >= 5.12 (your version is 5.9.7)

該当のソースコード

python

import numpy as np import pyqtgraph as pg from pyqtgraph.Qt import QtCore

試したこと

・qtをオンラインインストーラーを使って再インストール
→治らなかった
・anacondaの中のqtを使っているように見えるので、
conda update qt
を試しました。何も変化しませんでした。

補足情報(FW/ツールのバージョンなど)

コマンドプロンプトでバージョンを確認した結果
C:\Users\user>qmake -v
QMake version 3.1
Using Qt version 5.9.7 in C:/Users/user/anaconda3/Library/lib

良い質問の評価を上げる

以下のような質問は評価を上げましょう

  • 質問内容が明確
  • 自分も答えを知りたい
  • 質問者以外のユーザにも役立つ

評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

気になる質問をクリップする

クリップした質問は、後からいつでもマイページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

  • プログラミングに関係のない質問
  • やってほしいことだけを記載した丸投げの質問
  • 問題・課題が含まれていない質問
  • 意図的に内容が抹消された質問
  • 過去に投稿した質問と同じ内容の質問
  • 広告と受け取られるような投稿

評価を下げると、トップページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

jbpb0

2022/05/21 22:49

> conda update qt を試しました。何も変化しませんでした。 https://anaconda.org/anaconda/qt を見ると、現状ではWindows用は5.9.7までしか用意されてませんね condaでアップデートしたいなら、これを入れるとか https://anaconda.org/conda-forge/qt ただし、conda-forgeから何か入れると、他のにも影響が及ぶかもしれないので、condaで仮想環境を作って、その中に入れることをお勧めします
Suisoniumu

2022/05/23 12:07

>参考 これを見たら解決しました。ありがとうございます

まだ回答がついていません

会員登録して回答してみよう

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
87.20%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問

同じタグがついた質問を見る

Qt

QtはGUIプログラムの開発で広く使われているクロスプラットフォーム開発のフレームワークです。

Python

Pythonは、コードの読みやすさが特徴的なプログラミング言語の1つです。 強い型付け、動的型付けに対応しており、後方互換性がないバージョン2系とバージョン3系が使用されています。 商用製品の開発にも無料で使用でき、OSだけでなく仮想環境にも対応。Unicodeによる文字列操作をサポートしているため、日本語処理も標準で可能です。