質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
85.44%
Xcode 7

Xcode 7は、ソフトウェア開発のためのアップルの統合開発環境であるXcodeのバージョン。UIを作成するために用いるグラフィカルツールです。iOS9/OS X El Capitan/watchOS2に対応。Swift 2コンパイラーが搭載されています。

iOS

iOSとは、Apple製のスマートフォンであるiPhoneやタブレット端末のiPadに搭載しているオペレーションシステム(OS)です。その他にもiPod touch・Apple TVにも搭載されています。

App Store

App Storeは、Apple社が運営する、iPhone、iPod touch、iPad向けアプリケーションソフトのダウンロードサービスです。携帯電話、Wi-Fiによる無線通信に対応しており、多くのアプリケーションをダウンロード、インストールすることができます。世界中の開発者によってアプリケーションが登録されており、有償のソフトもあればフリーソフトも多く登録されています。

Q&A

解決済

2回答

19456閲覧

【iOS】互換性の設定

beginner_e

総合スコア9

Xcode 7

Xcode 7は、ソフトウェア開発のためのアップルの統合開発環境であるXcodeのバージョン。UIを作成するために用いるグラフィカルツールです。iOS9/OS X El Capitan/watchOS2に対応。Swift 2コンパイラーが搭載されています。

iOS

iOSとは、Apple製のスマートフォンであるiPhoneやタブレット端末のiPadに搭載しているオペレーションシステム(OS)です。その他にもiPod touch・Apple TVにも搭載されています。

App Store

App Storeは、Apple社が運営する、iPhone、iPod touch、iPad向けアプリケーションソフトのダウンロードサービスです。携帯電話、Wi-Fiによる無線通信に対応しており、多くのアプリケーションをダウンロード、インストールすることができます。世界中の開発者によってアプリケーションが登録されており、有償のソフトもあればフリーソフトも多く登録されています。

0グッド

0クリップ

投稿2016/04/19 00:03

編集2016/04/19 00:28

###実現したいこと
AppStoreで表示されている互換性をすべてのiPhoneに対応するように設定したいです

実現したいこと

###発生している問題
AppStoreで互換性がiphone5s以降になってしまいます。

発生している問題

###試したこと
課題に対してアプローチしたことを記載してください
以下のサイトに書かれていることはやってみました。

デバイス互換性がない!?

解決方法がわかる方がいらっしゃいましたら、ご教示お願いいたします。

気になる質問をクリップする

クリップした質問は、後からいつでもMYページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

guest

回答2

0

ベストアンサー

XCODE上の設定で、
「Deployment Info」 > 「Deployment Target」
という部分があるかと思います。ここに設定したOSのバージョンが、動作保証最低バージョンになったかと思います。
現状、「8.0」に設定されているのではないでしょうか?

XCODE7であれば、PROJECT設定のInfoタブと、TARGETSの設定のGeneralタブ、に設定が存在します。
古いXCODEの場合だと、infoと、Summaryに同じような設定があります。
どちらも、複数ありますが、ターゲットに合わせて設定し、再度リリース申請してください。

投稿2016/04/19 02:34

ItoTomonori

総合スコア1283

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

beginner_e

2016/04/19 02:39

>現状、「8.0」に設定されているのではないでしょうか? その通りです。 >ターゲットに合わせて設定し、再度リリース申請してください。 初心者なので、どのように設定すれば良いかわかりません。 初歩中の初歩かもしれませんが、ご教示いただけないでしょうか。 お手数をお掛けしますがよろしくお願いします。
ItoTomonori

2016/04/19 02:50

単に、ターゲットにしたいiOSのバージョンを選択するだけです。 ただ、iPhone4sも、実際にはiOS9がなんとか動作するようですので、実際には、AppStore側でコントロールされているような気がします(iOS8以降を指定すると、iPhone4sをリストに出さないみたいな)。 なので、現状は、アップしていただいたキャプチャを見る限りでは、7.0に設定しておけば、「iPhoneおよびiPad、、、」となるのかな?というように見えますので、7.0に設定してみるとか?ではないでしょうか。
beginner_e

2016/04/19 03:11

回答有り難うございました。 承知しました。 一度試してみます。
ItoTomonori

2016/04/19 04:20

設定変更して、ビルドが無事に通ったとしても、 実際に対象端末で動作をさせたら、うまく動かない・・・なんてことは、多々ありますので、対応端末での、最低限シミュレータ上でのテストもわすれないでください。 また、古いiOSや、iPhone4sなどのテストを行うには、古いXCODEから、無理矢理ひっぱってくるなど、手間かかりますが、このあたりは先人がいろいろネットで記載されておりますので、参考にされると、よろしいかと。
guest

0

全てのiPhoneとありますが、iPhoneのどの機種からを想定していますでしょうか。
たとえばiPhone3GSとかは対応するのでしょうか。
現実的なところだと、iPhone4SまたはiPhone5以降ぐらいだと思いますが。

投稿2016/04/19 01:35

YasuhiroMiyake

総合スコア1336

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

beginner_e

2016/04/19 01:36

回答ありがとうございます。 iPhone4S以降を想定しています。
YasuhiroMiyake

2016/04/19 02:24

ハードウェア制限は何もかけていないということでよかったでしょうか。(設定欄に自動的に追加されていないか確認出来ていますでしょうか。)
beginner_e

2016/04/19 02:41

>ハードウェア制限は何もかけていないということでよかったでしょうか。(設定欄に自動的に追加されていないか確認出来ていますでしょうか。) 申し訳ありません。 まだ初心者ですので、どこを見ればよいかご教示いただけないでしょうか。 お手数をお掛けしますがよろしくお願いします。
guest

あなたの回答

tips

太字

斜体

打ち消し線

見出し

引用テキストの挿入

コードの挿入

リンクの挿入

リストの挿入

番号リストの挿入

表の挿入

水平線の挿入

プレビュー

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
85.44%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問