質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
85.48%
scikit-learn

scikit-learnは、Pythonで使用できるオープンソースプロジェクトの機械学習用ライブラリです。多くの機械学習アルゴリズムが実装されていますが、どのアルゴリズムも同じような書き方で利用できます。

Python

Pythonは、コードの読みやすさが特徴的なプログラミング言語の1つです。 強い型付け、動的型付けに対応しており、後方互換性がないバージョン2系とバージョン3系が使用されています。 商用製品の開発にも無料で使用でき、OSだけでなく仮想環境にも対応。Unicodeによる文字列操作をサポートしているため、日本語処理も標準で可能です。

Q&A

解決済

1回答

7937閲覧

ModuleNotFoundError: No module named 'sklearn.svm.classes'

mochmoch

総合スコア39

scikit-learn

scikit-learnは、Pythonで使用できるオープンソースプロジェクトの機械学習用ライブラリです。多くの機械学習アルゴリズムが実装されていますが、どのアルゴリズムも同じような書き方で利用できます。

Python

Pythonは、コードの読みやすさが特徴的なプログラミング言語の1つです。 強い型付け、動的型付けに対応しており、後方互換性がないバージョン2系とバージョン3系が使用されています。 商用製品の開発にも無料で使用でき、OSだけでなく仮想環境にも対応。Unicodeによる文字列操作をサポートしているため、日本語処理も標準で可能です。

0グッド

0クリップ

投稿2021/01/17 11:31

日本語文章のネガポジ判定のコードでModuleNotFoundError: No module named 'sklearn.svm.classes'が出力される

日本語コメントのネガポジ判定をしようと思い、asariを試してみることにしました。

起こっている問題

githubに乗っている以下のコードを実行するとエラーが出力されました。

python

1from asari.api import Sonar 2 3sonar = Sonar() 4sonar.ping(text="広告多すぎる♡")

console

1Traceback (most recent call last): 2 File "/home/mochi/workspace/asari-test/run.py", line 3, in <module> 3 sonar = Sonar() 4 File "/home/mochi/.local/share/virtualenvs/asari-test-T_FwOZ3x/lib/python3.9/site-packages/asari/api.py", line 21 5, in __init__ 6 self.estimator = joblib.load(model_file) 7 File "/home/mochi/.local/share/virtualenvs/asari-test-T_FwOZ3x/lib/python3.9/site-packages/joblib/numpy_pickle.py 8", line 585, in load 9 obj = _unpickle(fobj, filename, mmap_mode) 10 File "/home/mochi/.local/share/virtualenvs/asari-test-T_FwOZ3x/lib/python3.9/site-packages/joblib/numpy_pickle.py", line 504, in _unpickle 11 obj = unpickler.load() 12 File "/usr/lib/python3.9/pickle.py", line 1212, in load 13 dispatch[key[0]](self) 14 File "/usr/lib/python3.9/pickle.py", line 1528, in load_global 15 klass = self.find_class(module, name) 16 File "/usr/lib/python3.9/pickle.py", line 1579, in find_class 17 __import__(module, level=0) 18ModuleNotFoundError: No module named 'sklearn.svm.classes'

試してみたこと

  • asariのバージョンを落とす

0.0.4から0.0.3へダウングレードしましたが、次のエラーが出力されました

File "/home/mochi/workspace/asari-test/run.py", line 1, in <module> from asari.api import Sonar File "/home/mochi/.local/share/virtualenvs/asari-test-T_FwOZ3x/lib/python3.9/site-packages/asari/api.py", line 12, in <module> from sklearn.externals import joblib ImportError: cannot import name 'joblib' from 'sklearn.externals' (/home/mochi/.local/share/virtualenvs/asari-test-T_FwOZ3x/lib/python3.9/site-packages/sklearn/externals/__init__.py)
  • pythonのバージョンを落とす

pyenvを使い3.9.1から3.6.12にダウングレードしましたが同様のエラーが出ました

  • janomeのバージョンを落とす

janome-0.4.1から0.3.7に落としましたが同様のエラーが出ました

環境

Manjaro Linux x86_64
Python 3.9.1
pipenv, version 2020.11.15

pip

1$ pip freeze 2asari==0.0.4 3Janome==0.4.1 4joblib==1.0.0 5numpy==1.19.5 6pandas==1.2.0 7python-dateutil==2.8.1 8pytz==2020.5 9scikit-learn==0.24.0 10scipy==1.6.0 11six==1.15.0 12threadpoolctl==2.1.0

気になる質問をクリップする

クリップした質問は、後からいつでもMYページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

guest

回答1

0

ベストアンサー

ModuleNotFoundError: No module named 'sklearn.svm.classes'

joblib エラー #7
に「FutureWarning: The sklearn.svm.classes module is deprecated in version 0.22 and will be removed in version 0.24.」って書いてあります

scikit-learn==0.24.0

を古いのに変えたら、動くでしょう

投稿2021/01/17 12:18

jbpb0

総合スコア7651

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

mochmoch

2021/01/19 00:24

sklearnを0.23.0にダウングレードしたところ、無事動作しました。 ありがとうございました。
guest

あなたの回答

tips

太字

斜体

打ち消し線

見出し

引用テキストの挿入

コードの挿入

リンクの挿入

リストの挿入

番号リストの挿入

表の挿入

水平線の挿入

プレビュー

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
85.48%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問