質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
85.44%
Laravel

LaravelとはTaylor Otwellによって開発された、オープンソースなPHPフレームワークです。Laravelはシンプルで表現的なシンタックスを持ち合わせており、ウェブアプリケーション開発の手助けをしてくれます。

バージョン管理

バージョン管理はコンピューター上にファイルとして格納されているドキュメント・プログラム・その他の情報の変更履歴等を管理するものです

composer

Composerとは、PHP5.3.2以上で使用可能なパッケージ管理ツールです。指定ディレクトリ内だけでパッケージ管理します。

Q&A

解決済

1回答

4836閲覧

Laravel 6.x→7.xバージョンアップ時のエラーが解消できない

退会済みユーザー

退会済みユーザー

総合スコア0

Laravel

LaravelとはTaylor Otwellによって開発された、オープンソースなPHPフレームワークです。Laravelはシンプルで表現的なシンタックスを持ち合わせており、ウェブアプリケーション開発の手助けをしてくれます。

バージョン管理

バージョン管理はコンピューター上にファイルとして格納されているドキュメント・プログラム・その他の情報の変更履歴等を管理するものです

composer

Composerとは、PHP5.3.2以上で使用可能なパッケージ管理ツールです。指定ディレクトリ内だけでパッケージ管理します。

0グッド

0クリップ

投稿2021/01/02 10:35

前提・実現したいこと

Laravelのバージョンを6.4.0から7.xにアップデートしたい

https://qiita.com/A-Kira/items/439cbcb001d71f3a3557
を参照してLaravelのバージョンアップをした際、以下のエラーメッセージが発生しました。

何か対処法などご存じの方はご教示お願いいたします。。。

発生している問題・エラーメッセージ

> composer update Loading composer repositories with package information Updating dependencies Your requirements could not be resolved to an installable set of packages. Problem 1 - Conclusion: don't install laravel/framework v7.0.0 (conflict analysis result) - Conclusion: don't install laravel/framework v7.0.1 (conflict analysis result) - Conclusion: don't install laravel/framework v7.0.2 (conflict analysis result) - Conclusion: don't install laravel/framework v7.0.3 (conflict analysis result) - Conclusion: don't install laravel/framework v7.0.4 (conflict analysis result) - Conclusion: don't install laravel/framework v7.0.5 (conflict analysis result) - Conclusion: don't install laravel/framework v7.0.6 (conflict analysis result) - Conclusion: don't install laravel/framework v7.0.7 (conflict analysis result) - Conclusion: don't install laravel/framework v7.0.8 (conflict analysis result) - Conclusion: don't install laravel/framework v7.1.0 (conflict analysis result) - Conclusion: don't install laravel/framework v7.1.1 (conflict analysis result) - Conclusion: don't install laravel/framework v7.1.2 (conflict analysis result) - Conclusion: don't install laravel/framework v7.1.3 (conflict analysis result) - Conclusion: don't install laravel/framework v7.2.0 (conflict analysis result) - Conclusion: don't install laravel/framework v7.2.1 (conflict analysis result) - Conclusion: don't install laravel/framework v7.2.2 (conflict analysis result) - Conclusion: don't install laravel/framework v7.3.0 (conflict analysis result) - Conclusion: don't install laravel/framework v7.4.0 (conflict analysis result) - Conclusion: don't install laravel/framework v7.5.0 (conflict analysis result) - Conclusion: don't install laravel/framework v7.5.1 (conflict analysis result) - Conclusion: don't install laravel/framework v7.5.2 (conflict analysis result) - Conclusion: don't install laravel/framework v7.6.0 (conflict analysis result) - Conclusion: don't install laravel/framework v7.6.1 (conflict analysis result) - Conclusion: don't install laravel/framework v7.6.2 (conflict analysis result) - Conclusion: don't install laravel/framework v7.7.0 (conflict analysis result) - Conclusion: don't install laravel/framework v7.7.1 (conflict analysis result) - Conclusion: don't install laravel/framework v7.8.0 (conflict analysis result) - Conclusion: don't install laravel/framework v7.8.1 (conflict analysis result) - Conclusion: don't install laravel/framework v7.9.0 (conflict analysis result) - Conclusion: don't install laravel/framework v7.9.1 (conflict analysis result) - Conclusion: don't install laravel/framework v7.9.2 (conflict analysis result) - Conclusion: don't install laravel/framework v7.10.0 (conflict analysis result) - Conclusion: don't install laravel/framework v7.10.1 (conflict analysis result) - Conclusion: don't install laravel/framework v7.10.2 (conflict analysis result) - Conclusion: don't install laravel/framework v7.10.3 (conflict analysis result) - Conclusion: don't install laravel/framework v7.11.0 (conflict analysis result) - Conclusion: don't install laravel/framework v7.12.0 (conflict analysis result) - Conclusion: don't install laravel/framework v7.13.0 (conflict analysis result) - Conclusion: don't install laravel/framework v7.14.0 (conflict analysis result) - Conclusion: don't install laravel/framework v7.14.1 (conflict analysis result) - Conclusion: don't install laravel/framework v7.15.0 (conflict analysis result) - Conclusion: don't install laravel/framework v7.16.0 (conflict analysis result) - Conclusion: don't install laravel/framework v7.16.1 (conflict analysis result) - Conclusion: don't install laravel/framework v7.17.0 (conflict analysis result) - Conclusion: don't install laravel/framework v7.17.1 (conflict analysis result) - Conclusion: don't install laravel/framework v7.17.2 (conflict analysis result) - Conclusion: don't install laravel/framework v7.18.0 (conflict analysis result) - Conclusion: don't install laravel/framework v7.19.0 (conflict analysis result) - Conclusion: don't install laravel/framework v7.19.1 (conflict analysis result) - Conclusion: don't install laravel/framework v7.20.0 (conflict analysis result) - Conclusion: don't install laravel/framework v7.21.0 (conflict analysis result) - Conclusion: don't install laravel/framework v7.22.0 (conflict analysis result) - Conclusion: don't install laravel/framework v7.22.1 (conflict analysis result) - Conclusion: don't install laravel/framework v7.22.2 (conflict analysis result) - Conclusion: don't install laravel/framework v7.22.3 (conflict analysis result) - Conclusion: don't install laravel/framework v7.22.4 (conflict analysis result) - Conclusion: don't install laravel/framework v7.23.0 (conflict analysis result) - Conclusion: don't install laravel/framework v7.23.1 (conflict analysis result) - Conclusion: don't install laravel/framework v7.23.2 (conflict analysis result) - Conclusion: don't install laravel/framework v7.24.0 (conflict analysis result) - Conclusion: don't install laravel/framework v7.25.0 (conflict analysis result) - Conclusion: don't install laravel/framework v7.26.0 (conflict analysis result) - Conclusion: don't install laravel/framework v7.26.1 (conflict analysis result) - Conclusion: don't install laravel/framework v7.27.0 (conflict analysis result) - Conclusion: don't install laravel/framework v7.28.0 (conflict analysis result) - Conclusion: don't install laravel/framework v7.28.1 (conflict analysis result) - Conclusion: don't install laravel/framework v7.28.2 (conflict analysis result) - Conclusion: don't install laravel/framework v7.28.3 (conflict analysis result) - Conclusion: don't install laravel/framework v7.28.4 (conflict analysis result) - Conclusion: don't install laravel/framework v7.29.0 (conflict analysis result) - Conclusion: don't install laravel/framework v7.29.1 (conflict analysis result) - Conclusion: don't install laravel/framework v7.29.2 (conflict analysis result) - Conclusion: don't install laravel/framework v7.29.3 (conflict analysis result) - Conclusion: don't install laravel/framework v7.30.0 (conflict analysis result) - Conclusion: don't install laravel/framework v7.30.1 (conflict analysis result) - laravel/ui[v1.2.0, ..., 1.x-dev] require illuminate/support ~5.8|^6.0 -> satisfiable by illuminate/support[v5.8.0, ..., 5.8.x-dev, v6.0.0, ..., 6.x-dev]. - Only one of these can be installed: illuminate/support[v5.4.0, ..., 5.8.x-dev, v6.0.0, ..., 6.x-dev, v7.0.0, ..., 7.x-dev, v8.0.0, ..., 8.x-dev], laravel/framework[v7.0.0, ..., 7.x-dev]. laravel/framework replaces illuminate/support and thus cannot coexist with it. - Root composer.json requires laravel/framework ^7.0 -> satisfiable by laravel/framework[v7.0.0, ..., 7.x-dev]. - Root composer.json requires laravel/ui ^1.2 -> satisfiable by laravel/ui[v1.2.0, v1.3.0, 1.x-dev]. Use the option --with-all-dependencies (-W) to allow upgrades, downgrades and removals for packages currently locked to specific versions. PS C:\Users\riiic\cookingDiary> yum install --enablerepo=remi,remi-php70 php php-devel php-mbstring php-pdo php-gd

補足情報(FW/ツールのバージョンなど)

Composer version 2.0.1
PHP 7.3.9

気になる質問をクリップする

クリップした質問は、後からいつでもMYページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

guest

回答1

0

ベストアンサー

laravel/uiをv2にする。
composer.jsonのrequire-devでインストールしていたならrequireに移動させる。

投稿2021/01/02 10:50

kawax

総合スコア10377

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

退会済みユーザー

退会済みユーザー

2021/01/04 10:19

教えていただきありがとうございます! requireにlaravel/uiは移動してありましたが、"laravel/ui": "^1.2"になっていたので "laravel/ui": "^2.1"を設定したら composer updateコマンドが通りました。
guest

あなたの回答

tips

太字

斜体

打ち消し線

見出し

引用テキストの挿入

コードの挿入

リンクの挿入

リストの挿入

番号リストの挿入

表の挿入

水平線の挿入

プレビュー

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
85.44%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問