質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.49%

  • Linux

    3887questions

    Linuxは、Unixをベースにして開発されたオペレーティングシステムです。日本では「リナックス」と呼ばれています。 主にWebサーバやDNSサーバ、イントラネットなどのサーバ用OSとして利用されています。 上位500のスーパーコンピュータの90%以上はLinuxを使用しています。 携帯端末用のプラットフォームAndroidは、Linuxカーネル上に構築されています。

  • CentOS

    2759questions

    CentOSは、主にRed Hat Enterprise Linux(RHEL)をベースにした、フリーのソフトウェアオペレーティングシステムです。

  • yum

    153questions

    yumコマンドは、UNIX系OSのRPMパッケージのインストールなどを行うためのプログラムのことです。

  • rpm

    27questions

    rpmコマンドは、UNIX系OSのroot権限でのみ利用可能なコマンドで、 RPMパッケージのインストールなどができます。

CentOS 6から要らないパッケージを削除したい

解決済

回答 1

投稿

  • 評価
  • クリップ 1
  • VIEW 1,280

shi_ue

score 4315

初めて質問します。ドキドキしますね。

実現したいこと・知りたいこと

yumまたはrpmでeximパッケージを削除したい。

rpmで--nodepで削除することは可能ですが、そうすると上のパッケージに影響が出るんでしょうか?
それを調べるのはどうすればいいんでしょうか?

発生している問題

何日か前にyumでアップデートしたところeximがアップデートされていました。
元々eximは使っておらず、最初から入っていたか、何かの依存性の関係でインストールされたものだと思います。

しかし、勝手に/usr/sbin/sendmailのシンボリックリンクを書き換えてしまい、後からコンパイルしたqmailのsendmailが使えなくなっていました。

そもそもqmailなんて止めろ、というのは置いておいてください

eximは使っていないので、削除しようとしましたが、以下の依存性があって削除できません。

↑なぜかコードの種類を入れないと強制的にハイライトする・・・Text作ってくれないかなぁ

【依存性】
cronie
cronie-anacron
crontabs
sysstat

現状の対処方法

yum.confを変更して、eximをアップデートしないようにしました。

補足情報

CentOS 6.7

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

+3

cronie が /usr/sbin/sendmail を必要としているので、/usr/sbin/sendmail を含む(Provides する)パッケージ(postfix, sendmail, exim, opensmtpd など)が少なくとも 1つインストールされている必要があります。

cronie-anacron, crontabs, sysstat は cronie と依存関係があるので、cronie をアンインストールしようとして一緒にリストアップされるのでしょう。

yum/RPM 以外でインストールした qmail を使うのでしたら、以下のいずれかになると思います。

  • /usr/sbin/sendmail を含むパッケージを 1つ残したまま、alternatives で qmail を優先するようにする
  • (shi_ue さんの方法) /usr/sbin/sendmail を含むパッケージを 1つ残したまま、シンボリックリンクで qmail を使うようにし、yum.conf でパッケージをアップデートしないようにする。
  • パッケージ管理を放棄して "--nodeps" で削除し、シンボリックリンクで qmail を使うようにする。
(alternatives 例)
# /usr/sbin/alternatives --install /usr/sbin/sendmail mta /var/qmail/bin/sendmail 200
    優先度を 200 など、大きい値に設定する(postfix:30, sendmail:90, exim(EPEL):10)

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/03/26 15:03 編集

    やっぱり強制的に消してしまうと、パッケージ管理を放棄するしかないんですね。

    もし、--nodepsで消したとして、cronieがアップデートするときに復活したりしないんでしょうか?
    それとも依存関係でエラーが出るんでしょうか?
    その辺りも含めて、「放棄する」ということになってしまうのでしょうか・

    キャンセル

  • 2016/03/26 15:33

    cronie アップデートで /usr/sbin/sendmail を提供するパッケージも一緒にインストールしようとしますね。
    exim を除外しても、ssmtp(EPEL) とか postfix とか。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.49%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

  • 解決済

    man ページが入ってない?

    新しく作った環境で man が表示されないので調べていたら、どうも man ページが入ってないっぽいことに気が付きました。 今までと環境が違うところといえば、Vagrant+Vir

  • 解決済

    phpenvのinstallでmcrypt.h not foundが出て進めない

    表題の件です。 下記の手順でインストールを行いました。  実行環境 CentOS release 6.5  インストール手順 $ curl -L https:

  • 解決済

    Phalcon3 インストール

    VagrantでPhalcon3をインストールしたいのですが、うまくいかないです。 環境は centos7 Apache 2.4.6 Mysql 5.7 PHP7

  • 解決済

    CentOS6.7にkmod-drbdなるものをインストールする

    おはようございます。 仕事で、昔作られたphpののプロジェクトを動かすための環境をCentOS6.7のVagrantで整備しているものです。 その当時の資料に、入っていたソ

  • 解決済

    centosでのiwconfig

    centos 7.2において、iwconfigを使用したいと考えております。 下記、URLを参考にして行っておりますが http://www.atmarkit.co.jp/

  • 解決済

    file_get_contentsでSSLエラー

    PHP 7.0.11 CakePHP 2.8.9 CentOS7 Apache 2.4.23 の環境でサイトを運用しております。 システム開発の経験は多いですが、サー

  • 解決済

    phpenv でエラー

    phpenvでphpバージョンをインストールしようとしたら、下記のように出ました。どのように解決するのでしょうか? |  BUILD ERROR  | Here are 

  • 解決済

    仮想環境下でnvmのインストールがうまくいかない。

     問題概要 ▪︎環境 CentOS6.7 VertualBox + Vagrant 現在、書籍「JS+Node.jsによるWebクローラー/ネットエージェント[開発テクニック]

同じタグがついた質問を見る

  • Linux

    3887questions

    Linuxは、Unixをベースにして開発されたオペレーティングシステムです。日本では「リナックス」と呼ばれています。 主にWebサーバやDNSサーバ、イントラネットなどのサーバ用OSとして利用されています。 上位500のスーパーコンピュータの90%以上はLinuxを使用しています。 携帯端末用のプラットフォームAndroidは、Linuxカーネル上に構築されています。

  • CentOS

    2759questions

    CentOSは、主にRed Hat Enterprise Linux(RHEL)をベースにした、フリーのソフトウェアオペレーティングシステムです。

  • yum

    153questions

    yumコマンドは、UNIX系OSのRPMパッケージのインストールなどを行うためのプログラムのことです。

  • rpm

    27questions

    rpmコマンドは、UNIX系OSのroot権限でのみ利用可能なコマンドで、 RPMパッケージのインストールなどができます。