質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.92%

railsアプリケーションをHerokuにデプロイした際のエラーが解決できない。

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 147

ym0814

score 1

いつの間にかなのですが、該当のアプリケーション内でrails -v すると

Your Ruby version is 2.6.3, but your Gemfile specified 2.6.2


と出てくるようになりました。。
一度切り替えがうまくいったと思って、ターミナルを起動し直すと同じエラーが吐かれて、そこから変更できなくなってしまいました。

参考にしたサイトは下記です。
https://qiita.com/ryu1_f/items/ee308dd1c11faf6f3eb0

$ which bundler
/Users/hoge/.rbenv/shims/bundler 
※hoge = 私のユーザー名
$ which ruby
/Users/hoge/.rbenv/shims/ruby
$ rbenv versions
* 2.6.2 (set by /Users/hoge/rails/rails-community/.ruby-version)

この辺りの影響もあってHerokuにデプロイしようとすると、

###### WARNING:
       There is a known bundler bug with your version of Ruby

       Your version of Ruby contains a problem with the built-in integration of bundler. If
       you encounter a bundler error you need to upgrade your Ruby version. We suggest you upgrade to:

       2.6.6

       For more information see:
         https://devcenter.heroku.com/articles/bundler-version#known-upgrade-issues


のようなエラーが吐かれます。
※これが原因なのかは推測ではありますが;

またHerokuの方で吐かれているエラー?なのかよくわからないところもあって、どこを直せばいいのかわからなくなってきています。
Herokuのエラー全文は下記URLになります。(下記のURLから観覧できますか・・・?できなかったようにエラーぽいところを書いておきます。)
▼Build Log
https://dashboard.heroku.com/apps/rails-community-ym/activity/builds/fef88eb0-9895-46e3-8b10-f8a5ed18ced0

Herokuのエラーらしき箇所

###### WARNING:
       There is a known bundler bug with your version of Ruby

       Your version of Ruby contains a problem with the built-in integration of bundler. If
       you encounter a bundler error you need to upgrade your Ruby version. We suggest you upgrade to:

       2.6.6

       For more information see:
         https://devcenter.heroku.com/articles/bundler-version#known-upgrade-issues
-----> bundler 1.17.3を使用して依存関係をインストールする
       実行:bundle install --without development:test --path vendor / bundle --binstubs vendor / bundle / bin -j4 --deployment
       依存関係tzinfo-data(> = 0)は、Bundlerがインストールしているプラ​​ットフォームでは使用されません。Bundlerはruby用にインストールしていますが、依存関係はx86-mingw32、x86-mswin32、x64-mingw32、javaのみです。これらのプラットフォームをバンドルに追加するには、 `bundle lock --add-platform x86-mingw32 x86-mswin32 x64-mingw32 java`を実行します。
HEADS UP! i18n 1.1 changed fallbacks to exclude default locale.
       But that may break your application.

       If you are upgrading your Rails application from an older version of Rails:

       Please check your Rails app for 'config.i18n.fallbacks = true'.
       If you're using I18n (>= 1.1.0) and Rails (< 5.2.2), this should be
       'config.i18n.fallbacks = [I18n.default_locale]'.
       If not, fallbacks will be broken in your app by I18n 1.1.x.
        If you are starting a NEW Rails application, you can ignore this notice.

       For more info see:
       https://github.com/svenfuchs/i18n/releases/tag/v1.1.0
-----> Detecting rake tasks
 !
 !     Could not detect rake tasks
 !     ensure you can run `$ bundle exec rake -P` against your app
 !     and using the production group of your Gemfile.
 !     rake aborted!
NameError: undefined local variable or method `config' for main:Object


↑を実行すると

rake aborted!


となります。こちらも一度コマンドが通るようにいろいろ調べて試したのですが、
ターミナル閉じたら、また通らなくなりました;

そして一番最後に

!プッシュが拒否され、Rubyアプリをコンパイルできませんでした。
!プッシュに失敗しました


というエラーが吐かれて、デプロイできないです;

昨日丸一日使って調べまわり、試していたのですが、なかなか前に進まず;
どれから手をつけたらいいのか、混乱してきたので、どなたかご教示いただけますと幸いです。
どうぞ、よろしくお願いいたします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • gouf

    2020/07/14 19:46

    開発環境の Ruby バージョンを 2.6.6 に変更し、Gemfile 内での Ruby バージョンを同様に変更した場合になにか変化は見られますか

    キャンセル

  • ym0814

    2020/07/14 22:11

    gouf様

    バージョン変えると、なぜか指定されているのは2.6.2だよっていってくるんです;
    Your Ruby version is 2.6.2, but your Gemfile specified 2.6.6
    この辺もかなり謎で、、、
    ちなみに、rbenv versionsでどのバージョン使っているか確認はしていて、2.6.6になっているのは確認しています。
    * 2.6.6 (set by /Users/hoge/rails/rails-community/.ruby-version)

    キャンセル

回答 1

check解決した方法

0

デプロイの際のエラーではなく、cssファイルで@importを使っていたのが原因でした。
apllication.css→apllication.scssに変更してデプロイしたら無事に通りました。
エラーをみていた方、お騒がせし申し訳ございませんでした。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.92%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る