質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.92%

macにてrstanをinstallする方法

受付中

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 301

unser

score 24

前提・実現したいこと

mac(ver 10.13.6)にrstanをinstallしたいのですが,
errorが出てしまい困惑しています。

発生している問題・エラーメッセージ

https://qiita.com/Yoshiki443/items/abd08f550293e6a03290

こちらのサイトを参照して,rstanをinstallしたのですが,libraryにrstanなんて
ないよと返ってきてしまいます。

> install.packages('rstan', repos='https://cloud.r-project.org/', dependencies=TRUE)
also installing the dependencies ‘V8’, ‘shinystan’

 URL 'https://cloud.r-project.org/src/contrib/V8_3.2.0.tar.gz' を試しています 
Content type 'application/x-gzip' length 680510 bytes (664 KB)
==================================================
downloaded 664 KB

 URL 'https://cloud.r-project.org/src/contrib/shinystan_2.5.0.tar.gz' を試しています 
Content type 'application/x-gzip' length 2400413 bytes (2.3 MB)
==================================================
downloaded 2.3 MB

 URL 'https://cloud.r-project.org/src/contrib/rstan_2.21.1.tar.gz' を試しています 
Content type 'application/x-gzip' length 1166938 bytes (1.1 MB)
==================================================
downloaded 1.1 MB

* installing *source* package ‘V8’ ...
**  パッケージ ‘V8’ の解凍および MD5 サムの検証に成功しました 
** using staged installation
Using PKG_CFLAGS=-I/usr/local/opt/v8/include -I/usr/local/opt/v8/libexec/include
Using PKG_LIBS=-L/usr/local/opt/v8/libexec -lv8 -lv8_libplatform
-----------------------------[ ANTICONF ]-------------------------------
Configuration failed to find the libv8 engine library. Try installing:
 * deb: libv8-dev or libnode-dev (Debian / Ubuntu)
 * rpm: v8-devel (Fedora, EPEL)
 * brew: v8 (OSX)
 * csw: libv8_dev (Solaris)
To use a custom libv8, set INCLUDE_DIR and LIB_DIR manually via:
R CMD INSTALL --configure-vars='INCLUDE_DIR=... LIB_DIR=...'
---------------------------[ ERROR MESSAGE ]----------------------------
<stdin>:1:10: fatal error: 'v8.h' file not found
#include <v8.h>
         ^~~~~~
1 error generated.
------------------------------------------------------------------------
ERROR: configuration failed for package ‘V8’
* removing ‘/usr/local/Cellar/r/4.0.0_1/lib/R/library/V8’
Warning in install.packages :
  installation of package ‘V8’ had non-zero exit status
ERROR: dependency ‘V8’ is not available for package ‘rstan’
* removing ‘/usr/local/Cellar/r/4.0.0_1/lib/R/library/rstan’
Warning in install.packages :
  installation of package ‘rstan’ had non-zero exit status
ERROR: dependency ‘rstan’ is not available for package ‘shinystan’
* removing ‘/usr/local/Cellar/r/4.0.0_1/lib/R/library/shinystan’
Warning in install.packages :
  installation of package ‘shinystan’ had non-zero exit status

The downloaded source packages are in
    ‘/private/var/folders/4l/z3sct5js7mq675xtd3tb1jd80000gn/T/RtmpY3TZj8/downloaded_packages’
Updating HTML index of packages in '.Library'
Making 'packages.html' ... done
> library(stan)
 library(stan) でエラー:  ‘stan’ という名前のパッケージはありません 

試したこと

rにてlibrary()で確認すると
rstantools        Tools for Developing R Packages
Interfacing with 'Stan'
という,rstantoolsはあることが確認できました。

こちらを消去してやる方法を今検討していますが,状況を下手に悪化させないため,まずこちらで質問させていただきます。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

0

以下の箇所にlibv8 engin libraryが見つからなくて失敗したとあり、環境ごとのインストールの指示が表示されています。

Configuration failed to find the libv8 engine library. Try installing:
* deb: libv8-dev or libnode-dev (Debian / Ubuntu)
* rpm: v8-devel (Fedora, EPEL)
* brew: v8 (OSX)
* csw: libv8_dev (Solaris)
To use a custom libv8, set INCLUDE_DIR and LIB_DIR manually via:
R CMD INSTALL --configure-vars='INCLUDE_DIR=... LIB_DIR=...'

macとのことなのでOSXの指示通りで良いと思います。
私はmacを持っていないので試せませんが、ターミナルからbrew install v8と実行し、
再度stanをインストールしてみてはどうでしょうか。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2020/07/15 12:11

    またしてもできませんでした...
    環境設定のため,ネットで訪ねるのは難しいため
    自粛が解除したら,わかるかたに直接聞いてみます。

    今回はありがとうございました。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.92%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る