質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.93%

laravel サーバーが実行できない

受付中

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 241

maflo110105

score 11

前提・実現したいこと

phpをやっとわかってきたかなというレベルで、
laravelを勉強したく、『laravel入門 第2版 著:掌田津那乃』の指示通りインストールしましたが上手くできなくて迷路に迷い込んでいます

インストール後、アプリを実行しようと試みましたが、
$ php artisan serve
とすると、

発生している問題・エラーメッセージ

PHP Warning:  require(C:\Users\xxx\Desktop\laravelapp/vendor/autoload.php): failed to open stream: No such file or directory in C:\Users\xxx\Desktop\laravelapp\artisan on line 18

Warning: require(C:\Users\xxx\Desktop\laravelapp/vendor/autoload.php): failed to open stream: No such file or directory in C:\Users\xxx\Desktop\laravelapp\artisan on line 18
PHP Fatal error:  require(): Failed opening required 'C:\Users\xxx\Desktop\laravelapp/vendor/autoload.php' (include_path='C:\xampp\php\PEAR') in C:\Users\xxx\Desktop\laravelapp\artisan on line 18

Fatal error: require(): Failed opening required 'C:\Users\xxx\Desktop\laravelapp/vendor/autoload.php' (include_path='C:\xampp\php\PEAR') in C:\Users\xxx\Desktop\laravelapp\artisan on line 18

と出まして、サーバーと接続できてません

試したこと

色々調べて、同じ様な質問の方がいたので、
$ composer installとやってみたところ

Composer could not find a composer.json file in C:\Users\xxx\Desktop
To initialize a project, please create a composer.json file as described in the https://getcomposer.org/ "Getting Started" section

と出まして

composer.jsonをインストールをしようとして、
https://qiita.com/sano1202/items/50e5a05227d739302761を見てトライしましたが

『"require"の後に、パッケージ名:バージョン番号で、インストールしたいライブラリを指定します。
今回はロガーライブラリであるMonologをインストールしてみましょう。
別のライブラリについてはPackagist(Composerリポジトリ)を参照します。』

の所で、勉強不足のためか内容がわからない状態です

1、まずもって、composer installで正しい処理なのでしょうか?
2、また、composer.jsonのインストールで正しいのであれば、その後の必要な作業をどうすればいいのでしょうか?
3、全く違うのであれば、別の方法をご教授頂きたいです

laravel迷子になっています
よろしくお願いします

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

+1

Composer could not find a composer.json file in C:\Users\xxx\Desktop

composer install を実行する場所が、C:\Users\xxx\Desktopになっています。

C:\Users\xxx\Desktop\laravelappをカレントディレクトリにして、実行してみてください。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2020/07/13 02:48

    早速の回答ありがとうございます。

    実行すると
    Loading composer repositories with package information
    Installing dependencies (including require-dev) from lock file
    Your requirements could not be resolved to an installable set of packages.

    Problem 1
    - This package requires php ^7.2.5 but your PHP version (7.2.3) does not satisfy that requirement.
    Problem 2
    - Installation request for laravel/framework v7.18.0 -> satisfiable by laravel/framework[v7.18.0].
    - laravel/framework v7.18.0 requires php ^7.2.5 -> your PHP version (7.2.3) does not satisfy that requirement.
    Problem 3
    - Installation request for symfony/console v5.1.2 -> satisfiable by symfony/console[v5.1.2].
    - symfony/console v5.1.2 requires php >=7.2.5 -> your PHP version (7.2.3) does not satisfy that requirement.
    Problem 4
    - Installation request for symfony/css-selector v5.1.2 -> satisfiable by symfony/css-selector[v5.1.2].
    - symfony/css-selector v5.1.2 requires php >=7.2.5 -> your PHP version (7.2.3) does not satisfy that requirement.
    Problem 5
    - Installation request for symfony/error-handler v5.1.2 -> satisfiable by symfony/error-handler[v5.1.2].
    - symfony/error-handler v5.1.2 requires php >=7.2.5 -> your PHP version (7.2.3) does not satisfy that requirement.
    Problem 6
    - Installation request for symfony/event-dispatcher v5.1.2 -> satisfiable by symfony/event-dispatcher[v5.1.2].
    - symfony/event-dispatcher v5.1.2 requires php >=7.2.5 -> your PHP version (7.2.3) does not satisfy that requirement.
    Problem 7
    - Installation request for symfony/event-dispatcher-contracts v2.1.2 -> satisfiable by symfony/event-dispatcher-contracts[v2.1.2].
    - symfony/event-dispatcher-contracts v2.1.2 requires php >=7.2.5 -> your PHP version (7.2.3) does not satisfy that requirement.
    Problem 8
    - Installation request for symfony/finder v5.1.2 -> satisfiable by symfony/finder[v5.1.2].
    - symfony/finder v5.1.2 requires php >=7.2.5 -> your PHP version (7.2.3) does not satisfy that requirement.
    Problem 9
    - Installation request for symfony/http-foundation v5.1.2 -> satisfiable by symfony/http-foundation[v5.1.2].
    - symfony/http-foundation v5.1.2 requires php >=7.2.5 -> your PHP version (7.2.3) does not satisfy that requirement.
    Problem 10
    - Installation request for symfony/http-kernel v5.1.2 -> satisfiable by symfony/http-kernel[v5.1.2].
    - symfony/http-kernel v5.1.2 requires php >=7.2.5 -> your PHP version (7.2.3) does not satisfy that requirement.
    Problem 11
    - Installation request for symfony/mime v5.1.2 -> satisfiable by symfony/mime[v5.1.2].
    - symfony/mime v5.1.2 requires php >=7.2.5 -> your PHP version (7.2.3) does not satisfy that requirement.
    Problem 12
    - Installation request for symfony/process v5.1.2 -> satisfiable by symfony/process[v5.1.2].
    - symfony/process v5.1.2 requires php >=7.2.5 -> your PHP version (7.2.3) does not satisfy that requirement.
    Problem 13
    - Installation request for symfony/routing v5.1.2 -> satisfiable by symfony/routing[v5.1.2].
    - symfony/routing v5.1.2 requires php >=7.2.5 -> your PHP version (7.2.3) does not satisfy that requirement.
    Problem 14
    - Installation request for symfony/service-contracts v2.1.2 -> satisfiable by symfony/service-contracts[v2.1.2].
    - symfony/service-contracts v2.1.2 requires php >=7.2.5 -> your PHP version (7.2.3) does not satisfy that requirement.
    Problem 15
    - Installation request for symfony/string v5.1.2 -> satisfiable by symfony/string[v5.1.2].
    - symfony/string v5.1.2 requires php >=7.2.5 -> your PHP version (7.2.3) does not satisfy that requirement.
    Problem 16
    - Installation request for symfony/translation v5.1.2 -> satisfiable by symfony/translation[v5.1.2].
    - symfony/translation v5.1.2 requires php >=7.2.5 -> your PHP version (7.2.3) does not satisfy that requirement.
    Problem 17
    - Installation request for symfony/translation-contracts v2.1.2 -> satisfiable by symfony/translation-contracts[v2.1.2].
    - symfony/translation-contracts v2.1.2 requires php >=7.2.5 -> your PHP version (7.2.3) does not satisfy that requirement.
    Problem 18
    - Installation request for symfony/var-dumper v5.1.2 -> satisfiable by symfony/var-dumper[v5.1.2].
    - symfony/var-dumper v5.1.2 requires php >=7.2.5 -> your PHP version (7.2.3) does not satisfy that requirement.
    Problem 19
    - Installation request for facade/ignition 2.0.7 -> satisfiable by facade/ignition[2.0.7].
    - facade/ignition 2.0.7 requires php ^7.2.5 -> your PHP version (7.2.3) does not satisfy that requirement.
    Problem 20
    - Installation request for mockery/mockery 1.4.0 -> satisfiable by mockery/mockery[1.4.0].
    - mockery/mockery 1.4.0 requires php ^7.3.0 -> your PHP version (7.2.3) does not satisfy that requirement.
    Problem 21
    - Installation request for nunomaduro/collision v4.2.0 -> satisfiable by nunomaduro/collision[v4.2.0].
    - nunomaduro/collision v4.2.0 requires php ^7.2.5 -> your PHP version (7.2.3) does not satisfy that requirement.
    Problem 22
    - symfony/http-foundation v5.1.2 requires php >=7.2.5 -> your PHP version (7.2.3) does not satisfy that requirement.
    - facade/flare-client-php 1.3.2 requires symfony/http-foundation ^3.3|^4.1|^5.0 -> satisfiable by symfony/http-foundation[v5.1.2].
    - Installation request for facade/flare-client-php 1.3.2 -> satisfiable by facade/flare-client-php[1.3.2].

    とメッセージがでます
    phpをバージョンアップして、7.2.5にするべきなのかなと考えまして
    調べた所、Linuxでphpをバージョンアップするのかとcentos8をインストールしたのですが
    そこでも迷子になり、前述の場所に戻って質問しようと戻ってきた感じです

    方向性あってますか?laravelのバージョンアップのために、visualboxインストールしてcentos8インストールしてdnfインストールしようとして躓いてしまって。そもそもが、もっと簡単なんじゃないかと思いまして。すいません、ご教授お願いします。

    キャンセル

  • 2020/07/13 02:50

    windows上で使いたいのかlinux上で使いたいのかはっきりしないと補足回答もできないと思われ

    キャンセル

  • 2020/07/13 02:56

    Windowsです
    すいませんlinuxは無知なものでよくわからず入り込んでしまいました

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.93%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る