質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.10%

ruby がすごい矛盾しているんですけど助けてください。。

受付中

回答 2

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 226

atage517

score 13

git push origin master


コマンドを実行すると以下のエラーが出ます。

Your Ruby version is 2.7.0, but your Gemfile specified 2.7.1


よって

vi gemfile.lock

vi gemfile

のなかみを

ruby 2.7.1 → ruby '2.7.0'


に変更し、bundle installをすると以下のエラーが出ます。

Your Ruby version is 2.7.1, but your Gemfile specified 2.7.0

そしてこのままもう一度

git push origin master

を実行するとなぜか以下のエラーが出ます。

Your Ruby version is 2.7.0, but your Gemfile specified 2.7.1


もうよくわかりません助けてください。。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • Daregada

    2020/06/30 23:01

    まずは「ruby --version」を実行して、実際のRubyのバージョンはいくつなのか調べ、われわれに示してください。

    キャンセル

  • atage517

    2020/06/30 23:04

    ruby -v
    ruby 2.7.0p0 (2019-12-25 revision 647ee6f091) [x86_64-darwin17]
    です gemfileも gemfile.lockも2,7,0に変更してあります。

    しかしなぜか your Gemfile specified 2.7.1 と出てしまいます

    キャンセル

  • Daregada

    2020/06/30 23:15

    なんでgemfile.lockを直接書き換えてしまうのか。

    キャンセル

  • atage517

    2020/06/30 23:21

    ダメなんですか?今回のエラーに関係あるんでしょうか

    キャンセル

回答 2

+1

2点 + 1点
1) 「なんでgemfile.lockを直接書き換えてしまうのか。
ダメなんですか?今回のエラーに関係あるんでしょうか」
ですがだめです。Gemfileを直し、bundle install してください。

2) git 実行して ruby のversionが顔を出すのはあまりにもおかしいです。
もしかして 生のgitが呼び出されていないのでhあ?という疑問。
which gitの結果をみせてください

3) ruby versionが思い通りにならない件の解決には全貌をもう少し把握が必要です以下を載せてください

  1. cat .ruby-version  の結果
  2. which ruby  の結果
  3. which bundle の結果
  4. grep "ruby " Gemfile  の結果
  5. echo $PATH  の結果
  6. 「bundle はちゃんと入っています」と判断したのはなにをもってか、それを説明してください

他にも有りますが、それは1,2,3,4の結果によって内容が変わるかもなのでそれを頂いてから。

追記
その結果からすると「ruby2.7.1がインストールされていたとしても」そのRAILSの環境で実行すると2.7.0が起動します。一番初めの「Your Ruby version is 2.7.0, 」と矛盾しないですね。
grep "ruby " Gemfile の結果が ruby '2.7.0' ということはその時のメッセージとは食い違いますが、それは「vi gemfileのなかみをruby 2.7.1 → ruby '2.7.0'」したからですね?
気になるのは Gemfileではなくgemfileになっていること。ここは入力ミス?

ん?
ここまで書いて疑問が。
最初にgit push する直前ですが、RAILSきちんと動いてましたか?
Gemfileが 2.7.1を要求し、 .ruby-versionで2.7.0を使うことを指示している。RAILSが立ち上がらなかったのではと思うのですが。

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2020/07/01 10:32

    そういえば bundle install した時にこのエラーが出てきたんですがこれが関係しているんでしょうか

    The dependency tzinfo-data (>= 0) will be unused by any of the platforms Bundler is installing for. Bundler is installing for ruby but the dependency is only for x86-mingw32, x86-mswin32, x64-mingw32, java. To add those platforms to the bundle, run `bundle lock --add-platform x86-mingw32 x86-mswin32 x64-mingw32 java`.


    bundle lock --add-platform x86-mingw32 x86-mswin32 x64-mingw32 java を実行したら以下のエラーも出ます。

    Fetching gem metadata from https://rubygems.org/............
    Writing lockfile to /Users/kaito/kaito_sample/Gemfile.lock
    Cannot write a changed lockfile while frozen.

    キャンセル

  • 2020/07/01 11:24

    今の状態で、RAILS立ち上がりますか?

    キャンセル

  • 2020/07/01 11:55

    rails のサーバーは立ち上がります。

    しかし、自分のrailsアプリを git push origin masterすると上のようなエラーが出ています。

    自分でも調べていますが原因が全くわかりません。

    キャンセル

0

bundlerが適切にインストールされていないのではないでしょうか?

参考:http://ztbuz.hateblo.jp/entry/2013/12/14/193235

検索キーワード:Your Ruby version is 2.7.0, but your Gemfile specified 2.7.1

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2020/06/30 23:15

    ありがとうございます。

    そのサイトも参考にしたんですけどね。 bundle はちゃんと入っています。そして bundle installは問題なく実行できますが。

    git push origin master を実行した時にエラーが表示されます

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.10%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る