質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.51%

  • Ruby

    9425questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails 4

    2542questions

    Ruby on Rails4はRubyによって書かれたオープンソースのウェブフレームワークです。 Ruby on Railsは「設定より規約」の原則に従っており、効率的に作業を行うために再開発を行う必要をなくしてくれます。

gem "google-api-client" ruby2.2.2 にてcannot load such file -- google/api_clientがでます。2.2.0なら動くのですが

受付中

回答 2

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 2,825

qaz3330

score 105

gem "google-api-client"

をruby2.2.2の環境下にて使用したいのですが、
表題の通りのエラーがでてしまいます。

(Rails 4.2.5)

ruby2.2.0なら問題ないのですが・・・。

調べていると、バージョン違いの問題な気がしており、以下のissueなどを参考に
gem 'google-api-client', '~> 0.7.1'
といったようにバージョンを変えて、色々と試しておりました。
https://github.com/google/google-api-ruby-client/issues/132

しかし未だに上手くいかず、困ってます。

bundle install自体はできるのですが、

bundle exec rails cの際にエラーが出てしまします。

/usr/local/var/rbenv/versions/2.2.2/lib/ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:in `require': cannot load such file -- bundler/setup (LoadError)

bundle exec irb より

require "google-api-client"

とすると表題のエラーがでます。

どなたかご助言いただけないでしょうか?
宜しくお願いします。

〜追記〜

Gemfileには以下のように記述しております。

gem 'google-api-client', require: 'google/api_client'
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

0

確か、このGemの読み込み方は特殊だった気がします。
以下はGoogleドライブの読み込みですが、どうでしょうか。
google/apis/サービス名_バージョン名だった気がします。

require 'google/apis'
 #もしくは
require 'google/apis/drive_v2'

サンプルソース

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/01/31 12:03

    ご回答有難う御座います。早速やってみたところ

    gem 'google/apis'
    gem 'google/apis/drive_v2'
    gem 'google-apis-drive_v2'
    gem 'google/apis/calendar_v3'
    gem 'google-apis-calendar_v3'
    の場合

    Could not find gem 'google-apis-calendar_v2' in any of the gem sources listed in your Gemfile or available on this machine.

    とエラーがでで、gemが見つかりませんでした。

    gem 'google-apis'

    だと、bundle installは成功したものの以下のエラーでした。
    /usr/local/var/rbenv/versions/2.2.2/lib/ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:in `require': cannot load such file -- bundler/setup (LoadError)


    キャンセル

  • 2016/08/03 13:49

    gemではなくrequire: 'google/apis'だと思います

    キャンセル

0

google-api-clientのバージョンアップにより、古いバージョンと互換性が無くなっています。

Migrating from 0.8.x
  Version 0.9 is not compatible with previous versions. See MIGRATING for additional details on how to migrate to the latest version.

とりあえずは、バージョン0.8をインストールして、そちらを使えば良いかと。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/01/31 12:07

    ご回答有難う御座います。
    以下のパターンで色々と試したのですが、結局うまくインストール出来ませんでした。
    (bundle install自体は成功するものの表題のエラーがでます。)


    gem 'google-api-client', '~>0.8.2', require: 'google/api_client'
    gem 'google-api-client', '~>0.8', require: 'google/api_client'
    gem 'google-api-client', '0.8', require: 'google/api_client'
    gem 'google-api-client', '0.8.2', require: 'google/api_client'

    キャンセル

  • 2016/01/31 16:26

    わたしの所では、下記でうまくいってます。
    gem 'google-api-client', '0.7'
    require 'google/api_client'
    # 0.7を使ってます。

    キャンセル

同じタグがついた質問を見る

  • Ruby

    9425questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails 4

    2542questions

    Ruby on Rails4はRubyによって書かれたオープンソースのウェブフレームワークです。 Ruby on Railsは「設定より規約」の原則に従っており、効率的に作業を行うために再開発を行う必要をなくしてくれます。

  • トップ
  • Rubyに関する質問
  • gem "google-api-client" ruby2.2.2 にてcannot load such file -- google/api_clientがでます。2.2.0なら動くのですが