質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.37%

Arduino IDEエラー解消方法 JAVAエラー?

解決済

回答 2

投稿

  • 評価
  • クリップ 0
  • VIEW 2,686

score 4

前提・実現したいこと

Arduino UNO R3 初めてのLチカを実現したい。
Arduino 1.8.10 IDE Blinkでいきなりエラーでつまずく。

発生している問題・エラーメッセージ

processing.app.debug.RunnerException
    at cc.arduino.Compiler.callArduinoBuilder(Compiler.java:317)
    at cc.arduino.Compiler.loadPreferences(Compiler.java:216)
    at cc.arduino.Compiler.build(Compiler.java:175)
    at processing.app.SketchController.build(SketchController.java:664)
    at processing.app.SketchController.exportApplet(SketchController.java:689)
    at processing.app.Editor$UploadHandler.run(Editor.java:2075)
    at java.lang.Thread.run(Thread.java:748)
Caused by: java.io.IOException: Cannot run program "C:\Users\dellservice\Desktop\Arduino UNO R3 Starter kit\arduino-1.8.10\arduino-builder": CreateProcess error=2, The system cannot find the file specified
    at java.lang.ProcessBuilder.start(ProcessBuilder.java:1048)
    at processing.app.helpers.ProcessUtils.exec(ProcessUtils.java:26)
    at cc.arduino.Compiler.callArduinoBuilder(Compiler.java:297)
    ... 6 more
Caused by: java.io.IOException: CreateProcess error=2, The system cannot find the file specified
    at java.lang.ProcessImpl.create(Native Method)
    at java.lang.ProcessImpl.<init>(ProcessImpl.java:386)
    at java.lang.ProcessImpl.start(ProcessImpl.java:137)
    at java.lang.ProcessBuilder.start(ProcessBuilder.java:1029)
    ... 8 more

該当のソースコード

// the setup function runs once when you press reset or power the board
void setup() {
  // initialize digital pin LED_BUILTIN as an output.
  pinMode(LED_BUILTIN, OUTPUT);
}

// the loop function runs over and over again forever
void loop() {
  digitalWrite(LED_BUILTIN, HIGH);   // turn the LED on (HIGH is the voltage level)
  delay(1000);                       // wait for a second
  digitalWrite(LED_BUILTIN, LOW);    // turn the LED off by making the voltage LOW
  delay(1000);                       // wait for a second
}

試したこと

IDEのインストールに失敗したと思い、Windows Installer, for Windows XP and upをアンインストールし、Windows ZIP file for non admin installを試すも同じ症状。
(また保存先もC直下にしてみましたがそれでもダメ)
別のPCでトライしても同じ。
JAVAの最新に更新しても改善されず。

補足情報(FW/ツールのバージョンなど)

WIN8.1
Arduino1.8.10
Arduino /Genuino UNO

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

check解決した方法

0

解決ではありませんが、WIN10のPCで試したところ問題なく使用できました。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

0

C:\Users\dellservice\Desktop\Arduino UNO R3 Starter kit\arduino-1.8.10\arduino-builder

全角文字や空白を含むパス名にちょっとあやうさを感じます。

保存先もC直下にしてみましたが
これはC:\Arduino-1.8.10\と配置して、ここからArduino.exeを起動した、という意味でしょうか。であれば上記はハズレということになりますが...

それと、UNOでは関係ないかも知れませんが、C:\Users\dellservice\AppData\Local\Arduino15以下にもファイルがいろいろ出来ていると思います。完全にアンインストールするときにはここも消さないと駄目なときがあります。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/11/01 15:41

    コメントありがとうございます。

    別のPCにインストールしてみましたが、同じ状態です。
    UNO自体に問題があるかと思い買い直し、先ほど試してみましたがやはり同じです。。。
    (1個目のUNOは中国製で2個目はイタリー製です)

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.37%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る