質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.38%

UnityでのAndroid SDK参照バージョン

解決済

回答 2

投稿

  • 評価
  • クリップ 0
  • VIEW 793

score 7

Unity2018でplay-services-adsのバージョンを17.2.0に上げると
ビルド時に「Select Android SDK directory」のダイアログが表示されるようになりました。
バージョンを上げる前だと問題なく動作しています、Android SDKのリンク先のバージョンを
変更するなどの対応が必要になりますでしょうか?

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

check解決した方法

0

SDKtoolsのバージョンを25.0.2にすることで解決しました。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

0

>Unity2018でplay-services-ads

AdMobを入れようとしているのでしょうか?
Google Mobile Ads Unity Pluginを入れた方がいいでしょう

バージョンを17.2.0

AndroidではAndroidManifest.xml に meta-dataの設定が必要です

>Android SDKのリンク先のバージョン

当然ライブラリーのバージョンはSDKのバージョンに紐づいているので
Android Studioでは赤線になる(ビルドはできるかもしれないけれど正しく動作するかは?)

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/08/29 15:37

    GoogleMobileAds.unitypackageの最新をインポートしましたが、依存関係が解決されず同様に「Select Android SDK directory」のダイアログが表示されます。
    エラーメッセージを確認するとJava8が必要なようですが、JDKの参照はjdk1.8.0になっています。
    SDKのバージョンを更新する必要がありますでしょうか。
    何か分かることがありましたら、ご教授お願いいたします。

    キャンセル

  • 2019/08/29 15:42 編集

    >SDKのバージョンを更新する必要がありますでしょうか。

    それで、バージョンはいくつでしょう
    エラーからしてそれを最初に試して見ては
    もしかして、SDKがどうなっているかわからないのでは?

    キャンセル

  • 2019/08/30 00:28 編集

    >25.0.2
    大昔のやり方では?
    それに、
    August 2019: New apps are required to target API level 28 (Android 9) or higher
    https://android-developers.googleblog.com/2019/02/expanding-target-api-level-requirements.html

    キャンセル

  • 2019/09/03 11:05

    ツールバージョンは25.0.2ですが、SDKのAPIレベルは28にアップしています。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.38%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る