質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
85.44%
Raspbian

Raspbianは、DebianベースのRaspberry Pi用ディストリビューション。ハードウェア浮動小数点演算を有効にすることが可能で、Webブラウズなどの速度を向上できます。

Linux

Linuxは、Unixをベースにして開発されたオペレーティングシステムです。日本では「リナックス」と呼ばれています。 主にWebサーバやDNSサーバ、イントラネットなどのサーバ用OSとして利用されています。 上位500のスーパーコンピュータの90%以上はLinuxを使用しています。 携帯端末用のプラットフォームAndroidは、Linuxカーネル上に構築されています。

Raspberry Pi

Raspberry Piは、ラズベリーパイ財団が開発した、名刺サイズのLinuxコンピュータです。 学校で基本的なコンピュータ科学の教育を促進することを意図しています。

Q&A

1回答

12251閲覧

pi zeroでaptを使ったinstall等ができない

issa06

総合スコア12

Raspbian

Raspbianは、DebianベースのRaspberry Pi用ディストリビューション。ハードウェア浮動小数点演算を有効にすることが可能で、Webブラウズなどの速度を向上できます。

Linux

Linuxは、Unixをベースにして開発されたオペレーティングシステムです。日本では「リナックス」と呼ばれています。 主にWebサーバやDNSサーバ、イントラネットなどのサーバ用OSとして利用されています。 上位500のスーパーコンピュータの90%以上はLinuxを使用しています。 携帯端末用のプラットフォームAndroidは、Linuxカーネル上に構築されています。

Raspberry Pi

Raspberry Piは、ラズベリーパイ財団が開発した、名刺サイズのLinuxコンピュータです。 学校で基本的なコンピュータ科学の教育を促進することを意図しています。

0グッド

0クリップ

投稿2019/07/18 13:02

aptを使ってinstall等を行うとdpkgがエラーを吐き出してしまい、実行できません。解決策を教えていただきたいです。
※updateは実行済です。

例: sudo apt upgrade を実行

pi@raspberrypi:~ $ sudo apt upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
debconf : PreDepends: perl-base (>= 5.20.1-3~) but it is not installed
init-system-helpers : Depends: perl-base (>= 5.20.1-3) but it is not installed
liblocale-gettext-perl : PreDepends: perl-base (>= 5.28.0-3) but it is not installed
libtext-charwidth-perl : Depends: perl-base (>= 5.28.0-3) but it is not installed
libtext-iconv-perl : Depends: perl-base (>= 5.28.0-3) but it is not installed
perl : Depends: perl-base (= 5.28.1-6) but it is not installed
perl-modules-5.28 : Depends: perl-base (>= 5.28.1-1) but it is not installed
tasksel : Depends: perl-base (>= 5.14.0-1) but it is not installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

気になる質問をクリップする

クリップした質問は、後からいつでもMYページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

guest

回答1

0

issa06さん、

エラーメッセージで、

You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:

(グーグル翻訳)

これらを修正するために 'apt --fix-broken install'を実行することをお勧めします。
以下のパッケージは、満たされていない依存関係を持っています:

なので、とりあえず、↓でしょうか

sudo apt --fix-broken install

投稿2019/07/18 16:08

mt08

総合スコア1825

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

issa06

2019/07/22 23:30

返事が送れてすみません。 実行しようとしたのですが、dpkgがエラー(2)を吐いてしまい、できませんでした。
coco_bauer

2019/07/23 02:02

「init-system-helpers : Depends: perl-base (>= 5.20.1-3) but it is not installed」 というようなエラーメッセージが多数出ていますが、これは各モジュールが perl-baseと依存関係があるのに、必要なバージョンの perl-base がインストールされていないので、依存関係が満たせないためです。 必要なバージョンの perl-base をインストールすると状況が改善するのではないでしょうか。
coco_bauer

2019/07/23 02:08

あるいは、追加で新規のパッケージが必要になればインストールしてくれる  $ sudo apt-get dist-upgrade を試してみるのも良いと思います。
guest

あなたの回答

tips

太字

斜体

打ち消し線

見出し

引用テキストの挿入

コードの挿入

リンクの挿入

リストの挿入

番号リストの挿入

表の挿入

水平線の挿入

プレビュー

まだベストアンサーが選ばれていません

会員登録して回答してみよう

アカウントをお持ちの方は

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
85.44%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問